Merge branch 'wip-glib' into master.

Conflicts:
	gnu/packages/package-management.scm
master
Andreas Enge 2015-04-26 16:05:39 +02:00
commit 003e8d5e04
8 changed files with 59 additions and 115 deletions

View File

@ -36,7 +36,7 @@
(define-public cups-filters
(package
(name "cups-filters")
(version "1.0.61")
(version "1.0.68")
(source (origin
(method url-fetch)
(uri
@ -44,7 +44,7 @@
"cups-filters-" version ".tar.xz"))
(sha256
(base32
"1bq48nnrarlbf6qc93bz1n5wlh6j420gppbck3r45sinwhz5wa7m"))
"0dx4assqzqdi0q4j7z5s7xzzvzxnd5c1njd9139a1h353qrcr5fi"))
(modules '((guix build utils)))
(snippet
;; install backends, banners and filters to cups-filters output

View File

@ -207,14 +207,14 @@ dynamic loading, and an object system.")
(define gobject-introspection
(package
(name "gobject-introspection")
(version "1.42.0")
(version "1.44.0")
(source (origin
(method url-fetch)
(uri (string-append "http://ftp.gnome.org/pub/GNOME/sources/"
(uri (string-append "mirror://gnome/sources/"
"gobject-introspection/" (version-major+minor version)
"/gobject-introspection-" version ".tar.xz"))
(sha256
(base32 "1xwm7wmr9r9wp6xljb3bckx3a4siybavaq39w46ly7gpskxfv8iv"))
(base32 "1b972qg2yb51sdavfvb6kc19akwc15c1bwnbg81vadxamql2q33g"))
(patches (list
(search-patch "gobject-introspection-cc.patch")
(search-patch
@ -243,14 +243,7 @@ dynamic loading, and an object system.")
(arguments
`(;; The patch 'gobject-introspection-absolute-shlib-path.patch' causes
;; some tests to fail.
#:tests? #f
#:phases
(alist-cons-before
'configure 'patch-paths
(lambda _
(substitute* "giscanner/sourcescanner.py"
(("GUIX_GCC_PATH") (which "gcc"))))
%standard-phases)))
#:tests? #f))
(home-page "https://wiki.gnome.org/GObjectIntrospection")
(synopsis "Generate interface introspection data for GObject libraries")
(description
@ -313,14 +306,14 @@ The intltool collection can be used to do these things:
(define itstool
(package
(name "itstool")
(version "1.2.0")
(version "2.0.2")
(source (origin
(method url-fetch)
(uri (string-append "http://files.itstool.org/itstool/itstool-"
version ".tar.bz2"))
(sha256
(base32
"1akq75aflihm3y7js8biy7b5mw2g11vl8yq90gydnwlwp0zxdzj6"))))
"0fh34wi52i0qikgvlmrcpf1vx6gc1xqdad4539l4d9hikfsrz45z"))))
(build-system gnu-build-system)
(propagated-inputs
`(("libxml2" ,libxml2)
@ -350,7 +343,7 @@ translated.")
(define dbus-glib
(package
(name "dbus-glib")
(version "0.102")
(version "0.104")
(source (origin
(method url-fetch)
(uri
@ -358,7 +351,7 @@ translated.")
version ".tar.gz"))
(sha256
(base32
"177j5p2vrvpmzk2xrrj6akn73kvpbvnmsjvlmca9l55qbdcfsr39"))))
"1xi1v1msz75qs0s4lkyf1psrksdppa3hwkg0mznc6gpw5flg3hdz"))))
(build-system gnu-build-system)
(inputs
`(("dbus" ,dbus)
@ -377,14 +370,15 @@ by GDBus included in Glib.")
(define libsigc++
(package
(name "libsigc++")
(version "2.3.1")
(version "2.4.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/libsigc++/2.3/libsigc++-"
version ".tar.xz"))
(uri (string-append "mirror://gnome/sources/libsigc++/"
(version-major+minor version) "/"
name "-" version ".tar.xz"))
(sha256
(base32
"14q3sq6d43f6wfcmwhw4v1aal4ba0h5x9v6wkxy2dnqznd95il37"))))
"1v0rvkzglzmf67y9nkcppwjwi68j1cy5yhldvcq7xrv8594l612l"))))
(build-system gnu-build-system)
(native-inputs `(("pkg-config" ,pkg-config)
("m4" ,m4)))
@ -403,7 +397,7 @@ has an ease of use unmatched by other C++ callback libraries.")
(define glibmm
(package
(name "glibmm")
(version "2.42.0")
(version "2.44.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/glibmm/"
@ -411,7 +405,7 @@ has an ease of use unmatched by other C++ callback libraries.")
"/glibmm-" version ".tar.xz"))
(sha256
(base32
"15rk3az8jh3rdwlc3lxjljbnh60drj3ka9574zd39lkqfgcq6l4q"))))
"1a1fczy7hcpn24fglyn4i79f4yjc8s50is70q03mb294bm1c02hv"))))
(build-system gnu-build-system)
(arguments
`(#:phases (alist-cons-before
@ -485,8 +479,7 @@ useful for C++.")
(define-public python-pygobject
(package
(name "python-pygobject")
(version "3.12.2") ;last version that works with
;gobject-introspection 1.38
(version "3.16.1")
(source
(origin
(method url-fetch)
@ -495,8 +488,7 @@ useful for C++.")
"/pygobject-" version ".tar.xz"))
(sha256
(base32
"08m5yad1hjdax4g39w6lgjk4124mcwpa8fc5iyvb8nygk8s3syky"))))
;; 3.14.0: 0m1d75iwxa6k1xbkn6c6yq5r10pxnf7i5c2a5yvwsnab7ylzz7kp
"1hqyma73w0lnjcgx68kawhnq84aq92xlkdqphrlc2ppia38dm5kx"))))
(build-system gnu-build-system)
(native-inputs
`(("which" ,which)
@ -549,14 +541,6 @@ useful for C++.")
(base32
"1symyzbjmxvksn2ifdkk50lafjm2llf2sbmky062gq2pz3cg23cy"))))
(build-system gnu-build-system)
(arguments
'(#:phases (alist-cons-before
'build 'set-cc
(lambda _
;; Set $CC so that g-ir-scanner works.
(setenv "CC" "gcc")
#t)
%standard-phases)))
(native-inputs
`(("glib" ,glib "bin") ; uses glib-mkenums
("pkg-config" ,pkg-config)

View File

@ -499,13 +499,6 @@ some form of information without getting in the user's way.")
("glib:bin" ,glib "bin")
("gobject-introspection" ,gobject-introspection)
("intltool" ,intltool)))
(arguments
`(#:phases
(alist-cons-before
'build 'pre-build
(lambda* _
(setenv "CC" "gcc"))
%standard-phases)))
(home-page "https://wiki.gnome.org/Libpeas")
(synopsis "GObject plugin system")
(description
@ -675,11 +668,7 @@ dealing with different structured file formats.")
(string-join (find-files (assoc-ref inputs "gdk-pixbuf")
"libpixbufloader-.*\\.so") " ")
"> " loaders-directory ".cache")))))
(alist-cons-before
'build 'pre-build
(lambda* _
(setenv "CC" "gcc"))
%standard-phases)))))
%standard-phases))))
(native-inputs
`(("pkg-config" ,pkg-config)
("glib" ,glib "bin") ; glib-mkenums, etc.
@ -1385,7 +1374,7 @@ engineering.")
(define-public vala
(package
(name "vala")
(version "0.26.1")
(version "0.28.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@ -1393,9 +1382,15 @@ engineering.")
name "-" version ".tar.xz"))
(sha256
(base32
"0swyym2papln0f62ah05dpvq3vv6fssap26jq2zqp9dkkaqsn1w4"))))
"0zwpzhkhfk3piya14m7p2hl2vaabahprphppfm46ci91z39kp7hd"))))
(build-system gnu-build-system)
(arguments '(#:make-flags '("CC=gcc")))
(arguments
'(#:phases
(modify-phases %standard-phases
(add-before 'check 'set-cc
(lambda _
(setenv "CC" "gcc")
#t)))))
(native-inputs
`(("pkg-config" ,pkg-config)
("flex" ,flex)
@ -1437,13 +1432,6 @@ libraries written in C.")
(propagated-inputs
`(("gtk+" ,gtk+) ;required by vte-2.91.pc
("gnutls" ,gnutls))) ;ditto
(arguments
`(#:phases
(alist-cons-before
'build 'pre-build
(lambda* _
(setenv "CC" "gcc"))
%standard-phases)))
(home-page "http://www.gnome.org/")
(synopsis "Virtual Terminal Emulator")
(description
@ -1542,14 +1530,6 @@ configuration storage systems.")
(base32
"02k66lpc4cmgygj66n8zcy59bggy7yzm3v4hni9xqplgva9d2yw8"))))
(build-system gnu-build-system)
(arguments
'(#:phases (alist-cons-before
'build 'set-cc
(lambda _
;; Set $CC so that g-ir-scanner works.
(setenv "CC" "gcc")
#t)
%standard-phases)))
(native-inputs
`(("glib" ,glib "bin") ;for glib-mkenums and glib-genmarshal
("gobject-introspection" ,gobject-introspection)
@ -1581,13 +1561,7 @@ JSON, such as arrays and objects.")
'(#:configure-flags
(list (string-append "--with-xkb-base="
(assoc-ref %build-inputs "xkeyboard-config")
"/share/X11/xkb"))
#:phases
(alist-cons-before
'build 'set-cc
(lambda _
(setenv "CC" "gcc")) ; for g-ir-scanner.
%standard-phases)))
"/share/X11/xkb"))))
(native-inputs
`(("glib:bin" ,glib "bin") ; for glib-mkenums, etc.
("gobject-introspection" ,gobject-introspection)
@ -1698,8 +1672,7 @@ library.")
(build-system gnu-build-system)
(outputs '("out" "doc"))
(arguments
`(#:make-flags '("CC=gcc") ; for g-ir-scanner
#:configure-flags
`(#:configure-flags
(list (string-append "--with-html-dir="
(assoc-ref %outputs "doc")
"/share/gtk-doc/html")
@ -1762,7 +1735,6 @@ and the GLib main loop, to integrate well with GNOME applications.")
(outputs '("out" "doc"))
(arguments
`(#:tests? #f ; FIXME: Testing hangs.
#:make-flags '("CC=gcc") ; for g-ir-scanner.
#:configure-flags
(list (string-append "--with-html-dir="
(assoc-ref %outputs "doc")
@ -1926,12 +1898,7 @@ keyboard shortcuts.")
(("/bin/true") (which "true")))
(substitute* "src/Makefile.in"
(("if test -w \\$\\(DESTDIR\\)\\$\\(prefix\\)/;")
"if test -w $(DESTDIR)$(localstatedir);"))))
(add-before 'build 'set-cc
(lambda _
;; Set $CC so that g-ir-scanner works.
(setenv "CC" "gcc")
#t)))))
"if test -w $(DESTDIR)$(localstatedir);")))))))
(native-inputs
`(("pkg-config" ,pkg-config)
("gobject-introspection" ,gobject-introspection)
@ -2015,7 +1982,6 @@ permission from user. ")
`(;; The tests want to write to $HOME/.cache/geocode-glib, which doesn't
;; work for the builder. Punt.
#:tests? #f
#:make-flags '("CC=gcc") ; for g-ir-scanner
))
(native-inputs
`(("glib:bin" ,glib "bin") ; for glib-mkenums
@ -2103,7 +2069,6 @@ service via the system message bus.")
`(;; The tests want to write to $HOME/.cache/geocode-glib, which doesn't
;; work for the builder. Punt.
#:tests? #f
#:make-flags '("CC=gcc") ; for g-ir-scanner
#:configure-flags
`(;; No introspection for now, as it wants to install to
;; gobject-introspection's own directory and I don't know how to easily

View File

@ -353,8 +353,7 @@ in the GNOME project.")
(build-system gnu-build-system)
(outputs '("out" "doc"))
(arguments
'(#:make-flags '("CC=gcc") ; for g-ir-scanner
#:configure-flags
'(#:configure-flags
(list (string-append "--with-html-dir="
(assoc-ref %outputs "doc")
"/share/gtk-doc/html"))
@ -450,8 +449,7 @@ is part of the GNOME accessibility project.")
("pkg-config" ,pkg-config)
("python-wrapper" ,python-wrapper)))
(arguments
`(#:make-flags '("CC=gcc")
#:configure-flags
`(#:configure-flags
(list "--with-xinput=yes"
(string-append "--with-html-dir="
(assoc-ref %outputs "doc")
@ -476,7 +474,7 @@ application suites.")
(define-public gtk+
(package (inherit gtk+-2)
(name "gtk+")
(version "3.16.0")
(version "3.16.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@ -484,7 +482,7 @@ application suites.")
name "-" version ".tar.xz"))
(sha256
(base32
"1si6ihl1wlvag8qq3166skr9fnm9i33dimbfry1j628qzqc76qff"))))
"1yhwg2l72l3khfkprydcjlpxjrg11ccqfc80sjl56llz3jk66fd0"))))
(propagated-inputs
`(("at-spi2-atk" ,at-spi2-atk)
("atk" ,atk)
@ -626,7 +624,7 @@ library.")
(define-public pangomm
(package
(name "pangomm")
(version "2.34.0")
(version "2.36.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@ -634,7 +632,7 @@ library.")
name "-" version ".tar.xz"))
(sha256
(base32
"0hcyvv7c5zmivprdam6cp111i6hn2y5jsxzk00m6j9pncbzvp0hf"))))
"1w11d05nkxglzg67rfa81vqghm75xhy6j396xmmp5mq8qx96knd8"))))
(build-system gnu-build-system)
(native-inputs `(("pkg-config" ,pkg-config)))
(propagated-inputs
@ -675,7 +673,7 @@ toolkit.")
(define-public gtkmm
(package
(name "gtkmm")
(version "3.14.0")
(version "3.16.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@ -683,7 +681,7 @@ toolkit.")
name "-" version ".tar.xz"))
(sha256
(base32
"12z4g2in82nk92nfjs2hmrdcwbav8v3laz1813x2dhkf5jk2ixfr"))))
"036xn22jkaf3akpid7w23b8vkqa3xxqz93mwacmyar5vw7slm3cv"))))
(build-system gnu-build-system)
(native-inputs `(("pkg-config" ,pkg-config)))
(propagated-inputs
@ -707,7 +705,7 @@ extensive documentation, including API reference and a tutorial.")
(define-public gtkmm-2
(package (inherit gtkmm)
(name "gtkmm")
(version "2.24.2")
(version "2.24.4")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@ -715,7 +713,7 @@ extensive documentation, including API reference and a tutorial.")
name "-" version ".tar.xz"))
(sha256
(base32
"0gcm91sc1a05c56kzh74l370ggj0zz8nmmjvjaaxgmhdq8lpl369"))))
"1vpmjqv0aqb1ds0xi6nigxnhlr0c74090xzi15b92amlzkrjyfj4"))))
(propagated-inputs
`(("pangomm" ,pangomm)
("cairomm" ,cairomm)

View File

@ -26,13 +26,13 @@
(define-public libidn
(package
(name "libidn")
(version "1.29")
(version "1.30")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/libidn/libidn-" version
".tar.gz"))
(sha256 (base32
"0z3w5arlvyiyvzg76msg3n2px3c1glqr6wnj7rq6zczrpdyp90pv"))))
"0lxh5r1z8gsk4jxx3rv8aasjv8p53j4y04kvfn2w30a0syagrf9r"))))
(build-system gnu-build-system)
;; FIXME: No Java and C# libraries are currently built.
(synopsis "Internationalized string processing library")

View File

@ -1,14 +1,11 @@
--- a/giscanner/sourcescanner.py 2013-12-15 23:03:54.002937000 +0100
+++ b/giscanner/sourcescanner.py 2013-12-15 23:04:50.322937000 +0100
@@ -277,6 +277,11 @@
defines = ['__GI_SCANNER__']
undefs = []
cpp_args = os.environ.get('CC', 'cc').split() # support CC="ccache gcc"
+ if (cpp_args == ['cc'] and
+ not any(map(lambda x: os.access(os.path.join(x, 'cc'), os.X_OK),
+ os.environ.get('PATH').split(':')))):
+ cpp_args = ['GUIX_GCC_PATH']
+
if 'cl' in cpp_args:
# The Microsoft compiler/preprocessor (cl) does not accept
# source input from stdin (the '-' flag), so we need
Use gcc as the default C compiler if CC is not set.
--- gobject-introspection-1.44.0.orig/giscanner/__init__.py 2014-08-04 22:37:07.000000000 +0800
+++ gobject-introspection-1.44.0/giscanner/__init__.py 2015-04-20 17:30:26.507697234 +0800
@@ -22,3 +22,5 @@
builddir = os.environ.get('UNINSTALLED_INTROSPECTION_BUILDDIR')
if builddir is not None:
__path__.append(os.path.join(builddir, 'giscanner'))
+if not 'CC' in os.environ:
+ os.environ['CC'] = 'gcc'

View File

@ -50,13 +50,13 @@
(define-public poppler
(package
(name "poppler")
(version "0.28.1")
(version "0.32.0")
(source (origin
(method url-fetch)
(uri (string-append "http://poppler.freedesktop.org/poppler-"
version ".tar.xz"))
(sha256 (base32
"01pxjdbhvpxf00ncf8d9wxc8gkcqcxz59lwrpa151ah988inxkrc"))))
"162vfbvbz0frvqyk00ldsbl49h4bj8i8wn0ngfl30xg1lldy6qs9"))))
(build-system gnu-build-system)
;; FIXME: more dependencies could be added
;; cairo output: no (requires cairo >= 1.10.0)

View File

@ -4301,7 +4301,7 @@ graphics cards.")
(define-public libxfont
(package
(name "libxfont")
(version "1.5.0")
(version "1.5.1")
(source
(origin
(method url-fetch)
@ -4311,7 +4311,7 @@ graphics cards.")
".tar.bz2"))
(sha256
(base32
"0py2c498lrq6wrj9al6nj57v2ypid9cz0zzhc0hjndgrmp254g1s"))))
"1630v3sfvwwlimb2ja10c84ql6v1mw9bdfhvan7pbybkgi99h25p"))))
(build-system gnu-build-system)
(propagated-inputs
`(("fontsproto" ,fontsproto)