gnu: bowtie: Update to 2.2.6.

* gnu/packages/bioinformatics.scm (bowtie): Update to 2.2.6.
[source]: Remove patch; do not set CC and CPP variables.
[inputs]: Add "tbb".
[arguments]: Pass "prefix" and "WITH_TBB" make flags; remove custom
"install" phase.
* gnu/packages/patches/bowtie-fix-makefile.patch: Remove file.
* gnu-system.am (dist_patch_DATA): Remove patch file.
This commit is contained in:
Ricardo Wurmus 2016-01-14 14:36:32 +01:00
parent 2d12284d38
commit 0047d26a22
3 changed files with 16 additions and 54 deletions

View File

@ -416,7 +416,6 @@ dist_patch_DATA = \
gnu/packages/patches/avidemux-install-to-lib.patch \
gnu/packages/patches/avrdude-fix-libusb.patch \
gnu/packages/patches/bash-completion-directories.patch \
gnu/packages/patches/bowtie-fix-makefile.patch \
gnu/packages/patches/bigloo-gc-shebangs.patch \
gnu/packages/patches/binutils-ld-new-dtags.patch \
gnu/packages/patches/binutils-loongson-workaround.patch \

View File

@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2015 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2014, 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015, 2016 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2015 Pjotr Prins <pjotr.guix@thebird.nl>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
@ -603,7 +603,7 @@ errors at the end of reads.")
(define-public bowtie
(package
(name "bowtie")
(version "2.2.4")
(version "2.2.6")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/BenLangmead/bowtie2/archive/v"
@ -611,42 +611,36 @@ errors at the end of reads.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
"15dnbqippwvhyh9zqjhaxkabk7lm1xbh1nvar1x4b5kwm117zijn"))
"1ssfvymxfrap6f9pf86s9bvsbqdgka4abr2r7j3mgr4w1l289m86"))
(modules '((guix build utils)))
(snippet
'(substitute* "Makefile"
(("^CC = .*$") "CC = gcc")
(("^CPP = .*$") "CPP = g++")
;; replace BUILD_HOST and BUILD_TIME for deterministic build
(("-DBUILD_HOST=.*") "-DBUILD_HOST=\"\\\"guix\\\"\"")
(("-DBUILD_TIME=.*") "-DBUILD_TIME=\"\\\"0\\\"\"")))
(patches (list (search-patch "bowtie-fix-makefile.patch")))))
(("-DBUILD_TIME=.*") "-DBUILD_TIME=\"\\\"0\\\"\"")))))
(build-system gnu-build-system)
(inputs `(("perl" ,perl)
("perl-clone" ,perl-clone)
("perl-test-deep" ,perl-test-deep)
("perl-test-simple" ,perl-test-simple)
("python" ,python-2)))
("python" ,python-2)
("tbb" ,tbb)))
(arguments
'(#:make-flags '("allall")
'(#:make-flags
(list "allall"
"WITH_TBB=1"
(string-append "prefix=" (assoc-ref %outputs "out")))
#:phases
(alist-delete
'configure
(alist-replace
'install
'check
(lambda* (#:key outputs #:allow-other-keys)
(let ((bin (string-append (assoc-ref outputs "out") "/bin/")))
(for-each (lambda (file)
(install-file file bin))
(find-files "." "bowtie2.*"))))
(alist-replace
'check
(lambda* (#:key outputs #:allow-other-keys)
(system* "perl"
"scripts/test/simple_tests.pl"
"--bowtie2=./bowtie2"
"--bowtie2-build=./bowtie2-build"))
%standard-phases)))))
(system* "perl"
"scripts/test/simple_tests.pl"
"--bowtie2=./bowtie2"
"--bowtie2-build=./bowtie2-build"))
%standard-phases))))
(home-page "http://bowtie-bio.sourceforge.net/bowtie2/index.shtml")
(synopsis "Fast and sensitive nucleotide sequence read aligner")
(description

View File

@ -1,31 +0,0 @@
From 4a99b0023bdfbbe486b9649489a32ea184c18c9a Mon Sep 17 00:00:00 2001
From: Valentin Antonescu <valentin@jhu.edu>
Date: Tue, 2 Dec 2014 11:19:13 -0500
Subject: [PATCH] Make sure the Mavericks test happens only under Darwin.
---
Makefile | 11 +++++------
1 file changed, 5 insertions(+), 6 deletions(-)
diff --git a/Makefile b/Makefile
index d74f7c8..a4cdfa7 100644
--- a/Makefile
+++ b/Makefile
@@ -54,12 +54,11 @@ endif
MACOS = 0
ifneq (,$(findstring Darwin,$(shell uname)))
MACOS = 1
-endif
-
-ifneq (,$(findstring 13,$(shell uname -r)))
- CPP = clang++
- CC = clang
- EXTRA_FLAGS += -stdlib=libstdc++
+ ifneq (,$(findstring 13,$(shell uname -r)))
+ CPP = clang++
+ CC = clang
+ EXTRA_FLAGS += -stdlib=libstdc++
+ endif
endif
POPCNT_CAPABILITY ?= 1