gnu: emacs-org-ql: Patch for Helm users.
The package has a Helm component that is missing the relevant `require` statements. * gnu/packages/patches/emacs-helm-org-ql.patch: Add. * gnu/local.mk (emacs-helm-org-ql): Add entry. * gnu/packages/emacs-xyz.scm: Update and add dependencies.
This commit is contained in:
parent
c2acf8f32b
commit
0091853199
|
@ -791,6 +791,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/emacs-dired-toggle-sudo-emacs-26.patch \
|
||||
%D%/packages/patches/emacs-exec-path.patch \
|
||||
%D%/packages/patches/emacs-fix-scheme-indent-function.patch \
|
||||
%D%/packages/patches/emacs-helm-org-ql.patch \
|
||||
%D%/packages/patches/emacs-json-reformat-fix-tests.patch \
|
||||
%D%/packages/patches/emacs-highlight-stages-add-gexp.patch \
|
||||
%D%/packages/patches/emacs-scheme-complete-scheme-r5rs-info.patch \
|
||||
|
|
|
@ -11757,6 +11757,9 @@ according to a parsing expression grammar.")
|
|||
(sha256
|
||||
(base32
|
||||
"0apcg63xm0242mjgsgw0jrcda4p4iqj7fy3sgh0p7khi4hrs5ch0"))
|
||||
(patches
|
||||
(search-patches
|
||||
"emacs-helm-org-ql.patch"))
|
||||
(file-name (git-file-name name version))))
|
||||
(build-system emacs-build-system)
|
||||
(propagated-inputs
|
||||
|
@ -11767,6 +11770,8 @@ according to a parsing expression grammar.")
|
|||
("emacs-org-super-agenda" ,emacs-org-super-agenda)
|
||||
("emacs-ts" ,emacs-ts)
|
||||
("emacs-org" ,emacs-org)
|
||||
("emacs-helm" ,emacs-helm)
|
||||
("emacs-helm-org" ,emacs-helm-org)
|
||||
("emacs-dash" ,emacs-dash)))
|
||||
(native-inputs
|
||||
`(("emacs-buttercup" ,emacs-buttercup)))
|
||||
|
|
|
@ -0,0 +1,42 @@
|
|||
From 3918944856834ef4a7ed613243a1612424d2daba Mon Sep 17 00:00:00 2001
|
||||
From: Brian Leung <leungbk@mailfence.com>
|
||||
Date: Thu, 10 Oct 2019 06:54:33 +0200
|
||||
Subject: [PATCH] Use require statements.
|
||||
|
||||
---
|
||||
helm-org-ql.el | 19 ++-----------------
|
||||
1 file changed, 2 insertions(+), 17 deletions(-)
|
||||
|
||||
diff --git a/helm-org-ql.el b/helm-org-ql.el
|
||||
index 26beab9..113b7f2 100644
|
||||
--- a/helm-org-ql.el
|
||||
+++ b/helm-org-ql.el
|
||||
@@ -35,23 +35,8 @@
|
||||
(require 'org-ql)
|
||||
(require 'org-ql-search)
|
||||
|
||||
-;; (require 'helm)
|
||||
-;; (require 'helm-org)
|
||||
-
|
||||
-;;;; Compatibility
|
||||
-
|
||||
-;; Declare Helm functions since Helm may not be installed.
|
||||
-(declare-function helm "ext:helm")
|
||||
-(declare-function helm-run-after-exit "ext:helm")
|
||||
-(declare-function helm-window "ext:helm-lib")
|
||||
-(declare-function helm-buffer-get "ext:helm-lib")
|
||||
-(declare-function helm-make-source "ext:helm-source")
|
||||
-(declare-function helm-org-goto-marker "ext:helm-org")
|
||||
-
|
||||
-;; Silence byte-compiler about variables.
|
||||
-(defvar helm-map)
|
||||
-(defvar helm-pattern)
|
||||
-(defvar helm-input-idle-delay)
|
||||
+(require 'helm)
|
||||
+(require 'helm-org)
|
||||
|
||||
;;;; Variables
|
||||
|
||||
--
|
||||
2.23.0
|
||||
|
Loading…
Reference in New Issue