gnu: libtasn1: Fix CVE-2017-10790.
* gnu/packages/patches/libtasn1-CVE-2017-10790.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/tls.scm (libtasn1/fixed)[source]: Use it.
This commit is contained in:
parent
6a4364335c
commit
01a61d7040
|
@ -775,6 +775,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/libssh2-fix-build-failure-with-gcrypt.patch \
|
%D%/packages/patches/libssh2-fix-build-failure-with-gcrypt.patch \
|
||||||
%D%/packages/patches/libtar-CVE-2013-4420.patch \
|
%D%/packages/patches/libtar-CVE-2013-4420.patch \
|
||||||
%D%/packages/patches/libtasn1-CVE-2017-6891.patch \
|
%D%/packages/patches/libtasn1-CVE-2017-6891.patch \
|
||||||
|
%D%/packages/patches/libtasn1-CVE-2017-10790.patch \
|
||||||
%D%/packages/patches/libtheora-config-guess.patch \
|
%D%/packages/patches/libtheora-config-guess.patch \
|
||||||
%D%/packages/patches/libtiff-CVE-2016-10092.patch \
|
%D%/packages/patches/libtiff-CVE-2016-10092.patch \
|
||||||
%D%/packages/patches/libtiff-CVE-2016-10093.patch \
|
%D%/packages/patches/libtiff-CVE-2016-10093.patch \
|
||||||
|
|
|
@ -0,0 +1,63 @@
|
||||||
|
Fix CVE-2017-10790:
|
||||||
|
|
||||||
|
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-10790
|
||||||
|
|
||||||
|
Patch copied from upstream source repository:
|
||||||
|
|
||||||
|
https://git.savannah.nongnu.org/cgit/libtasn1.git/commit/?id=d8d805e1f2e6799bb2dff4871a8598dc83088a39
|
||||||
|
|
||||||
|
From d8d805e1f2e6799bb2dff4871a8598dc83088a39 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Nikos Mavrogiannopoulos <nmav@redhat.com>
|
||||||
|
Date: Thu, 22 Jun 2017 16:31:37 +0200
|
||||||
|
Subject: [PATCH] _asn1_check_identifier: safer access to values read
|
||||||
|
|
||||||
|
Signed-off-by: Nikos Mavrogiannopoulos <nmav@redhat.com>
|
||||||
|
---
|
||||||
|
lib/parser_aux.c | 17 ++++++++++++-----
|
||||||
|
1 file changed, 12 insertions(+), 5 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/lib/parser_aux.c b/lib/parser_aux.c
|
||||||
|
index 976ab38..786ea64 100644
|
||||||
|
--- a/lib/parser_aux.c
|
||||||
|
+++ b/lib/parser_aux.c
|
||||||
|
@@ -955,7 +955,7 @@ _asn1_check_identifier (asn1_node node)
|
||||||
|
if (p2 == NULL)
|
||||||
|
{
|
||||||
|
if (p->value)
|
||||||
|
- _asn1_strcpy (_asn1_identifierMissing, p->value);
|
||||||
|
+ _asn1_str_cpy (_asn1_identifierMissing, sizeof(_asn1_identifierMissing), (char*)p->value);
|
||||||
|
else
|
||||||
|
_asn1_strcpy (_asn1_identifierMissing, "(null)");
|
||||||
|
return ASN1_IDENTIFIER_NOT_FOUND;
|
||||||
|
@@ -968,9 +968,15 @@ _asn1_check_identifier (asn1_node node)
|
||||||
|
if (p2 && (type_field (p2->type) == ASN1_ETYPE_DEFAULT))
|
||||||
|
{
|
||||||
|
_asn1_str_cpy (name2, sizeof (name2), node->name);
|
||||||
|
- _asn1_str_cat (name2, sizeof (name2), ".");
|
||||||
|
- _asn1_str_cat (name2, sizeof (name2), (char *) p2->value);
|
||||||
|
- _asn1_strcpy (_asn1_identifierMissing, p2->value);
|
||||||
|
+ if (p2->value)
|
||||||
|
+ {
|
||||||
|
+ _asn1_str_cat (name2, sizeof (name2), ".");
|
||||||
|
+ _asn1_str_cat (name2, sizeof (name2), (char *) p2->value);
|
||||||
|
+ _asn1_str_cpy (_asn1_identifierMissing, sizeof(_asn1_identifierMissing), (char*)p2->value);
|
||||||
|
+ }
|
||||||
|
+ else
|
||||||
|
+ _asn1_strcpy (_asn1_identifierMissing, "(null)");
|
||||||
|
+
|
||||||
|
p2 = asn1_find_node (node, name2);
|
||||||
|
if (!p2 || (type_field (p2->type) != ASN1_ETYPE_OBJECT_ID) ||
|
||||||
|
!(p2->type & CONST_ASSIGN))
|
||||||
|
@@ -990,7 +996,8 @@ _asn1_check_identifier (asn1_node node)
|
||||||
|
_asn1_str_cpy (name2, sizeof (name2), node->name);
|
||||||
|
_asn1_str_cat (name2, sizeof (name2), ".");
|
||||||
|
_asn1_str_cat (name2, sizeof (name2), (char *) p2->value);
|
||||||
|
- _asn1_strcpy (_asn1_identifierMissing, p2->value);
|
||||||
|
+ _asn1_str_cpy (_asn1_identifierMissing, sizeof(_asn1_identifierMissing), (char*)p2->value);
|
||||||
|
+
|
||||||
|
p2 = asn1_find_node (node, name2);
|
||||||
|
if (!p2 || (type_field (p2->type) != ASN1_ETYPE_OBJECT_ID)
|
||||||
|
|| !(p2->type & CONST_ASSIGN))
|
||||||
|
--
|
||||||
|
2.13.3
|
||||||
|
|
|
@ -81,7 +81,8 @@ specifications.")
|
||||||
(origin
|
(origin
|
||||||
(inherit (package-source libtasn1))
|
(inherit (package-source libtasn1))
|
||||||
(patches
|
(patches
|
||||||
(search-patches "libtasn1-CVE-2017-6891.patch"))))))
|
(search-patches "libtasn1-CVE-2017-6891.patch"
|
||||||
|
"libtasn1-CVE-2017-10790.patch"))))))
|
||||||
|
|
||||||
(define-public asn1c
|
(define-public asn1c
|
||||||
(package
|
(package
|
||||||
|
|
Loading…
Reference in New Issue