gnu: automake: Update to 1.15.1.
* gnu/packages/autotools.scm (automake): Update to 1.15.1. [source]: Remove patches. (automake/latest): Remove package. * gnu/packages/patches/automake-regexp-syntax.patch, gnu/packages/patches/automake-test-gzip-warning.patch: Remove files. * gnu/local.mk (dist_patch_DATA): Remove them.
This commit is contained in:
parent
759807e872
commit
01c7193e0b
|
@ -534,8 +534,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/ath9k-htc-firmware-gcc.patch \
|
%D%/packages/patches/ath9k-htc-firmware-gcc.patch \
|
||||||
%D%/packages/patches/ath9k-htc-firmware-objcopy.patch \
|
%D%/packages/patches/ath9k-htc-firmware-objcopy.patch \
|
||||||
%D%/packages/patches/automake-skip-amhello-tests.patch \
|
%D%/packages/patches/automake-skip-amhello-tests.patch \
|
||||||
%D%/packages/patches/automake-regexp-syntax.patch \
|
|
||||||
%D%/packages/patches/automake-test-gzip-warning.patch \
|
|
||||||
%D%/packages/patches/avahi-localstatedir.patch \
|
%D%/packages/patches/avahi-localstatedir.patch \
|
||||||
%D%/packages/patches/avidemux-install-to-lib.patch \
|
%D%/packages/patches/avidemux-install-to-lib.patch \
|
||||||
%D%/packages/patches/awesome-reproducible-png.patch \
|
%D%/packages/patches/awesome-reproducible-png.patch \
|
||||||
|
|
|
@ -238,21 +238,18 @@ output is indexed in many ways to simplify browsing.")
|
||||||
(license gpl3+)))
|
(license gpl3+)))
|
||||||
|
|
||||||
(define-public automake
|
(define-public automake
|
||||||
;; Replace with 'automake/latest' on the next rebuild cycle.
|
|
||||||
(package
|
(package
|
||||||
(name "automake")
|
(name "automake")
|
||||||
(version "1.15")
|
(version "1.15.1")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "mirror://gnu/automake/automake-"
|
(uri (string-append "mirror://gnu/automake/automake-"
|
||||||
version ".tar.xz"))
|
version ".tar.xz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0dl6vfi2lzz8alnklwxzfz624b95hb1ipjvd3mk177flmddcf24r"))
|
"1bzd9g32dfm4rsbw93ld9x7b5nc1y6i4m6zp032qf1i28a8s6sxg"))
|
||||||
(patches
|
(patches
|
||||||
(search-patches "automake-regexp-syntax.patch"
|
(search-patches "automake-skip-amhello-tests.patch"))))
|
||||||
"automake-skip-amhello-tests.patch"
|
|
||||||
"automake-test-gzip-warning.patch"))))
|
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(native-inputs
|
(native-inputs
|
||||||
`(("autoconf" ,(autoconf-wrapper))
|
`(("autoconf" ,(autoconf-wrapper))
|
||||||
|
@ -317,22 +314,6 @@ intuitive format and then Automake works with Autoconf to produce a robust
|
||||||
Makefile, simplifying the entire process for the developer.")
|
Makefile, simplifying the entire process for the developer.")
|
||||||
(license gpl2+))) ; some files are under GPLv3+
|
(license gpl2+))) ; some files are under GPLv3+
|
||||||
|
|
||||||
|
|
||||||
(define-public automake/latest
|
|
||||||
;; Merge with 'automake' on the next rebuild cycle.
|
|
||||||
(package
|
|
||||||
(inherit automake)
|
|
||||||
(version "1.15.1")
|
|
||||||
(source (origin
|
|
||||||
(method url-fetch)
|
|
||||||
(uri (string-append "mirror://gnu/automake/automake-"
|
|
||||||
version ".tar.xz"))
|
|
||||||
(sha256
|
|
||||||
(base32
|
|
||||||
"1bzd9g32dfm4rsbw93ld9x7b5nc1y6i4m6zp032qf1i28a8s6sxg"))
|
|
||||||
(patches
|
|
||||||
(search-patches "automake-skip-amhello-tests.patch"))))))
|
|
||||||
|
|
||||||
(define-public libtool
|
(define-public libtool
|
||||||
(package
|
(package
|
||||||
(name "libtool")
|
(name "libtool")
|
||||||
|
|
|
@ -1,34 +0,0 @@
|
||||||
From <https://lists.gnu.org/archive/html/automake-patches/2015-07/msg00000.html>.
|
|
||||||
See also <http://bugs.gnu.org/22372>.
|
|
||||||
|
|
||||||
From 34163794a58b5bd91c5d6bd9adf5437571c7a479 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Pavel Raiskup <praiskup@redhat.com>
|
|
||||||
Date: Tue, 7 Jul 2015 10:54:24 +0200
|
|
||||||
Subject: [PATCH] bin/automake: escape '{' in regexp pattern
|
|
||||||
|
|
||||||
Based on perlre(1) documentation:
|
|
||||||
.. in Perl v5.26, literal uses of a curly bracket will be required
|
|
||||||
to be escaped, say by preceding them with a backslash ("\{" ) or
|
|
||||||
enclosing them within square brackets ("[{]") ..
|
|
||||||
|
|
||||||
References:
|
|
||||||
https://bugzilla.redhat.com/1239379
|
|
||||||
|
|
||||||
* bin/automake.in (substitute_ac_subst_variables): Escape the
|
|
||||||
occurrence of '{' character.
|
|
||||||
---
|
|
||||||
bin/automake.in | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/bin/automake.in b/bin/automake.in
|
|
||||||
index 0c29184..c294ced 100644
|
|
||||||
--- a/bin/automake.in
|
|
||||||
+++ b/bin/automake.in
|
|
||||||
@@ -3898,7 +3898,7 @@ sub substitute_ac_subst_variables_worker
|
|
||||||
sub substitute_ac_subst_variables
|
|
||||||
{
|
|
||||||
my ($text) = @_;
|
|
||||||
- $text =~ s/\${([^ \t=:+{}]+)}/substitute_ac_subst_variables_worker ($1)/ge;
|
|
||||||
+ $text =~ s/\$\{([^ \t=:+{}]+)}/substitute_ac_subst_variables_worker ($1)/ge;
|
|
||||||
return $text;
|
|
||||||
}
|
|
|
@ -1,17 +0,0 @@
|
||||||
Adjust test to ignore gzip 1.8+ warnings.
|
|
||||||
|
|
||||||
--- automake-1.15/t/distcheck-no-prefix-or-srcdir-override.sh 2016-06-14 00:36:26.554218552 +0200
|
|
||||||
+++ automake-1.15/t/distcheck-no-prefix-or-srcdir-override.sh 2016-06-14 00:37:52.903157770 +0200
|
|
||||||
@@ -49,7 +49,11 @@ grep "cannot find sources.* in foobar" s
|
|
||||||
|
|
||||||
./configure
|
|
||||||
run_make -E -O distcheck
|
|
||||||
-test ! -s stderr
|
|
||||||
+
|
|
||||||
+# Gzip 1.8+ emits warnings like "gzip: warning: GZIP environment
|
|
||||||
+# variable is deprecated"; filter them out.
|
|
||||||
+test `grep -v '^gzip: warning' stderr | wc -l` -eq 0
|
|
||||||
+
|
|
||||||
# Sanity check: the flags have been actually seen.
|
|
||||||
$PERL -e 'undef $/; $_ = <>; s/ \\\n/ /g; print;' <stdout >t
|
|
||||||
grep '/configure .* --srcdir am-src' t || exit 99
|
|
Loading…
Reference in New Issue