gnu: racket: Update to 6.12.

* gnu/packages/patches/racket-minus_zero_p-disable-xform.patch: New file.
* gnu/packages/scheme.scm (racket): Update version and patch.
master
Christopher Lemmer Webber 2018-02-24 18:36:13 -06:00
parent 35b3135f5d
commit 02283a6130
No known key found for this signature in database
GPG Key ID: 4BC025925FF8F4D3
2 changed files with 15 additions and 2 deletions

View File

@ -0,0 +1,10 @@
--- a/src/racket/src/number.c 2018-02-24 18:16:32.031698079 -0600
+++ b/src/racket/src/number.c 2018-02-24 18:15:41.055445301 -0600
@@ -1775,6 +1775,7 @@
}
XFORM_NONGCING static MZ_INLINE int minus_zero_p(double d)
+ XFORM_SKIP_PROC
{
#ifdef MZ_IS_NEG_ZERO
return MZ_IS_NEG_ZERO(d);

View File

@ -405,7 +405,7 @@ implementation techniques and as an expository tool.")
(define-public racket
(package
(name "racket")
(version "6.11")
(version "6.12")
(source (origin
(method url-fetch)
(uri (list (string-append "http://mirror.racket-lang.org/installers/"
@ -415,7 +415,10 @@ implementation techniques and as an expository tool.")
version "/racket-" version "-src.tgz")))
(sha256
(base32
"1nk7705x24jjlbqqhj8yvbgqkfscxx3m81bry1g56kjxysjmf3sw"))))
"0cwcypzjfl9py1s695mhqkiapff7c1w29llsmdj7qgn58wl0apk5"))
(patches (search-patches
;; See: https://github.com/racket/racket/issues/1962
"racket-minus_zero_p-disable-xform.patch"))))
(build-system gnu-build-system)
(arguments
'(#:phases