gnu: Update calibre to 3.6.0.
* gnu/local.mk: Remove calibre-drop-unrar.patch * gnu/packages/ebook.scm (calibre): Update to 3.6.0. Add python-html5-parser input. * gnu/packages/patches/calibre-drop-unrar.patch: Remove file.
This commit is contained in:
parent
13be557d98
commit
026ebc141f
|
@ -536,7 +536,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/blast+-fix-makefile.patch \
|
||||
%D%/packages/patches/byobu-writable-status.patch \
|
||||
%D%/packages/patches/cairo-CVE-2016-9082.patch \
|
||||
%D%/packages/patches/calibre-drop-unrar.patch \
|
||||
%D%/packages/patches/calibre-no-updates-dialog.patch \
|
||||
%D%/packages/patches/calibre-use-packaged-feedparser.patch \
|
||||
%D%/packages/patches/catdoc-CVE-2017-11110.patch \
|
||||
|
|
|
@ -72,7 +72,7 @@
|
|||
(define-public calibre
|
||||
(package
|
||||
(name "calibre")
|
||||
(version "3.0.0")
|
||||
(version "3.6.0")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
|
@ -81,21 +81,19 @@
|
|||
version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"1zhk7bvgr973dd18x4wp48kzai29qqqi5qcy72sxc4wcbk2sbnkw"))
|
||||
"0vp2nds4b5xbchsh1rpc1q7093gd26dnw7mgbnax97dcchvlc4sc"))
|
||||
;; Remove non-free or doubtful code, see
|
||||
;; https://lists.gnu.org/archive/html/guix-devel/2015-02/msg00478.html
|
||||
(modules '((guix build utils)))
|
||||
(snippet
|
||||
'(begin
|
||||
(delete-file-recursively "src/calibre/ebooks/markdown")
|
||||
(delete-file-recursively "src/unrar")
|
||||
(delete-file "src/odf/thumbnail.py")
|
||||
(delete-file-recursively "resources/fonts/liberation")
|
||||
(substitute* (find-files "." "\\.py")
|
||||
(("calibre\\.ebooks\\.markdown") "markdown"))
|
||||
#t))
|
||||
(patches (search-patches "calibre-drop-unrar.patch"
|
||||
"calibre-use-packaged-feedparser.patch"
|
||||
(patches (search-patches "calibre-use-packaged-feedparser.patch"
|
||||
"calibre-no-updates-dialog.patch"))))
|
||||
(build-system python-build-system)
|
||||
(native-inputs
|
||||
|
@ -129,6 +127,7 @@
|
|||
("python2-dbus" ,python2-dbus)
|
||||
("python2-dnspython" ,python2-dnspython)
|
||||
("python2-feedparser" ,python2-feedparser)
|
||||
("python2-html5-parser" ,python2-html5-parser)
|
||||
("python2-lxml" ,python2-lxml)
|
||||
("python2-markdown" ,python2-markdown)
|
||||
("python2-mechanize" ,python2-mechanize)
|
||||
|
@ -140,6 +139,9 @@
|
|||
("python2-pyqt" ,python2-pyqt)
|
||||
("python2-sip" ,python2-sip)
|
||||
("python2-regex" ,python2-regex)
|
||||
;; python2-unrardll is needed for decompressing RAR files.
|
||||
;; A program called 'pdf2html' is needed for reading PDF books
|
||||
;; in the web interface.
|
||||
("sqlite" ,sqlite)))
|
||||
(arguments
|
||||
`(#:python ,python-2
|
||||
|
|
|
@ -1,49 +0,0 @@
|
|||
Recreated old debian patch on the latest calibre version
|
||||
|
||||
From 6764e4c211e50d4f4633dbabfba7cbc3089c51dc Mon Sep 17 00:00:00 2001
|
||||
From: Brendan Tildesley <brendan.tildesley@openmailbox.org>
|
||||
Date: Sat, 13 May 2017 21:12:12 +1000
|
||||
Subject: [PATCH] Remove unrar extension
|
||||
|
||||
---
|
||||
setup/extensions.json | 11 -----------
|
||||
src/calibre/ebooks/metadata/archive.py | 2 +-
|
||||
2 files changed, 1 insertion(+), 12 deletions(-)
|
||||
|
||||
diff --git a/setup/extensions.json b/setup/extensions.json
|
||||
index 1f6d1fb5fd..127390450f 100644
|
||||
--- a/setup/extensions.json
|
||||
+++ b/setup/extensions.json
|
||||
@@ -211,16 +211,5 @@
|
||||
"sources": "calibre/devices/mtp/unix/devices.c calibre/devices/mtp/unix/libmtp.c",
|
||||
"headers": "calibre/devices/mtp/unix/devices.h calibre/devices/mtp/unix/upstream/music-players.h calibre/devices/mtp/unix/upstream/device-flags.h",
|
||||
"libraries": "mtp"
|
||||
- },
|
||||
- {
|
||||
- "name": "unrar",
|
||||
- "sources": "unrar/rar.cpp unrar/strlist.cpp unrar/strfn.cpp unrar/pathfn.cpp unrar/savepos.cpp unrar/smallfn.cpp unrar/global.cpp unrar/file.cpp unrar/filefn.cpp unrar/filcreat.cpp unrar/archive.cpp unrar/arcread.cpp unrar/unicode.cpp unrar/system.cpp unrar/isnt.cpp unrar/crypt.cpp unrar/crc.cpp unrar/rawread.cpp unrar/encname.cpp unrar/resource.cpp unrar/match.cpp unrar/timefn.cpp unrar/rdwrfn.cpp unrar/consio.cpp unrar/options.cpp unrar/ulinks.cpp unrar/errhnd.cpp unrar/rarvm.cpp unrar/secpassword.cpp unrar/rijndael.cpp unrar/getbits.cpp unrar/sha1.cpp unrar/extinfo.cpp unrar/extract.cpp unrar/volume.cpp unrar/list.cpp unrar/find.cpp unrar/unpack.cpp unrar/cmddata.cpp unrar/filestr.cpp unrar/scantree.cpp calibre/utils/unrar.cpp",
|
||||
- "inc_dirs": "unrar",
|
||||
- "defines": "SILENT RARDLL UNRAR _FILE_OFFSET_BITS=64 _LARGEFILE_SOURCE",
|
||||
- "windows_defines": "SILENT RARDLL UNRAR",
|
||||
- "haiku_defines": "LITTLE_ENDIAN SILENT RARDLL UNRAR _FILE_OFFSET_BITS=64 _LARGEFILE_SOURCE _BSD_SOURCE",
|
||||
- "haiku_libraries": "bsd",
|
||||
- "optimize_level": 2,
|
||||
- "windows_libraries": "User32 Advapi32 kernel32 Shell32"
|
||||
}
|
||||
]
|
||||
diff --git a/src/calibre/ebooks/metadata/archive.py b/src/calibre/ebooks/metadata/archive.py
|
||||
index f5c0b7bed3..32257dcdae 100644
|
||||
--- a/src/calibre/ebooks/metadata/archive.py
|
||||
+++ b/src/calibre/ebooks/metadata/archive.py
|
||||
@@ -44,7 +44,7 @@ class ArchiveExtract(FileTypePlugin):
|
||||
description = _('Extract common e-book formats from archive files '
|
||||
'(ZIP/RAR). Also try to autodetect if they are actually '
|
||||
'CBZ/CBR files.')
|
||||
- file_types = set(['zip', 'rar'])
|
||||
+ file_types = set(['zip'])
|
||||
supported_platforms = ['windows', 'osx', 'linux']
|
||||
on_import = True
|
||||
|
||||
--
|
||||
2.12.2
|
||||
|
Loading…
Reference in New Issue