gnu: libgcrypt: Update to 1.8.4.
Update libgcrypt and remove reproducibility patch, it is now built-in. See https://dev.gnupg.org/T4102 * gnu/packages/gnupg.scm (libgcrypt): Update to 1.8.4. [source]: Remove patch. * gnu/packages/patches/libgcrypt-make-yat2m-reproducible.patch: Delete file. * gnu/local.mk(dist_patch_DATA): Remove it.
This commit is contained in:
parent
fae3c0d953
commit
02d83c2479
|
@ -886,7 +886,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/libevent-2.1-skip-failing-test.patch \
|
||||
%D%/packages/patches/libexif-CVE-2016-6328.patch \
|
||||
%D%/packages/patches/libexif-CVE-2017-7544.patch \
|
||||
%D%/packages/patches/libgcrypt-make-yat2m-reproducible.patch \
|
||||
%D%/packages/patches/libgit2-mtime-0.patch \
|
||||
%D%/packages/patches/libgdata-fix-tests.patch \
|
||||
%D%/packages/patches/libgdata-glib-duplicate-tests.patch \
|
||||
|
|
|
@ -15,6 +15,7 @@
|
|||
;;; Copyright © 2017 Petter <petter@mykolab.ch>
|
||||
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
|
||||
;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
|
||||
;;; Copyright © 2018 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
|
||||
;;;
|
||||
;;; This file is part of GNU Guix.
|
||||
;;;
|
||||
|
@ -97,16 +98,14 @@ Daemon and possibly more in the future.")
|
|||
(define-public libgcrypt
|
||||
(package
|
||||
(name "libgcrypt")
|
||||
(version "1.8.3")
|
||||
(version "1.8.4")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://gnupg/libgcrypt/libgcrypt-"
|
||||
version ".tar.bz2"))
|
||||
(sha256
|
||||
(base32
|
||||
"0z5gs1khzyknyfjr19k8gk4q148s6q987ya85cpn0iv70fz91v36"))
|
||||
(patches
|
||||
(search-patches "libgcrypt-make-yat2m-reproducible.patch"))))
|
||||
"09r27ywj9zplq6n9qw3mn7zmvf6y2jdmwx5d1kg8yqkj0qx18f7n"))))
|
||||
(build-system gnu-build-system)
|
||||
(propagated-inputs
|
||||
`(("libgpg-error-host" ,libgpg-error)))
|
||||
|
|
|
@ -1,32 +0,0 @@
|
|||
Make yat2m in libgcrypt respect SOURCE_DATE_EPOCH, making
|
||||
the build reproducible.
|
||||
|
||||
This was already fixed upstream in GnuPG:
|
||||
https://dev.gnupg.org/rG139de02b93773615bdd95e04a7f0c1ad73b4f6fb
|
||||
|
||||
and in libgpg-error:
|
||||
https://dev.gnupg.org/rE5494a5728418938d2e42158bb646b07124184e64
|
||||
|
||||
|
||||
--- a/doc/yat2m.c 2017-11-23 19:16:58.000000000 +0100
|
||||
+++ b/doc/yat2m.c 2017-08-28 12:22:54.000000000 +0200
|
||||
@@ -1475,6 +1484,7 @@
|
||||
main (int argc, char **argv)
|
||||
{
|
||||
int last_argc = -1;
|
||||
+ const char *s;
|
||||
|
||||
opt_source = "GNU";
|
||||
opt_release = "";
|
||||
@@ -1608,6 +1618,11 @@
|
||||
if (argc > 1)
|
||||
die ("usage: " PGM " [OPTION] [FILE] (try --help for more information)\n");
|
||||
|
||||
+ /* Take care of supplied timestamp for reproducible builds. See
|
||||
+ * https://reproducible-builds.org/specs/source-date-epoch/ */
|
||||
+ if (!opt_date && (s = getenv ("SOURCE_DATE_EPOCH")) && *s)
|
||||
+ opt_date = s;
|
||||
+
|
||||
/* Start processing. */
|
||||
if (argc && strcmp (*argv, "-"))
|
||||
{
|
Loading…
Reference in New Issue