gnu: emacs-realgud: Patch configure.ac to repair the build.
This fixes https://bugs.gnu.org/33196, a build problem caused by a defective Elisp snippet in a check in configure.ac. * gnu/packages/patches/emacs-realgud-fix-configure-ac.patch: Add patch. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/emacs.scm (emacs-realgud)[source]: Use it.
This commit is contained in:
parent
30f0d21b40
commit
03592a6f88
|
@ -19,6 +19,7 @@
|
|||
# Copyright © 2018 Amirouche Boubekki <amirouche@hypermove.net>
|
||||
# Copyright © 2018 Oleg Pykhalov <go.wigust@gmail.com>
|
||||
# Copyright © 2018 Stefan Stefanović <stefanx2ovic@gmail.com>
|
||||
# Copyright © 2018 Maxim Cournoyer <maxim.cournoyer@gmail.com>
|
||||
#
|
||||
# This file is part of GNU Guix.
|
||||
#
|
||||
|
@ -663,6 +664,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/emacs-highlight-stages-add-gexp.patch \
|
||||
%D%/packages/patches/emacs-scheme-complete-scheme-r5rs-info.patch \
|
||||
%D%/packages/patches/emacs-source-date-epoch.patch \
|
||||
%D%/packages/patches/emacs-realgud-fix-configure-ac.patch \
|
||||
%D%/packages/patches/enlightenment-fix-setuid-path.patch \
|
||||
%D%/packages/patches/erlang-man-path.patch \
|
||||
%D%/packages/patches/eudev-rules-directory.patch \
|
||||
|
|
|
@ -3659,7 +3659,11 @@ after buffer changes.")
|
|||
version ".tar"))
|
||||
(sha256
|
||||
(base32
|
||||
"108wgxg7fb4byaiasgvbxv2hq7b00biq9f0mh9hy6vw4160y5w24"))))
|
||||
"108wgxg7fb4byaiasgvbxv2hq7b00biq9f0mh9hy6vw4160y5w24"))
|
||||
(patches
|
||||
;; Patch awaiting inclusion upstream (see:
|
||||
;; https://github.com/realgud/realgud/pull/226).
|
||||
(search-patches "emacs-realgud-fix-configure-ac.patch"))))
|
||||
(build-system emacs-build-system)
|
||||
(arguments
|
||||
`(#:tests? #t
|
||||
|
|
|
@ -0,0 +1,27 @@
|
|||
From a293690f29407ac54a218d6d20c2142e1a0319d1 Mon Sep 17 00:00:00 2001
|
||||
From: Maxim Cournoyer <maxim.cournoyer@gmail.com>
|
||||
Date: Wed, 31 Oct 2018 00:08:34 -0400
|
||||
Subject: [PATCH] configure.ac: Fix NO_CHECK_EMACS_PACKAGES elisp.
|
||||
|
||||
Remove the extraneous trailing parenthesis.
|
||||
---
|
||||
configure.ac | 3 +--
|
||||
1 file changed, 1 insertion(+), 2 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index de0d932..69bcea7 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -25,8 +25,7 @@ AC_MSG_NOTICE("Checking prerequiste packages")
|
||||
$EMACS -batch -q --no-site-file -eval \
|
||||
'(dolist (package
|
||||
(quote (cl-lib loc-changes load-relative test-simple)))
|
||||
- (require package))
|
||||
- )'
|
||||
+ (require package))'
|
||||
fi
|
||||
if test $? -ne 0 ; then
|
||||
AC_MSG_ERROR([Can't continue until above error is corrected.])
|
||||
--
|
||||
2.19.0
|
||||
|
Loading…
Reference in New Issue