gnu: gobject-introspection: Update to 1.58.1.
* gnu/packages/glib.scm (gobject-introspection): Update to 1.58.1. [source]: Remove snippet. [arguments]: Add phase "do-not-use-/usr/bin/env". [inputs]: Replace python-2 with python-wrapper; add zlib. [native-inputs]: Add autoconf and automake to be able to keep using the gnu-build-system. * gnu/packages/patches/gobject-introspection-cc.patch: Update patch to apply to latest version.
This commit is contained in:
parent
6c237a2d7b
commit
036c86be5a
|
@ -28,6 +28,7 @@
|
||||||
|
|
||||||
(define-module (gnu packages glib)
|
(define-module (gnu packages glib)
|
||||||
#:use-module (gnu packages)
|
#:use-module (gnu packages)
|
||||||
|
#:use-module (gnu packages autotools)
|
||||||
#:use-module (gnu packages backup)
|
#:use-module (gnu packages backup)
|
||||||
#:use-module (gnu packages base)
|
#:use-module (gnu packages base)
|
||||||
#:use-module (gnu packages bash)
|
#:use-module (gnu packages bash)
|
||||||
|
@ -335,32 +336,44 @@ dynamic loading, and an object system.")
|
||||||
(define gobject-introspection
|
(define gobject-introspection
|
||||||
(package
|
(package
|
||||||
(name "gobject-introspection")
|
(name "gobject-introspection")
|
||||||
(version "1.56.1")
|
(version "1.58.1")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "mirror://gnome/sources/"
|
(uri (string-append "mirror://gnome/sources/"
|
||||||
"gobject-introspection/" (version-major+minor version)
|
"gobject-introspection/" (version-major+minor version)
|
||||||
"/gobject-introspection-" version ".tar.xz"))
|
"/gobject-introspection-" version ".tar.xz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32 "0jx2kryjd7l0vl5gb3qp1qjfy3cjiizvcd1snsm7pzwrzz67aa2v"))
|
(base32 "12fzs3044047icdfs7cb2lsmnfi6w6fyhkci3m2rbvf5llgnhm29"))
|
||||||
(modules '((guix build utils)))
|
|
||||||
(snippet
|
|
||||||
'(begin
|
|
||||||
(substitute* "tools/g-ir-tool-template.in"
|
|
||||||
(("#!/usr/bin/env @PYTHON@") "#!@PYTHON@"))
|
|
||||||
#t))
|
|
||||||
(patches (search-patches
|
(patches (search-patches
|
||||||
"gobject-introspection-cc.patch"
|
"gobject-introspection-cc.patch"
|
||||||
"gobject-introspection-girepository.patch"
|
"gobject-introspection-girepository.patch"
|
||||||
"gobject-introspection-absolute-shlib-path.patch"))))
|
"gobject-introspection-absolute-shlib-path.patch"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
|
(arguments
|
||||||
|
`(;; The build system has at least one race condition involving Gio-2.0.gir
|
||||||
|
;; which causes intermittent failures, as of 1.56.0.
|
||||||
|
#:parallel-build? #f
|
||||||
|
;; The patch 'gobject-introspection-absolute-shlib-path.patch' causes
|
||||||
|
;; some tests to fail.
|
||||||
|
#:tests? #f
|
||||||
|
#:phases
|
||||||
|
(modify-phases %standard-phases
|
||||||
|
(add-after 'unpack 'do-not-use-/usr/bin/env
|
||||||
|
(lambda _
|
||||||
|
(substitute* "tools/g-ir-tool-template.in"
|
||||||
|
(("#!@PYTHON_CMD@")
|
||||||
|
(string-append "#!" (which "python3"))))
|
||||||
|
#t)))))
|
||||||
(inputs
|
(inputs
|
||||||
`(("bison" ,bison)
|
`(("bison" ,bison)
|
||||||
("flex" ,flex)
|
("flex" ,flex)
|
||||||
("glib" ,glib)
|
("glib" ,glib)
|
||||||
("python-2" ,python-2)))
|
("python" ,python-wrapper)
|
||||||
|
("zlib" ,zlib)))
|
||||||
(native-inputs
|
(native-inputs
|
||||||
`(("glib" ,glib "bin")
|
`(("autoconf" ,autoconf)
|
||||||
|
("automake" ,automake)
|
||||||
|
("glib" ,glib "bin")
|
||||||
("pkg-config" ,pkg-config)))
|
("pkg-config" ,pkg-config)))
|
||||||
(propagated-inputs
|
(propagated-inputs
|
||||||
`(;; In practice, GIR users will need libffi when using
|
`(;; In practice, GIR users will need libffi when using
|
||||||
|
@ -371,13 +384,6 @@ dynamic loading, and an object system.")
|
||||||
(variable "GI_TYPELIB_PATH")
|
(variable "GI_TYPELIB_PATH")
|
||||||
(files '("lib/girepository-1.0")))))
|
(files '("lib/girepository-1.0")))))
|
||||||
(search-paths native-search-paths)
|
(search-paths native-search-paths)
|
||||||
(arguments
|
|
||||||
`(;; The build system has at least one race condition involving Gio-2.0.gir
|
|
||||||
;; which causes intermittent failures, as of 1.56.0.
|
|
||||||
#:parallel-build? #f
|
|
||||||
;; The patch 'gobject-introspection-absolute-shlib-path.patch' causes
|
|
||||||
;; some tests to fail.
|
|
||||||
#:tests? #f))
|
|
||||||
(home-page "https://wiki.gnome.org/GObjectIntrospection")
|
(home-page "https://wiki.gnome.org/GObjectIntrospection")
|
||||||
(synopsis "Generate interface introspection data for GObject libraries")
|
(synopsis "Generate interface introspection data for GObject libraries")
|
||||||
(description
|
(description
|
||||||
|
|
|
@ -1,11 +1,14 @@
|
||||||
Use gcc as the default C compiler if CC is not set.
|
Use gcc as the default C compiler if CC is not set.
|
||||||
|
|
||||||
|
diff -ru gobject-introspection-1.58.1.orig/giscanner/__init__.py gobject-introspection-1.58.1/giscanner/__init__.py
|
||||||
--- gobject-introspection-1.44.0.orig/giscanner/__init__.py 2014-08-04 22:37:07.000000000 +0800
|
--- gobject-introspection-1.58.1.orig/giscanner/__init__.py 1970-01-01 01:00:00.000000000 +0100
|
||||||
+++ gobject-introspection-1.44.0/giscanner/__init__.py 2015-04-20 17:30:26.507697234 +0800
|
+++ gobject-introspection-1.58.1/giscanner/__init__.py 2018-12-03 13:33:28.788971299 +0100
|
||||||
@@ -22,3 +22,5 @@
|
@@ -22,6 +22,8 @@
|
||||||
builddir = os.environ.get('UNINSTALLED_INTROSPECTION_BUILDDIR')
|
builddir = os.environ.get('UNINSTALLED_INTROSPECTION_BUILDDIR')
|
||||||
if builddir is not None:
|
if builddir is not None:
|
||||||
__path__.append(os.path.join(builddir, 'giscanner'))
|
__path__.append(os.path.join(builddir, 'giscanner'))
|
||||||
+if not 'CC' in os.environ:
|
+if not 'CC' in os.environ:
|
||||||
+ os.environ['CC'] = 'gcc'
|
+ os.environ['CC'] = 'gcc'
|
||||||
|
try:
|
||||||
|
from ._version import __version__
|
||||||
|
except ImportError:
|
||||||
|
|
Loading…
Reference in New Issue