gnu: flashrom: Update to 0.9.9
* gnu/packages/flashing-tools.scm (flashrom): Update to 0.9.9. [source]: Use HTTPS URL. Remove "flashrom-use-libftdi1.patch". [aruments]: Add 'CONFIG_ENABLE_LIBUSB0_PROGRAMMERS=no' to #:make-flags. * gnu/packages/patches/flashrom-use-libftdi1.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. Signed-off-by: Leo Famulari <leo@famulari.name>
This commit is contained in:
parent
0f5de84e98
commit
03ddad84ba
|
@ -512,7 +512,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/fasthenry-spFactor.patch \
|
||||
%D%/packages/patches/findutils-localstatedir.patch \
|
||||
%D%/packages/patches/findutils-test-xargs.patch \
|
||||
%D%/packages/patches/flashrom-use-libftdi1.patch \
|
||||
%D%/packages/patches/flint-ldconfig.patch \
|
||||
%D%/packages/patches/fltk-shared-lib-defines.patch \
|
||||
%D%/packages/patches/fltk-xfont-on-demand.patch \
|
||||
|
|
|
@ -38,16 +38,15 @@
|
|||
(define-public flashrom
|
||||
(package
|
||||
(name "flashrom")
|
||||
(version "0.9.7")
|
||||
(version "0.9.9")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append
|
||||
"http://download.flashrom.org/releases/flashrom-"
|
||||
"https://download.flashrom.org/releases/flashrom-"
|
||||
version ".tar.bz2"))
|
||||
(sha256
|
||||
(base32
|
||||
"1s9pc4yls2s1gcg2ar4q75nym2z5v6lxq36bl6lq26br00nj2mas"))
|
||||
(patches (search-patches "flashrom-use-libftdi1.patch"))))
|
||||
"0i9wg1lyfg99bld7d00zqjm9f0lk6m0q3h3n9c195c9yysq5ccfb"))))
|
||||
(build-system gnu-build-system)
|
||||
(inputs `(("dmidecode" ,dmidecode)
|
||||
("pciutils" ,pciutils)
|
||||
|
@ -55,7 +54,9 @@
|
|||
("libftdi" ,libftdi)))
|
||||
(native-inputs `(("pkg-config" ,pkg-config)))
|
||||
(arguments
|
||||
'(#:make-flags (list "CC=gcc" (string-append "PREFIX=" %output))
|
||||
'(#:make-flags (list "CC=gcc"
|
||||
(string-append "PREFIX=" %output)
|
||||
"CONFIG_ENABLE_LIBUSB0_PROGRAMMERS=no")
|
||||
#:tests? #f ; no 'check' target
|
||||
#:phases
|
||||
(alist-delete
|
||||
|
|
|
@ -1,70 +0,0 @@
|
|||
Update to libftdi-1.0 is advertised as a drop-in replacement for libftdi,
|
||||
running on top of libusb-1.0. This also removes indirect dependency to
|
||||
libusb-0.1.
|
||||
|
||||
Patch by Kyösti Mälkki <kyosti.malkki@gmail.com>.
|
||||
See <http://patchwork.coreboot.org/patch/3904/>.
|
||||
|
||||
--- flashrom/Makefile.orig 2013-08-13 18:00:00.000000000 -0400
|
||||
+++ flashrom/Makefile 2014-08-05 03:10:40.217145375 -0400
|
||||
@@ -492,19 +492,21 @@
|
||||
ifeq ($(CONFIG_FT2232_SPI), yes)
|
||||
# This is a totally ugly hack.
|
||||
FEATURE_CFLAGS += $(shell LC_ALL=C grep -q "FTDISUPPORT := yes" .features && printf "%s" "-D'CONFIG_FT2232_SPI=1'")
|
||||
-NEED_FTDI := yes
|
||||
+NEED_FTDI1 := yes
|
||||
PROGRAMMER_OBJS += ft2232_spi.o
|
||||
endif
|
||||
|
||||
ifeq ($(CONFIG_USBBLASTER_SPI), yes)
|
||||
# This is a totally ugly hack.
|
||||
FEATURE_CFLAGS += $(shell LC_ALL=C grep -q "FTDISUPPORT := yes" .features && printf "%s" "-D'CONFIG_USBBLASTER_SPI=1'")
|
||||
-NEED_FTDI := yes
|
||||
+NEED_LIBUSB1 := yes
|
||||
+NEED_FTDI1 := yes
|
||||
PROGRAMMER_OBJS += usbblaster_spi.o
|
||||
endif
|
||||
|
||||
-ifeq ($(NEED_FTDI), yes)
|
||||
-FTDILIBS := $(shell pkg-config --libs libftdi 2>/dev/null || printf "%s" "-lftdi -lusb")
|
||||
+ifeq ($(NEED_FTDI1), yes)
|
||||
+FTDILIBS := $(shell pkg-config --libs libftdi1 2>/dev/null || printf "%s" "-lftdi1 -lusb-1.0")
|
||||
+FEATURE_CFLAGS += $(shell pkg-config --cflags libftdi1 2>/dev/null)
|
||||
FEATURE_CFLAGS += $(shell LC_ALL=C grep -q "FT232H := yes" .features && printf "%s" "-D'HAVE_FT232H=1'")
|
||||
FEATURE_LIBS += $(shell LC_ALL=C grep -q "FTDISUPPORT := yes" .features && printf "%s" "$(FTDILIBS)")
|
||||
# We can't set NEED_USB here because that would transform libftdi auto-enabling
|
||||
@@ -781,6 +783,7 @@
|
||||
endif
|
||||
|
||||
define FTDI_TEST
|
||||
+#include <stddef.h>
|
||||
#include <ftdi.h>
|
||||
struct ftdi_context *ftdic = NULL;
|
||||
int main(int argc, char **argv)
|
||||
@@ -793,6 +796,7 @@
|
||||
export FTDI_TEST
|
||||
|
||||
define FTDI_232H_TEST
|
||||
+#include <stddef.h>
|
||||
#include <ftdi.h>
|
||||
enum ftdi_chip_type type = TYPE_232H;
|
||||
endef
|
||||
@@ -826,15 +830,15 @@
|
||||
|
||||
features: compiler
|
||||
@echo "FEATURES := yes" > .features.tmp
|
||||
-ifeq ($(NEED_FTDI), yes)
|
||||
+ifeq ($(NEED_FTDI1), yes)
|
||||
@printf "Checking for FTDI support... "
|
||||
@echo "$$FTDI_TEST" > .featuretest.c
|
||||
- @$(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) .featuretest.c -o .featuretest$(EXEC_SUFFIX) $(FTDILIBS) $(LIBS) >/dev/null 2>&1 && \
|
||||
+ @$(CC) $(CPPFLAGS) $(CFLAGS) $(FEATURE_CFLAGS) $(LDFLAGS) .featuretest.c -o .featuretest$(EXEC_SUFFIX) $(FTDILIBS) $(LIBS) >/dev/null 2>&1 && \
|
||||
( echo "found."; echo "FTDISUPPORT := yes" >> .features.tmp ) || \
|
||||
( echo "not found."; echo "FTDISUPPORT := no" >> .features.tmp )
|
||||
@printf "Checking for FT232H support in libftdi... "
|
||||
@echo "$$FTDI_232H_TEST" >> .featuretest.c
|
||||
- @$(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) .featuretest.c -o .featuretest$(EXEC_SUFFIX) $(FTDILIBS) $(LIBS) >/dev/null 2>&1 && \
|
||||
+ @$(CC) $(CPPFLAGS) $(CFLAGS) $(FEATURE_CFLAGS) $(LDFLAGS) .featuretest.c -o .featuretest$(EXEC_SUFFIX) $(FTDILIBS) $(LIBS) >/dev/null 2>&1 && \
|
||||
( echo "found."; echo "FT232H := yes" >> .features.tmp ) || \
|
||||
( echo "not found."; echo "FT232H := no" >> .features.tmp )
|
||||
endif
|
Loading…
Reference in New Issue