gnu: kodi: Update to 18.2.
* gnu/packages/kodi.scm (kodi): Update to 18.2. * gnu/packages/patches/kodi-set-libcurl-ssl-parameters.patch: Adjust for upstream changes.
This commit is contained in:
parent
06c86f166d
commit
05e1534ee8
|
@ -271,7 +271,7 @@ alternatives. In compilers, this can reduce the cascade of secondary errors.")
|
||||||
(define-public kodi
|
(define-public kodi
|
||||||
(package
|
(package
|
||||||
(name "kodi")
|
(name "kodi")
|
||||||
(version "18.1")
|
(version "18.2")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method git-fetch)
|
(method git-fetch)
|
||||||
(uri (git-reference
|
(uri (git-reference
|
||||||
|
@ -280,7 +280,7 @@ alternatives. In compilers, this can reduce the cascade of secondary errors.")
|
||||||
(file-name (git-file-name name version))
|
(file-name (git-file-name name version))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1w26aqvzxv4c70gcd1vw1pldapsc2xcacwq9b7dqx5m44j0zx1dc"))
|
"1yzi8171p1mnszyf80lqkl05ql25n73s5gn8pcgvv4jph4yvasnq"))
|
||||||
(patches (search-patches "kodi-skip-test-449.patch"
|
(patches (search-patches "kodi-skip-test-449.patch"
|
||||||
"kodi-set-libcurl-ssl-parameters.patch"))
|
"kodi-set-libcurl-ssl-parameters.patch"))
|
||||||
(snippet
|
(snippet
|
||||||
|
|
|
@ -4,13 +4,14 @@ connections work we can set them based on SSL_CERT_DIR and SSL_CERT_FILE.
|
||||||
--- a/xbmc/filesystem/CurlFile.cpp
|
--- a/xbmc/filesystem/CurlFile.cpp
|
||||||
+++ b/xbmc/filesystem/CurlFile.cpp
|
+++ b/xbmc/filesystem/CurlFile.cpp
|
||||||
@@ -626,5 +626,9 @@
|
@@ -626,5 +626,9 @@
|
||||||
// Setup allowed TLS/SSL ciphers. New versions of cURL may deprecate things that are still in use.
|
|
||||||
if (!m_cipherlist.empty())
|
if (!m_cipherlist.empty())
|
||||||
g_curlInterface.easy_setopt(h, CURLOPT_SSL_CIPHER_LIST, m_cipherlist.c_str());
|
g_curlInterface.easy_setopt(h, CURLOPT_SSL_CIPHER_LIST, m_cipherlist.c_str());
|
||||||
+
|
|
||||||
+ // Load certificate data from environment paths
|
+ // Load certificate data from environment paths
|
||||||
+ g_curlInterface.easy_setopt(m_state->m_easyHandle, CURLOPT_CAPATH, getenv("SSL_CERT_DIR"));
|
+ g_curlInterface.easy_setopt(m_state->m_easyHandle, CURLOPT_CAPATH, getenv("SSL_CERT_DIR"));
|
||||||
+ g_curlInterface.easy_setopt(m_state->m_easyHandle, CURLOPT_CAINFO, getenv("SSL_CERT_FILE"));
|
+ g_curlInterface.easy_setopt(m_state->m_easyHandle, CURLOPT_CAINFO, getenv("SSL_CERT_FILE"));
|
||||||
|
+
|
||||||
|
// enable HTTP2 support. default: CURL_HTTP_VERSION_1_1. Curl >= 7.62.0 defaults to CURL_HTTP_VERSION_2TLS
|
||||||
|
g_curlInterface.easy_setopt(h, CURLOPT_HTTP_VERSION, CURL_HTTP_VERSION_2_0);
|
||||||
|
-
|
||||||
}
|
}
|
||||||
|
|
||||||
void CCurlFile::SetRequestHeaders(CReadState* state)
|
|
Loading…
Reference in New Issue