gnu: bcftools: Update to 1.5.
* gnu/packages/bioinformatics.scm (bcftools): Update to 1.5. [origin]: Remove fix-makefile patch. [arguments]: Add configure flags, add LIBS make flag. Do not delete configure phase. * gnu/packages/patches/bcftools-fix-makefile.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
63fa0ffcd4
commit
0620387a59
|
@ -522,7 +522,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/awesome-reproducible-png.patch \
|
||||
%D%/packages/patches/azr3.patch \
|
||||
%D%/packages/patches/bash-completion-directories.patch \
|
||||
%D%/packages/patches/bcftools-fix-makefile.patch \
|
||||
%D%/packages/patches/binutils-ld-new-dtags.patch \
|
||||
%D%/packages/patches/binutils-loongson-workaround.patch \
|
||||
%D%/packages/patches/binutils-mips-bash-bug.patch \
|
||||
|
|
|
@ -300,7 +300,7 @@ BAM files.")
|
|||
(define-public bcftools
|
||||
(package
|
||||
(name "bcftools")
|
||||
(version "1.4.1")
|
||||
(version "1.5")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append
|
||||
|
@ -308,18 +308,19 @@ BAM files.")
|
|||
version "/bcftools-" version ".tar.bz2"))
|
||||
(sha256
|
||||
(base32
|
||||
"024xv59bzv148b6w3das4jmldf7rywsf8y1fbqznap008qc8gl6p"))
|
||||
(patches (search-patches "bcftools-fix-makefile.patch"))
|
||||
"0093hkkvxmbwfaa7905s6185jymynvg42kq6sxv7fili11l5mxwz"))
|
||||
(modules '((guix build utils)))
|
||||
(snippet
|
||||
;; Delete bundled htslib.
|
||||
'(delete-file-recursively "htslib-1.4.1"))))
|
||||
'(delete-file-recursively "htslib-1.5"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
`(#:test-target "test"
|
||||
#:configure-flags (list "--with-htslib=system")
|
||||
#:make-flags
|
||||
(list
|
||||
"USE_GPL=1"
|
||||
"LIBS=-lgsl -lgslcblas"
|
||||
(string-append "prefix=" (assoc-ref %outputs "out"))
|
||||
(string-append "HTSDIR=" (assoc-ref %build-inputs "htslib") "/include")
|
||||
(string-append "HTSLIB=" (assoc-ref %build-inputs "htslib") "/lib/libhts.so")
|
||||
|
@ -328,7 +329,6 @@ BAM files.")
|
|||
(string-append "PACKAGE_VERSION=" ,version))
|
||||
#:phases
|
||||
(modify-phases %standard-phases
|
||||
(delete 'configure)
|
||||
(add-before 'check 'patch-tests
|
||||
(lambda _
|
||||
(substitute* "test/test.pl"
|
||||
|
|
|
@ -1,33 +0,0 @@
|
|||
diff --git a/Makefile b/Makefile
|
||||
index edd2c4a..73b25ea 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -30,8 +30,8 @@ all: $(PROG) $(TEST_PROG)
|
||||
|
||||
# Adjust $(HTSDIR) to point to your top-level htslib directory
|
||||
HTSDIR = htslib-1.4.1
|
||||
-include $(HTSDIR)/htslib.mk
|
||||
-include $(HTSDIR)/htslib_static.mk
|
||||
+#include $(HTSDIR)/htslib.mk
|
||||
+#include $(HTSDIR)/htslib_static.mk
|
||||
HTSLIB = $(HTSDIR)/libhts.a
|
||||
BGZIP = $(HTSDIR)/bgzip
|
||||
TABIX = $(HTSDIR)/tabix
|
||||
@@ -73,7 +73,7 @@ GSL_LIBS =
|
||||
ifdef USE_GPL
|
||||
EXTRA_CPPFLAGS += -DUSE_GPL
|
||||
OBJS += polysomy.o peakfit.o
|
||||
- GSL_LIBS = -lgsl -lcblas
|
||||
+ GSL_LIBS = -lgsl -lgslcblas
|
||||
endif
|
||||
|
||||
prefix = /usr/local
|
||||
@@ -217,7 +217,7 @@ test/test-regidx.o: test/test-regidx.c regidx.h
|
||||
test/test-regidx: test/test-regidx.o regidx.o $(HTSLIB)
|
||||
$(CC) $(ALL_LDFLAGS) -o $@ $^ $(HTSLIB) -lpthread $(HTSLIB_LIBS) $(ALL_LIBS)
|
||||
|
||||
-bcftools: $(HTSLIB) $(OBJS)
|
||||
+bcftools: $(OBJS)
|
||||
$(CC) $(ALL_LDFLAGS) -o $@ $(OBJS) $(HTSLIB) -lpthread $(HTSLIB_LIBS) $(GSL_LIBS) $(ALL_LIBS)
|
||||
|
||||
doc/bcftools.1: doc/bcftools.txt
|
Loading…
Reference in New Issue