gnu: clang-runtime: Adapt for glibc@2.28.
* gnu/packages/llvm.scm (clang-runtime@3.7, clang-runtime@3.8, clang-runtime@3.9)[patches]: Add patch to work around removed ustat.h. * gnu/packages/patches/clang-3.5-libsanitizer-ustat-fix.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it.
This commit is contained in:
parent
68b0226b2a
commit
0627f93db6
|
@ -613,6 +613,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/ceph-skip-unittest_blockdev.patch \
|
||||
%D%/packages/patches/chmlib-inttypes.patch \
|
||||
%D%/packages/patches/clang-3.5-libc-search-path.patch \
|
||||
%D%/packages/patches/clang-3.5-libsanitizer-ustat-fix.patch \
|
||||
%D%/packages/patches/clang-3.8-libc-search-path.patch \
|
||||
%D%/packages/patches/clang-6.0-libc-search-path.patch \
|
||||
%D%/packages/patches/clang-runtime-asan-build-fixes.patch \
|
||||
|
|
|
@ -7,6 +7,7 @@
|
|||
;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
|
||||
;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
|
||||
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
|
||||
;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
|
||||
;;;
|
||||
;;; This file is part of GNU Guix.
|
||||
;;;
|
||||
|
@ -270,7 +271,8 @@ code analysis tools.")
|
|||
llvm-3.9.1
|
||||
"16gc2gdmp5c800qvydrdhsp0bzb97s8wrakl6i8a4lgslnqnf2fk"
|
||||
'("clang-runtime-asan-build-fixes.patch"
|
||||
"clang-runtime-esan-build-fixes.patch")))
|
||||
"clang-runtime-esan-build-fixes.patch"
|
||||
"clang-3.5-libsantitizer-ustat-fix.patch")))
|
||||
|
||||
(define-public clang-3.9.1
|
||||
(clang-from-llvm llvm-3.9.1 clang-runtime-3.9.1
|
||||
|
@ -294,7 +296,8 @@ code analysis tools.")
|
|||
(clang-runtime-from-llvm
|
||||
llvm-3.8
|
||||
"0p0y85c7izndbpg2l816z7z7558axq11d5pwkm4h11sdw7d13w0d"
|
||||
'("clang-runtime-asan-build-fixes.patch")))
|
||||
'("clang-runtime-asan-build-fixes.patch"
|
||||
"clang-3.5-libsantitizer-ustat-fix.patch")))
|
||||
|
||||
(define-public clang-3.8
|
||||
(clang-from-llvm llvm-3.8 clang-runtime-3.8
|
||||
|
@ -317,7 +320,8 @@ code analysis tools.")
|
|||
(clang-runtime-from-llvm
|
||||
llvm-3.7
|
||||
"10c1mz2q4bdq9bqfgr3dirc6hz1h3sq8573srd5q5lr7m7j6jiwx"
|
||||
'("clang-runtime-asan-build-fixes.patch")))
|
||||
'("clang-runtime-asan-build-fixes.patch"
|
||||
"clang-3.5-libsantitizer-ustat-fix.patch")))
|
||||
|
||||
(define-public clang-3.7
|
||||
(clang-from-llvm llvm-3.7 clang-runtime-3.7
|
||||
|
|
|
@ -0,0 +1,46 @@
|
|||
From d9d97cac3702b99a00cd113de98c41eb535d47ed Mon Sep 17 00:00:00 2001
|
||||
From: Efraim Flashner <efraim@flashner.co.il>
|
||||
Date: Sun, 14 Oct 2018 12:11:30 +0300
|
||||
Subject: [PATCH] patch modified from the gcc patch series, also dealing with
|
||||
ustat.
|
||||
|
||||
---
|
||||
.../sanitizer_platform_limits_posix.cc | 15 +++++++++++++--
|
||||
1 file changed, 13 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/lib/sanitizer_common/sanitizer_platform_limits_posix.cc b/lib/sanitizer_common/sanitizer_platform_limits_posix.cc
|
||||
index 29fea6e..570b9a5 100644
|
||||
--- a/lib/sanitizer_common/sanitizer_platform_limits_posix.cc
|
||||
+++ b/lib/sanitizer_common/sanitizer_platform_limits_posix.cc
|
||||
@@ -129,7 +129,6 @@
|
||||
#include <sys/statvfs.h>
|
||||
#include <sys/timex.h>
|
||||
#include <sys/user.h>
|
||||
-#include <sys/ustat.h>
|
||||
#include <linux/cyclades.h>
|
||||
#include <linux/if_eql.h>
|
||||
#include <linux/if_plip.h>
|
||||
@@ -222,7 +221,19 @@ namespace __sanitizer {
|
||||
#endif // SANITIZER_LINUX || SANITIZER_FREEBSD
|
||||
|
||||
#if SANITIZER_LINUX && !SANITIZER_ANDROID
|
||||
- unsigned struct_ustat_sz = sizeof(struct ustat);
|
||||
+ // Use pre-computed size of struct ustat to avoid <sys/ustat.h> which
|
||||
+ // has been removed from glibc 2.28.
|
||||
+#if defined(__aarch64__) || defined(__s390x__) || defined (__mips64) \
|
||||
+ || defined(__powerpc64__) || defined(__arch64__) || defined(__sparcv9) \
|
||||
+ || defined(__x86_64__)
|
||||
+#define SIZEOF_STRUCT_USTAT 32
|
||||
+#elif defined(__arm__) || defined(__i386__) || defined(__mips__) \
|
||||
+ || defined(__powerpc__) || defined(__s390__)
|
||||
+#define SIZEOF_STRUCT_USTAT 20
|
||||
+#else
|
||||
+#error Unknown size of struct ustat
|
||||
+#endif
|
||||
+ unsigned struct_ustat_sz = SIZEOF_STRUCT_USTAT;
|
||||
unsigned struct_rlimit64_sz = sizeof(struct rlimit64);
|
||||
unsigned struct_statvfs64_sz = sizeof(struct statvfs64);
|
||||
#endif // SANITIZER_LINUX && !SANITIZER_ANDROID
|
||||
--
|
||||
2.19.1
|
||||
|
Loading…
Reference in New Issue