gnu: Add python-rarfile.

* gnu/packages/python.scm (python-rarfile, python2-rarfile): New
variables.
* gnu/packages/patches/python-rarfile-fix-tests.patch: New file.
* gnu-system.am (dist_patch_DATA): Add it.
master
Leo Famulari 2016-02-14 02:12:27 -05:00
parent 13edb0e5c3
commit 064503aaa2
3 changed files with 47 additions and 0 deletions

View File

@ -701,6 +701,7 @@ dist_patch_DATA = \
gnu/packages/patches/python-disable-ssl-test.patch \
gnu/packages/patches/python-fix-tests.patch \
gnu/packages/patches/python-ipython-inputhook-ctype.patch \
gnu/packages/patches/python-rarfile-fix-tests.patch \
gnu/packages/patches/python2-rdflib-drop-sparqlwrapper.patch \
gnu/packages/patches/python-configobj-setuptools.patch \
gnu/packages/patches/python-paste-remove-website-test.patch \

View File

@ -0,0 +1,14 @@
There is no test.sh, but there are test1.sh and test2.sh.
diff --git a/test/Makefile b/test/Makefile
index 027bc5f..5383db3 100644
--- a/test/Makefile
+++ b/test/Makefile
@@ -1,5 +1,6 @@
test:
- ./test.sh
+ ./test1.sh
+ ./test2.sh
clean:
rm -rf __pycache__

View File

@ -8438,3 +8438,35 @@ encoding algorithms to do fuzzy string matching.")
(description "Unicodecsv is a drop-in replacement for Python 2.7's CSV
module, adding support for Unicode strings.")
(license bsd-2)))
(define-public python-rarfile
(package
(name "python-rarfile")
(version "2.7")
(source (origin
(method url-fetch)
(uri (pypi-uri "rarfile" version))
(sha256
(base32
"0d8n1dlpiz7av8dmbp0vclrwl9cnxizr4f2c9xvj1h5nvn480527"))
;; https://github.com/markokr/rarfile/pull/17/
(patches (list (search-patch "python-rarfile-fix-tests.patch")))))
(build-system python-build-system)
(arguments
'(#:phases
(modify-phases %standard-phases
(replace 'check
;; Many tests fail, but the installation proceeds.
(lambda _ (zero? (system* "make" "-C" "test" "test")))))))
(native-inputs
`(("which" ,which))) ; required for tests
(propagated-inputs
`(("libarchive" ,libarchive)))
(home-page "https://github.com/markokr/rarfile")
(synopsis "RAR archive reader for Python")
(description "This is Python module for RAR archive reading. The interface
is made as zipfile like as possible.")
(license isc)))
(define-public python2-rarfile
(package-with-python2 python-rarfile))