gnu: GnuTLS: Update to 3.6.5.

* gnu/packages/patches/gnutls-skip-pkgconfig-test.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
* gnu/packages/tls.scm (gnutls): Update to 3.6.5.
[source](patches): Remove obsolete.
[source](snippet): Add Guile detection fix.
* gnu/packages/gnome.scm (libsoup)[arguments]: Adjust 'certtool' invokation to
cope with the new API.
master
Marius Bakke 2018-12-10 02:38:32 +01:00
parent cc2e0566be
commit 06f5bc4e12
No known key found for this signature in database
GPG Key ID: A2A06DF2A33A54FA
4 changed files with 14 additions and 31 deletions

View File

@ -772,7 +772,6 @@ dist_patch_DATA = \
%D%/packages/patches/gnucash-price-quotes-perl.patch \
%D%/packages/patches/gnucash-disable-failing-tests.patch \
%D%/packages/patches/gnutls-skip-trust-store-test.patch \
%D%/packages/patches/gnutls-skip-pkgconfig-test.patch \
%D%/packages/patches/gobject-introspection-absolute-shlib-path.patch \
%D%/packages/patches/gobject-introspection-cc.patch \
%D%/packages/patches/gobject-introspection-girepository.patch \

View File

@ -2556,7 +2556,8 @@ libxml to ease remote use of the RESTful API.")
"" ;URI of subject
"127.0.0.1" ;IP address of subject
"" ;signing?
"" ;encryption?
"" ;encryption (RSA)?
"" ;data encryption?
"" ;sign OCSP requests?
"" ;sign code?
"" ;time stamping?

View File

@ -1,24 +0,0 @@
FIXME: The static test fails with an error such as:
/tmp/guix-build-gnutls-3.5.13.drv-0/ccOnGPmc.o: In function `main':
c.29617.tmp.c:(.text+0x5): undefined reference to `gnutls_global_init'
collect2: error: ld returned 1 exit status
FAIL pkgconfig.sh (exit status: 1)
diff --git a/tests/pkgconfig.sh b/tests/pkgconfig.sh
index 6bd4e62f9..05aab8278 100755
--- a/tests/pkgconfig.sh
+++ b/tests/pkgconfig.sh
@@ -57,11 +57,7 @@ echo "Trying dynamic linking with:"
echo " * flags: $(${PKGCONFIG} --libs gnutls)"
echo " * common: ${COMMON}"
echo " * lib: ${CFLAGS}"
-cc ${TMPFILE} -o ${TMPFILE_O} $(${PKGCONFIG} --libs gnutls) $(${PKGCONFIG} --cflags gnutls) ${COMMON}
-
-echo ""
-echo "Trying static linking with $(${PKGCONFIG} --libs --static gnutls)"
-cc ${TMPFILE} -o ${TMPFILE_O} $(${PKGCONFIG} --static --libs gnutls) $(${PKGCONFIG} --cflags gnutls) ${COMMON}
+gcc ${TMPFILE} -o ${TMPFILE_O} $(${PKGCONFIG} --libs gnutls) $(${PKGCONFIG} --cflags gnutls) ${COMMON}
rm -f ${TMPFILE} ${TMPFILE_O}

View File

@ -162,7 +162,7 @@ living in the same process.")
(define-public gnutls
(package
(name "gnutls")
(version "3.5.18")
(version "3.6.5")
(source (origin
(method url-fetch)
(uri
@ -171,12 +171,19 @@ living in the same process.")
(string-append "mirror://gnupg/gnutls/v"
(version-major+minor version)
"/gnutls-" version ".tar.xz"))
(patches
(search-patches "gnutls-skip-trust-store-test.patch"
"gnutls-skip-pkgconfig-test.patch"))
(patches (search-patches "gnutls-skip-trust-store-test.patch"))
(sha256
(base32
"0d02x28fwkkx7xzn7807nww6idchizzq3plx8sfcyiw7wzclh8mf"))))
"0ddvg97dyrh8dkffv1mdc0knxx5my3qdbzv97s4a6jggmk9wwgh7"))
(modules '((guix build utils)))
(snippet
'(begin
;; XXX: The generated configure script in GnuTLS 3.6.5
;; apparently does not know about Guile 2.2.
(substitute* "configure"
(("guile_versions_to_search=\"2\\.0 1\\.8\"")
"guile_versions_to_search=\"2.2 2.0 1.8\""))
#t))))
(build-system gnu-build-system)
(arguments
`(; Ensure we don't keep a reference to this buggy software.