gnu: weechat: Update to 2.6.

* gnu/packages/irc.scm (weechat): Update to 2.6.
[source]: Remove obsolete patch.
[inputs]: Replace python-2 with python(@3).
[arguments]: Remove ‘wrap’ phase.
* gnu/packages/patches/weechat-python.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
master
Tobias Geerinckx-Rice 2019-09-10 15:26:38 +02:00
parent 4eb69bf0d3
commit 07c0110eac
No known key found for this signature in database
GPG Key ID: 0DB0FF884F556D79
3 changed files with 7 additions and 54 deletions

View File

@ -1398,7 +1398,6 @@ dist_patch_DATA = \
%D%/packages/patches/wavpack-CVE-2018-6767.patch \
%D%/packages/patches/wavpack-CVE-2018-7253.patch \
%D%/packages/patches/wavpack-CVE-2018-7254.patch \
%D%/packages/patches/weechat-python.patch \
%D%/packages/patches/wicd-bitrate-none-fix.patch \
%D%/packages/patches/wicd-get-selected-profile-fix.patch \
%D%/packages/patches/wicd-urwid-1.3.patch \

View File

@ -5,7 +5,7 @@
;;; Copyright © 2015, 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 ng0 <ng0@n0.is>
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@ -166,15 +166,14 @@ SILC and ICB protocols via plugins.")
(define-public weechat
(package
(name "weechat")
(version "2.5")
(version "2.6")
(source (origin
(method url-fetch)
(uri (string-append "https://weechat.org/files/src/weechat-"
version ".tar.xz"))
(sha256
(base32
"09sc5lf7z70x3iw87q4zh8rbyngsw89pwnzs5jk195zzqdspgj2j"))
(patches (search-patches "weechat-python.patch"))))
"0j2iflnfvv31q2l9r67r8aj3ipggqfm2r2dpy7pvdpxgwwq337ps"))))
(build-system cmake-build-system)
(native-inputs
`(("gettext" ,gettext-minimal)
@ -187,9 +186,11 @@ SILC and ICB protocols via plugins.")
("aspell" ,aspell)
("curl" ,curl)
("gnutls" ,gnutls)
;; Scripting language plug-ins.
("guile" ,guile-2.0)
("lua" ,lua-5.1)
("python" ,python-2)
("python" ,python)
("perl" ,perl)
("tcl" ,tcl)))
(arguments
@ -214,14 +215,7 @@ SILC and ICB protocols via plugins.")
(substitute* "tests/scripts/test-scripts.cpp"
((".*\\{ \"(javascript|php|ruby)\", " all)
(string-append "// SKIP" all)))
#t))
(add-after 'install 'wrap
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
(py2 (assoc-ref inputs "python")))
(wrap-program (string-append out "/bin/weechat")
`("PATH" ":" prefix (,(string-append py2 "/bin"))))
#t))))))
#t)))))
(synopsis "Extensible chat client")
(description "WeeChat (Wee Enhanced Environment for Chat) is an
@dfn{Internet Relay Chat} (IRC) client, which is designed to be light and fast.

View File

@ -1,40 +0,0 @@
Get Python LDFLAGS from 'pkg-config'.
The other approach is more complex and gets it wrong: it returns
"-L/path/to/python/lib/python-2.7.10/lib/python2.7/config -lpython -lwhatever";
since that config/ sub-directory contains libpython2.7.a, we end up
statically linking Python in Weechat's python.so, which we do not want.
--- weechat-1.3/configure.ac 2015-08-16 08:27:07.000000000 +0200
+++ weechat-1.3/configure.ac 2015-11-29 18:18:52.975197048 +0100
@@ -535,29 +535,7 @@ if test "x$enable_python" = "xyes" ; the
if test -r "$PYTHON_INCLUDE/Python.h"; then
PYTHON_CFLAGS="-I$PYTHON_INCLUDE"
AC_MSG_RESULT(found)
- PYTHON_LIB=`$PYTHON -c "import sys, distutils.sysconfig; sys.stdout.write(distutils.sysconfig.get_config_var('LIBPL'))"`
- PYTHON_LFLAGS="-lpython$PYTHON_VERSION "`$PYTHON -c "import sys, distutils.sysconfig; sys.stdout.write(distutils.sysconfig.get_config_var('LIBS')+' '+distutils.sysconfig.get_config_var('SYSLIBS')+' '+distutils.sysconfig.get_config_var('LINKFORSHARED'))"`
- AC_MSG_CHECKING(for Python library)
- if test -r "$PYTHON_LIB/libpython$PYTHON_VERSION.so"; then
- PYTHON_LFLAGS="-L$PYTHON_LIB $PYTHON_LFLAGS"
- AC_MSG_RESULT(found)
- elif test -r "$PYTHON_LIB/libpython$PYTHON_VERSION.a"; then
- PYTHON_LFLAGS="-L$PYTHON_LIB $PYTHON_LFLAGS"
- AC_MSG_RESULT(found)
- elif test -r "$PYTHON_LIB/libpython$PYTHON_VERSION.dll.a"; then
- PYTHON_LFLAGS="-L$PYTHON_LIB $PYTHON_LFLAGS"
- AC_MSG_RESULT(found)
- elif test -r "$PYTHON_SYSPREFIX/lib/libpython$PYTHON_VERSION.so"; then
- PYTHON_LFLAGS="-L$PYTHON_SYSPREFIX/lib/ $PYTHON_LFLAGS"
- AC_MSG_RESULT(found)
- else
- AC_MSG_WARN([
-*** Python library couldn't be found on your system.
-*** Try to install it with your software package manager.
-*** WeeChat will be built without Python support.])
- enable_python="no"
- not_found="$not_found python"
- fi
+ PYTHON_LFLAGS=`pkg-config python2 --libs`
else
AC_MSG_WARN([
*** Python header files couldn't be found on your system.