gnu: emacs-realgud: Update to 1.5.0.

* gnu/packages/emacs-xyz.scm (emacs-realgud): Update to 1.5.0.
[source]: Fetch from git.
Remove upstreamed patch.
* gnu/packages/patches/emacs-realgud-fix-configure-ac.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
master
Brian Leung 2019-06-07 06:31:55 +02:00 committed by Ludovic Courtès
parent ed8a551653
commit 0882c491f0
No known key found for this signature in database
GPG Key ID: 090B11993D9AEBB5
3 changed files with 6 additions and 42 deletions

View File

@ -762,7 +762,6 @@ dist_patch_DATA = \
%D%/packages/patches/emacs-highlight-stages-add-gexp.patch \
%D%/packages/patches/emacs-scheme-complete-scheme-r5rs-info.patch \
%D%/packages/patches/emacs-source-date-epoch.patch \
%D%/packages/patches/emacs-realgud-fix-configure-ac.patch \
%D%/packages/patches/emacs-undohist-ignored.patch \
%D%/packages/patches/emacs-wordnut-require-adaptive-wrap.patch \
%D%/packages/patches/emacs-zones-called-interactively.patch \

View File

@ -4336,19 +4336,16 @@ after buffer changes.")
(define-public emacs-realgud
(package
(name "emacs-realgud")
(version "1.4.5")
(version "1.5.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://elpa.gnu.org/packages/realgud-"
version ".tar"))
(method git-fetch)
(uri (git-reference
(url "https://github.com/realgud/realgud/")
(commit version)))
(sha256
(base32
"108wgxg7fb4byaiasgvbxv2hq7b00biq9f0mh9hy6vw4160y5w24"))
(patches
;; Patch awaiting inclusion upstream (see:
;; https://github.com/realgud/realgud/pull/226).
(search-patches "emacs-realgud-fix-configure-ac.patch"))))
"0xnick9016wxrgi8v0lycvxhyz8l2k4nfvdpjc5yq476vwrjfzbz"))))
(build-system emacs-build-system)
(arguments
`(#:tests? #t
@ -4367,11 +4364,6 @@ after buffer changes.")
(setenv "HOME" (getenv "TMPDIR"))))
(add-before 'patch-el-files 'remove-realgud-pkg.el
(lambda _
;; XXX: This file is auto-generated at some point and causes
;; substitute* to crash during the `patch-el-files' phase with:
;; ERROR: In procedure stat: No such file or directory:
;; "./realgud-pkg.el"
(delete-file "./realgud-pkg.el")
;; FIXME: `patch-el-files' crashes on this file with error:
;; unable to locate "bashdb".
(delete-file "./test/test-regexp-bashdb.el"))))

View File

@ -1,27 +0,0 @@
From a293690f29407ac54a218d6d20c2142e1a0319d1 Mon Sep 17 00:00:00 2001
From: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Date: Wed, 31 Oct 2018 00:08:34 -0400
Subject: [PATCH] configure.ac: Fix NO_CHECK_EMACS_PACKAGES elisp.
Remove the extraneous trailing parenthesis.
---
configure.ac | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/configure.ac b/configure.ac
index de0d932..69bcea7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -25,8 +25,7 @@ AC_MSG_NOTICE("Checking prerequiste packages")
$EMACS -batch -q --no-site-file -eval \
'(dolist (package
(quote (cl-lib loc-changes load-relative test-simple)))
- (require package))
- )'
+ (require package))'
fi
if test $? -ne 0 ; then
AC_MSG_ERROR([Can't continue until above error is corrected.])
--
2.19.0