From 0adc21c2933fbe47ee37d90acdb4ad8cbc60ed69 Mon Sep 17 00:00:00 2001
From: Efraim Flashner <efraim@flashner.co.il>
Date: Mon, 4 Jul 2016 20:45:30 +0300
Subject: [PATCH] gnu: Add python2-pytest-cache.

* gnu/packages/python.scm (python2-pytest-cache): New variable.
(python-pytest-cache)[properties]: New field.
---
 gnu/packages/python.scm | 12 +++++++++++-
 1 file changed, 11 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 49f0b88020..3505f36b4c 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7091,7 +7091,17 @@ minimal and fast API targetting the following uses:
     (description "The pytest-cache plugin provides tools to rerun failures from
 the last py.test invocation.")
     (home-page "https://bitbucket.org/hpk42/pytest-cache/")
-    (license license:expat)))
+    (license license:expat)
+    (properties `((python2-variant . ,(delay python2-pytest-cache))))))
+
+(define-public python2-pytest-cache
+  (let ((pytest-cache (package-with-python2
+                        (strip-python2-variant python-pytest-cache))))
+    (package
+      (inherit pytest-cache)
+      (native-inputs
+       `(("python2-setuptools" ,python2-setuptools)
+         ,@(package-native-inputs pytest-cache))))))
 
 (define-public python-pytest-localserver
   (package