gnu: procps: Update to 3.3.11.
procps-ng is the new upstream. * gnu/packages/procps.scm (procps): Update to 3.3.11. [source]: Adjust formatting. Remove patches. [home-page]: Update URL. * gnu/packages/patches/procps-make-3.82.patch: Remove file. * gnu-system.am (dist_patch_DATA): Remove it.
This commit is contained in:
parent
b85d098410
commit
0cc2284819
|
@ -603,7 +603,6 @@ dist_patch_DATA = \
|
|||
gnu/packages/patches/portaudio-audacity-compat.patch \
|
||||
gnu/packages/patches/preseq-1.0.2-install-to-PREFIX.patch \
|
||||
gnu/packages/patches/preseq-1.0.2-link-with-libbam.patch \
|
||||
gnu/packages/patches/procps-make-3.82.patch \
|
||||
gnu/packages/patches/pt-scotch-build-parallelism.patch \
|
||||
gnu/packages/patches/pulseaudio-fix-mult-test.patch \
|
||||
gnu/packages/patches/pulseaudio-longer-test-timeout.patch \
|
||||
|
|
|
@ -457,62 +457,34 @@ providing the system administrator with some help in common tasks.")
|
|||
(define-public procps
|
||||
(package
|
||||
(name "procps")
|
||||
(version "3.2.8")
|
||||
(version "3.3.11")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
;; A mirror://sourceforge URI doesn't work, presumably becuase
|
||||
;; the SourceForge project is misconfigured.
|
||||
(uri (string-append "http://procps.sourceforge.net/procps-"
|
||||
version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"0d8mki0q4yamnkk4533kx8mc0jd879573srxhg6r2fs3lkc6iv8i"))
|
||||
(patches (list (search-patch "procps-make-3.82.patch")))))
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://sourceforge/procps-ng/Production/"
|
||||
"procps-ng-" version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"1va4n0mpsq327ca9dqp4hnrpgs6821rp0f2m0jyc1bfjl9lk2jg9"))))
|
||||
(build-system gnu-build-system)
|
||||
(inputs `(("ncurses" ,ncurses)))
|
||||
(arguments
|
||||
'(#:modules ((guix build utils)
|
||||
(guix build gnu-build-system)
|
||||
(srfi srfi-1)
|
||||
(srfi srfi-26))
|
||||
#:phases (alist-replace
|
||||
'configure
|
||||
(lambda* (#:key outputs #:allow-other-keys)
|
||||
;; No `configure', just a single Makefile.
|
||||
(let ((out (assoc-ref outputs "out")))
|
||||
(substitute* "Makefile"
|
||||
(("/usr/") "/")
|
||||
(("--(owner|group) 0") "")
|
||||
(("ldconfig") "true")
|
||||
(("^LDFLAGS[[:blank:]]*:=(.*)$" _ value)
|
||||
;; Add libproc to the RPATH.
|
||||
(string-append "LDFLAGS := -Wl,-rpath="
|
||||
out "/lib" value))))
|
||||
(setenv "CC" "gcc"))
|
||||
(alist-replace
|
||||
'install
|
||||
(lambda* (#:key outputs #:allow-other-keys)
|
||||
(let ((out (assoc-ref outputs "out")))
|
||||
(and (zero?
|
||||
(system* "make" "install"
|
||||
(string-append "DESTDIR=" out)))
|
||||
|
||||
;; Remove commands and man pages redundant with
|
||||
;; Coreutils.
|
||||
(let ((dup (append-map (cut find-files out <>)
|
||||
'("^kill" "^uptime"))))
|
||||
(for-each delete-file dup)
|
||||
#t)
|
||||
|
||||
;; Sanity check.
|
||||
(zero?
|
||||
(system* (string-append out "/bin/ps")
|
||||
"--version")))))
|
||||
%standard-phases))
|
||||
|
||||
;; What did you expect? Tests?
|
||||
#:tests? #f))
|
||||
(home-page "http://procps.sourceforge.net/")
|
||||
#:phases
|
||||
(modify-phases %standard-phases
|
||||
(add-after
|
||||
'install 'post-install
|
||||
;; Remove commands and man pages redudant with
|
||||
;; Coreutils.
|
||||
(lambda* (#:key outputs #:allow-other-keys)
|
||||
(let* ((out (assoc-ref outputs "out"))
|
||||
(dup (append-map (cut find-files out <>)
|
||||
'("^kill" "^uptime"))))
|
||||
(for-each delete-file dup)
|
||||
#t))))))
|
||||
(inputs `(("ncurses" ,ncurses)))
|
||||
(home-page "https://gitlab.com/procps-ng/procps/")
|
||||
(synopsis "Utilities that give information about processes")
|
||||
(description
|
||||
"Procps is the package that has a bunch of small useful utilities
|
||||
|
|
|
@ -1,14 +0,0 @@
|
|||
Fix compilation with GNU Make 3.82 (patch from Nixpkgs).
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 09fb3ed..59eba16 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -174,7 +174,7 @@ INSTALL := $(BINFILES) $(MANFILES)
|
||||
# want this rule first, use := on ALL, and ALL not filled in yet
|
||||
all: do_all
|
||||
|
||||
--include */module.mk
|
||||
+-include proc/module.mk ps/module.mk
|
||||
|
||||
do_all: $(ALL)
|
Loading…
Reference in New Issue