gnu: gcc-4.8: Update to 4.8.4.
* gnu/packages/gcc.scm (gcc-4.8): Update to 4.8.4. Remove patch. * gnu/packages/patches/gcc-fix-pr61801.patch: Remove. * gnu-system.am (dist_patch_DATA): Adjust accordingly.
This commit is contained in:
parent
763a401ed1
commit
0d12bc744e
|
@ -356,7 +356,6 @@ dist_patch_DATA = \
|
||||||
gnu/packages/patches/flex-bison-tests.patch \
|
gnu/packages/patches/flex-bison-tests.patch \
|
||||||
gnu/packages/patches/gawk-shell.patch \
|
gnu/packages/patches/gawk-shell.patch \
|
||||||
gnu/packages/patches/gcc-cross-environment-variables.patch \
|
gnu/packages/patches/gcc-cross-environment-variables.patch \
|
||||||
gnu/packages/patches/gcc-fix-pr61801.patch \
|
|
||||||
gnu/packages/patches/gd-mips64-deplibs-fix.patch \
|
gnu/packages/patches/gd-mips64-deplibs-fix.patch \
|
||||||
gnu/packages/patches/glib-tests-desktop.patch \
|
gnu/packages/patches/glib-tests-desktop.patch \
|
||||||
gnu/packages/patches/glib-tests-homedir.patch \
|
gnu/packages/patches/glib-tests-homedir.patch \
|
||||||
|
|
|
@ -261,15 +261,14 @@ Go. It also includes runtime support libraries for these languages.")
|
||||||
|
|
||||||
(define-public gcc-4.8
|
(define-public gcc-4.8
|
||||||
(package (inherit gcc-4.7)
|
(package (inherit gcc-4.7)
|
||||||
(version "4.8.3")
|
(version "4.8.4")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "mirror://gnu/gcc/gcc-"
|
(uri (string-append "mirror://gnu/gcc/gcc-"
|
||||||
version "/gcc-" version ".tar.bz2"))
|
version "/gcc-" version ".tar.bz2"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"07hg10zs7gnqz58my10ch0zygizqh0z0bz6pv4pgxx45n48lz3ka"))
|
"15c6gwm6dzsaagamxkak5smdkf1rdfbqqjs9jdbrp3lbg4ism02a"))))))
|
||||||
(patches (list (search-patch "gcc-fix-pr61801.patch")))))))
|
|
||||||
|
|
||||||
(define-public gcc-4.9
|
(define-public gcc-4.9
|
||||||
(package (inherit gcc-4.7)
|
(package (inherit gcc-4.7)
|
||||||
|
|
|
@ -1,25 +0,0 @@
|
||||||
GCC bug fix for <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=61801>.
|
|
||||||
Initially discussed at
|
|
||||||
<http://lists.gnu.org/archive/html/guix-devel/2014-09/msg00283.html>.
|
|
||||||
Patch from <https://gcc.gnu.org/viewcvs/gcc?view=revision&revision=212740>.
|
|
||||||
|
|
||||||
2014-07-17 Richard Biener <rguenther@suse.de>
|
|
||||||
|
|
||||||
PR rtl-optimization/61801
|
|
||||||
|
|
||||||
* sched-deps.c (sched_analyze_2): For ASM_OPERANDS and
|
|
||||||
ASM_INPUT don't set reg_pending_barrier if it appears in a
|
|
||||||
debug-insn.
|
|
||||||
|
|
||||||
--- gcc-4_8-branch/gcc/sched-deps.c 2014/07/17 07:48:49 212739
|
|
||||||
+++ gcc-4_8-branch/gcc/sched-deps.c 2014/07/17 07:49:44 212740
|
|
||||||
@@ -2744,7 +2744,8 @@
|
|
||||||
Consider for instance a volatile asm that changes the fpu rounding
|
|
||||||
mode. An insn should not be moved across this even if it only uses
|
|
||||||
pseudo-regs because it might give an incorrectly rounded result. */
|
|
||||||
- if (code != ASM_OPERANDS || MEM_VOLATILE_P (x))
|
|
||||||
+ if ((code != ASM_OPERANDS || MEM_VOLATILE_P (x))
|
|
||||||
+ && !DEBUG_INSN_P (insn))
|
|
||||||
reg_pending_barrier = TRUE_BARRIER;
|
|
||||||
|
|
||||||
/* For all ASM_OPERANDS, we must traverse the vector of input operands.
|
|
Loading…
Reference in New Issue