gnu: vtk: Upgrade to 7.1.0.
* gnu/packages/vtk.scm (vtk): Upgrade to 7.1.0. [source]: Remove patches. Use version-major+minor. * gnu/packages/patches/vtk-mesa-10.patch: Delete patch. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
996f5ece8c
commit
0e988a8483
|
@ -912,7 +912,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/vpnc-script.patch \
|
%D%/packages/patches/vpnc-script.patch \
|
||||||
%D%/packages/patches/vte-CVE-2012-2738-pt1.patch \
|
%D%/packages/patches/vte-CVE-2012-2738-pt1.patch \
|
||||||
%D%/packages/patches/vte-CVE-2012-2738-pt2.patch \
|
%D%/packages/patches/vte-CVE-2012-2738-pt2.patch \
|
||||||
%D%/packages/patches/vtk-mesa-10.patch \
|
|
||||||
%D%/packages/patches/weechat-python.patch \
|
%D%/packages/patches/weechat-python.patch \
|
||||||
%D%/packages/patches/wicd-bitrate-none-fix.patch \
|
%D%/packages/patches/wicd-bitrate-none-fix.patch \
|
||||||
%D%/packages/patches/wicd-get-selected-profile-fix.patch \
|
%D%/packages/patches/wicd-get-selected-profile-fix.patch \
|
||||||
|
|
|
@ -1,36 +0,0 @@
|
||||||
Fix build against new mesa. See:
|
|
||||||
|
|
||||||
https://bugs.freedesktop.org/show_bug.cgi?id=83631
|
|
||||||
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=765938
|
|
||||||
|
|
||||||
Description: fixes FTBFS against new libjpeg-turbo
|
|
||||||
Author: Ondřej Surý <ondrej@debian.org>
|
|
||||||
Bug-Debian: https://bugs.debian.org/765938
|
|
||||||
Reviewed-By: Anton Gladky <gladk@debian.org>
|
|
||||||
Last-Update: 2014-10-22
|
|
||||||
|
|
||||||
Index: vtk6-6.1.0+dfsg2/Rendering/OpenGL/vtkOpenGL.h
|
|
||||||
===================================================================
|
|
||||||
--- vtk6-6.1.0+dfsg2.orig/Rendering/OpenGL/vtkOpenGL.h
|
|
||||||
+++ vtk6-6.1.0+dfsg2/Rendering/OpenGL/vtkOpenGL.h
|
|
||||||
@@ -20,6 +20,7 @@
|
|
||||||
|
|
||||||
// To prevent gl.h to include glext.h provided by the system
|
|
||||||
#define GL_GLEXT_LEGACY
|
|
||||||
+#define GLX_GLEXT_LEGACY
|
|
||||||
#if defined(__APPLE__) && (defined(VTK_USE_CARBON) || defined(VTK_USE_COCOA))
|
|
||||||
# include <OpenGL/gl.h> // Include OpenGL API.
|
|
||||||
#else
|
|
||||||
Index: vtk6-6.1.0+dfsg2/Rendering/OpenGL/vtkXOpenGLRenderWindow.cxx
|
|
||||||
===================================================================
|
|
||||||
--- vtk6-6.1.0+dfsg2.orig/Rendering/OpenGL/vtkXOpenGLRenderWindow.cxx
|
|
||||||
+++ vtk6-6.1.0+dfsg2/Rendering/OpenGL/vtkXOpenGLRenderWindow.cxx
|
|
||||||
@@ -27,7 +27,7 @@
|
|
||||||
|
|
||||||
// define GLX_GLXEXT_LEGACY to prevent glx.h to include glxext.h provided by
|
|
||||||
// the system
|
|
||||||
-//#define GLX_GLXEXT_LEGACY
|
|
||||||
+#define GLX_GLXEXT_LEGACY
|
|
||||||
#include "GL/glx.h"
|
|
||||||
|
|
||||||
#include "vtkgl.h"
|
|
|
@ -1,6 +1,7 @@
|
||||||
;;; GNU Guix --- Functional package management for GNU
|
;;; GNU Guix --- Functional package management for GNU
|
||||||
;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
|
;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
|
||||||
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
|
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
|
||||||
|
;;; Copyright © 2016 Eric Bavier <bavier@member.fsf.org>
|
||||||
;;;
|
;;;
|
||||||
;;; This file is part of GNU Guix.
|
;;; This file is part of GNU Guix.
|
||||||
;;;
|
;;;
|
||||||
|
@ -29,17 +30,15 @@
|
||||||
(define-public vtk
|
(define-public vtk
|
||||||
(package
|
(package
|
||||||
(name "vtk")
|
(name "vtk")
|
||||||
(version "6.1.0")
|
(version "7.1.0")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "http://www.vtk.org/files/release/"
|
(uri (string-append "http://www.vtk.org/files/release/"
|
||||||
(substring version 0
|
(version-major+minor version)
|
||||||
(string-rindex version #\.))
|
|
||||||
"/VTK-" version ".tar.gz"))
|
"/VTK-" version ".tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0d7shccdkyj4mbh2riilslgx3gd28in4c7xpm0lxa1ln8w5g2zdx"))
|
"0yj96z58haan77gzilnqp7xpf8hg5jk11a3jx55p2ksd400s0gjz"))))
|
||||||
(patches (search-patches "vtk-mesa-10.patch"))))
|
|
||||||
(build-system cmake-build-system)
|
(build-system cmake-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
;; Build without '-g' to save space.
|
;; Build without '-g' to save space.
|
||||||
|
|
Loading…
Reference in New Issue