gnu: dealii: Update to 8.4.1.
* gnu/packages/maths.scm (dealii): Update to 8.4.1. * gnu/packages/patches/dealii-p4est-interface.patch: Remove file.
This commit is contained in:
parent
7b995c7bcb
commit
101e847294
|
@ -2247,7 +2247,7 @@ revised simplex and the branch-and-bound methods.")
|
||||||
(define-public dealii
|
(define-public dealii
|
||||||
(package
|
(package
|
||||||
(name "dealii")
|
(name "dealii")
|
||||||
(version "8.2.1")
|
(version "8.4.1")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
|
@ -2255,8 +2255,7 @@ revised simplex and the branch-and-bound methods.")
|
||||||
"download/v" version "/dealii-" version ".tar.gz"))
|
"download/v" version "/dealii-" version ".tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"185jych0gdnpkjwxni7pd0dda149492zwq2457xdjg76bzj78mnp"))
|
"1bdksvvyp1rj37df1ndh8j3x9nzpc3sazw8nd0hzvnlw0qnyk800"))
|
||||||
(patches (search-patches "dealii-p4est-interface.patch"))
|
|
||||||
(modules '((guix build utils)))
|
(modules '((guix build utils)))
|
||||||
(snippet
|
(snippet
|
||||||
;; Remove bundled sources: UMFPACK, TBB, muParser, and boost
|
;; Remove bundled sources: UMFPACK, TBB, muParser, and boost
|
||||||
|
|
|
@ -1,62 +0,0 @@
|
||||||
From upstream commit f764598c.
|
|
||||||
|
|
||||||
The p4est_connectivity_load function used to take an unsigned long as argument,
|
|
||||||
but this has been changed to size_t in p4est 1.0. This makes no difference on
|
|
||||||
64 bit systems, but leads to compiler errors on 32 bit systems. Fix this.
|
|
||||||
|
|
||||||
--- a/source/distributed/tria.cc
|
|
||||||
+++ b/source/distributed/tria.cc
|
|
||||||
@@ -204,7 +204,11 @@ namespace internal
|
|
||||||
static
|
|
||||||
int (&connectivity_is_valid) (types<2>::connectivity *connectivity);
|
|
||||||
|
|
||||||
-#if DEAL_II_P4EST_VERSION_GTE(0,3,4,3)
|
|
||||||
+#if DEAL_II_P4EST_VERSION_GTE(1,0,0,0)
|
|
||||||
+ static
|
|
||||||
+ types<2>::connectivity *(&connectivity_load) (const char *filename,
|
|
||||||
+ size_t *length);
|
|
||||||
+#elif DEAL_II_P4EST_VERSION_GTE(0,3,4,3)
|
|
||||||
static
|
|
||||||
types<2>::connectivity *(&connectivity_load) (const char *filename,
|
|
||||||
long unsigned *length);
|
|
||||||
@@ -384,7 +388,12 @@ namespace internal
|
|
||||||
*connectivity)
|
|
||||||
= p4est_connectivity_is_valid;
|
|
||||||
|
|
||||||
-#if DEAL_II_P4EST_VERSION_GTE(0,3,4,3)
|
|
||||||
+#if DEAL_II_P4EST_VERSION_GTE(1,0,0,0)
|
|
||||||
+ types<2>::connectivity *
|
|
||||||
+ (&functions<2>::connectivity_load) (const char *filename,
|
|
||||||
+ size_t *length)
|
|
||||||
+ = p4est_connectivity_load;
|
|
||||||
+#elif DEAL_II_P4EST_VERSION_GTE(0,3,4,3)
|
|
||||||
types<2>::connectivity *
|
|
||||||
(&functions<2>::connectivity_load) (const char *filename,
|
|
||||||
long unsigned *length)
|
|
||||||
@@ -564,7 +573,11 @@ namespace internal
|
|
||||||
static
|
|
||||||
int (&connectivity_is_valid) (types<3>::connectivity *connectivity);
|
|
||||||
|
|
||||||
-#if DEAL_II_P4EST_VERSION_GTE(0,3,4,3)
|
|
||||||
+#if DEAL_II_P4EST_VERSION_GTE(1,0,0,0)
|
|
||||||
+ static
|
|
||||||
+ types<3>::connectivity *(&connectivity_load) (const char *filename,
|
|
||||||
+ size_t *length);
|
|
||||||
+#elif DEAL_II_P4EST_VERSION_GTE(0,3,4,3)
|
|
||||||
static
|
|
||||||
types<3>::connectivity *(&connectivity_load) (const char *filename,
|
|
||||||
long unsigned *length);
|
|
||||||
@@ -747,7 +760,12 @@ namespace internal
|
|
||||||
*connectivity)
|
|
||||||
= p8est_connectivity_is_valid;
|
|
||||||
|
|
||||||
-#if DEAL_II_P4EST_VERSION_GTE(0,3,4,3)
|
|
||||||
+#if DEAL_II_P4EST_VERSION_GTE(1,0,0,0)
|
|
||||||
+ types<3>::connectivity *
|
|
||||||
+ (&functions<3>::connectivity_load) (const char *filename,
|
|
||||||
+ size_t *length)
|
|
||||||
+ = p8est_connectivity_load;
|
|
||||||
+#elif DEAL_II_P4EST_VERSION_GTE(0,3,4,3)
|
|
||||||
types<3>::connectivity *
|
|
||||||
(&functions<3>::connectivity_load) (const char *filename,
|
|
||||||
long unsigned *length)
|
|
Loading…
Reference in New Issue