gnu: Add amule.
* gnu/packages/networking.scm (amule): New public variable. * gnu/packages/patches/amule_crypto-6.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
This commit is contained in:
parent
b989c3e376
commit
1170198d65
|
@ -557,6 +557,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/aegis-test-fixup-1.patch \
|
%D%/packages/patches/aegis-test-fixup-1.patch \
|
||||||
%D%/packages/patches/aegis-test-fixup-2.patch \
|
%D%/packages/patches/aegis-test-fixup-2.patch \
|
||||||
%D%/packages/patches/agg-am_c_prototype.patch \
|
%D%/packages/patches/agg-am_c_prototype.patch \
|
||||||
|
%D%/packages/patches/amule-crypto-6.patch \
|
||||||
%D%/packages/patches/ansible-wrap-program-hack.patch \
|
%D%/packages/patches/ansible-wrap-program-hack.patch \
|
||||||
%D%/packages/patches/antiword-CVE-2014-8123.patch \
|
%D%/packages/patches/antiword-CVE-2014-8123.patch \
|
||||||
%D%/packages/patches/antlr3-3_1-fix-java8-compilation.patch \
|
%D%/packages/patches/antlr3-3_1-fix-java8-compilation.patch \
|
||||||
|
|
|
@ -19,6 +19,7 @@
|
||||||
;;; Copyright © 2017 Gábor Boskovits <boskovits@gmail.com>
|
;;; Copyright © 2017 Gábor Boskovits <boskovits@gmail.com>
|
||||||
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
|
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
|
||||||
;;; Copyright © 2018 Adam Van Ymeren <adam@vany.ca>
|
;;; Copyright © 2018 Adam Van Ymeren <adam@vany.ca>
|
||||||
|
;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
|
||||||
;;;
|
;;;
|
||||||
;;; This file is part of GNU Guix.
|
;;; This file is part of GNU Guix.
|
||||||
;;;
|
;;;
|
||||||
|
@ -56,6 +57,7 @@
|
||||||
#:use-module (gnu packages check)
|
#:use-module (gnu packages check)
|
||||||
#:use-module (gnu packages code)
|
#:use-module (gnu packages code)
|
||||||
#:use-module (gnu packages compression)
|
#:use-module (gnu packages compression)
|
||||||
|
#:use-module (gnu packages crypto)
|
||||||
#:use-module (gnu packages curl)
|
#:use-module (gnu packages curl)
|
||||||
#:use-module (gnu packages databases)
|
#:use-module (gnu packages databases)
|
||||||
#:use-module (gnu packages dejagnu)
|
#:use-module (gnu packages dejagnu)
|
||||||
|
@ -66,6 +68,7 @@
|
||||||
#:use-module (gnu packages gnome)
|
#:use-module (gnu packages gnome)
|
||||||
#:use-module (gnu packages gnupg)
|
#:use-module (gnu packages gnupg)
|
||||||
#:use-module (gnu packages gtk)
|
#:use-module (gnu packages gtk)
|
||||||
|
#:use-module (gnu packages image)
|
||||||
#:use-module (gnu packages libidn)
|
#:use-module (gnu packages libidn)
|
||||||
#:use-module (gnu packages linux)
|
#:use-module (gnu packages linux)
|
||||||
#:use-module (gnu packages lua)
|
#:use-module (gnu packages lua)
|
||||||
|
@ -84,6 +87,7 @@
|
||||||
#:use-module (gnu packages tls)
|
#:use-module (gnu packages tls)
|
||||||
#:use-module (gnu packages valgrind)
|
#:use-module (gnu packages valgrind)
|
||||||
#:use-module (gnu packages wm)
|
#:use-module (gnu packages wm)
|
||||||
|
#:use-module (gnu packages wxwidgets)
|
||||||
#:use-module (gnu packages xml)
|
#:use-module (gnu packages xml)
|
||||||
#:use-module (ice-9 match))
|
#:use-module (ice-9 match))
|
||||||
|
|
||||||
|
@ -1702,3 +1706,62 @@ file for more details.")
|
||||||
;; src/libstrongswan/plugins/blowfish/blowfish_crypter.c
|
;; src/libstrongswan/plugins/blowfish/blowfish_crypter.c
|
||||||
;; src/libstrongswan/plugins/des/des_crypter.c
|
;; src/libstrongswan/plugins/des/des_crypter.c
|
||||||
license:bsd-4))))
|
license:bsd-4))))
|
||||||
|
|
||||||
|
(define-public amule
|
||||||
|
(package
|
||||||
|
(name "amule")
|
||||||
|
(version "2.3.2")
|
||||||
|
(source (origin
|
||||||
|
(method url-fetch)
|
||||||
|
(uri (string-append
|
||||||
|
"https://github.com/amule-project/amule/archive/"
|
||||||
|
version ".tar.gz"))
|
||||||
|
(file-name (string-append name "-" version ".tar.gz"))
|
||||||
|
(sha256
|
||||||
|
(base32
|
||||||
|
"1wvcj0n9xz03xz5c2xwp6dwfp7sqjhhwbki3m0lwikskpn9lkzk2"))
|
||||||
|
;; Patch for adopting crypto++ >= 6.0.
|
||||||
|
(patches (search-patches "amule-crypto-6.patch"))))
|
||||||
|
(build-system gnu-build-system)
|
||||||
|
(arguments
|
||||||
|
`(#:phases
|
||||||
|
(modify-phases %standard-phases
|
||||||
|
(add-after 'patch-source-shebangs 'autogen
|
||||||
|
(lambda _
|
||||||
|
(invoke "sh" "autogen.sh")
|
||||||
|
#t)))
|
||||||
|
#:configure-flags
|
||||||
|
'("--disable-rpath"
|
||||||
|
"--enable-wxcas"
|
||||||
|
"--enable-cas"
|
||||||
|
"--enable-alc"
|
||||||
|
"--enable-alcc"
|
||||||
|
"--enable-xas"
|
||||||
|
"--enable-amulecmd"
|
||||||
|
"--enable-geoip"
|
||||||
|
"--enable-ccache"
|
||||||
|
"--enable-nls"
|
||||||
|
"--enable-optimize"
|
||||||
|
"--enable-amule-gui"
|
||||||
|
"--enable-amule-daemon"
|
||||||
|
"--enable-webserver"
|
||||||
|
"--with-denoise-level=0")))
|
||||||
|
(native-inputs
|
||||||
|
`(("autoconf" ,autoconf)
|
||||||
|
("automake" ,automake)
|
||||||
|
("gettext-minimal" ,gettext-minimal)
|
||||||
|
("perl" ,perl)))
|
||||||
|
(inputs
|
||||||
|
`(("zlib" ,zlib)
|
||||||
|
("crypto++" ,crypto++)
|
||||||
|
("libpng" ,libpng)
|
||||||
|
("wxwidgets-gtk2", wxwidgets-gtk2)))
|
||||||
|
(home-page "http://amule.org/")
|
||||||
|
(synopsis "Peer-to-peer client for the eD2K and Kademlia networks")
|
||||||
|
(description
|
||||||
|
"aMule is an eMule-like client for the eD2k and Kademlia peer-to-peer
|
||||||
|
file sharing networks. It includes a graphical user interface (GUI), a daemon
|
||||||
|
allowing you to run a client with no graphical interface, and a Web GUI for
|
||||||
|
remote access. The @command{amulecmd} command allows you to control aMule
|
||||||
|
remotely.")
|
||||||
|
(license license:gpl2+)))
|
||||||
|
|
|
@ -0,0 +1,45 @@
|
||||||
|
From d1d1368c7909ffd8423730afaa811ce7b6a3a8aa Mon Sep 17 00:00:00 2001
|
||||||
|
From: Tommy Jerry Mairo <tommy.mairo@gmail.com>
|
||||||
|
Date: Sun, 4 Feb 2018 12:42:00 -0800
|
||||||
|
Subject: [PATCH 1/2] Bugfix: API mismatch with crypto++ 6.0.0
|
||||||
|
|
||||||
|
---
|
||||||
|
src/ClientCreditsList.cpp | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/src/ClientCreditsList.cpp b/src/ClientCreditsList.cpp
|
||||||
|
index 3bea9fe2d..a7ae1e34c 100644
|
||||||
|
--- a/src/ClientCreditsList.cpp
|
||||||
|
+++ b/src/ClientCreditsList.cpp
|
||||||
|
@@ -312,7 +312,7 @@ void CClientCreditsList::InitalizeCrypting()
|
||||||
|
// calculate and store public key
|
||||||
|
CryptoPP::RSASSA_PKCS1v15_SHA_Verifier pubkey(*static_cast<CryptoPP::RSASSA_PKCS1v15_SHA_Signer *>(m_pSignkey));
|
||||||
|
CryptoPP::ArraySink asink(m_abyMyPublicKey, 80);
|
||||||
|
- pubkey.DEREncode(asink);
|
||||||
|
+ pubkey.AccessMaterial().Save(asink);
|
||||||
|
m_nMyPublicKeyLen = asink.TotalPutLength();
|
||||||
|
asink.MessageEnd();
|
||||||
|
} catch (const CryptoPP::Exception& e) {
|
||||||
|
|
||||||
|
From 88ba0ac952b78382445f2fff73c6792c0474dc62 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Tommy Jerry Mairo <tommy.mairo@gmail.com>
|
||||||
|
Date: Wed, 21 Mar 2018 11:56:28 -0700
|
||||||
|
Subject: [PATCH 2/2] Update: Change AccessMaterial to GetMaterial
|
||||||
|
|
||||||
|
---
|
||||||
|
src/ClientCreditsList.cpp | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/src/ClientCreditsList.cpp b/src/ClientCreditsList.cpp
|
||||||
|
index a7ae1e34c..69e881fd8 100644
|
||||||
|
--- a/src/ClientCreditsList.cpp
|
||||||
|
+++ b/src/ClientCreditsList.cpp
|
||||||
|
@@ -312,7 +312,7 @@ void CClientCreditsList::InitalizeCrypting()
|
||||||
|
// calculate and store public key
|
||||||
|
CryptoPP::RSASSA_PKCS1v15_SHA_Verifier pubkey(*static_cast<CryptoPP::RSASSA_PKCS1v15_SHA_Signer *>(m_pSignkey));
|
||||||
|
CryptoPP::ArraySink asink(m_abyMyPublicKey, 80);
|
||||||
|
- pubkey.AccessMaterial().Save(asink);
|
||||||
|
+ pubkey.GetMaterial().Save(asink);
|
||||||
|
m_nMyPublicKeyLen = asink.TotalPutLength();
|
||||||
|
asink.MessageEnd();
|
||||||
|
} catch (const CryptoPP::Exception& e) {
|
Loading…
Reference in New Issue