gnu: teckit: Update to 2.5.4.
* gnu/packages/fontutils.scm (teckit): Update to 2.5.4. Drop patch. Use svn-fetch for download. [arguments]: Add phase to call autogen. [native-inputs]: New field. * gnu/packages/patches/teckit-cstdio.patch: Delete file. * gnu-system.am (dist_patch_DATA): Unregister patch.
This commit is contained in:
parent
8fd3c1ff6e
commit
1436c5c7e8
|
@ -620,7 +620,6 @@ dist_patch_DATA = \
|
||||||
gnu/packages/patches/tar-d_ino_in_dirent-fix.patch \
|
gnu/packages/patches/tar-d_ino_in_dirent-fix.patch \
|
||||||
gnu/packages/patches/tar-skip-unreliable-tests.patch \
|
gnu/packages/patches/tar-skip-unreliable-tests.patch \
|
||||||
gnu/packages/patches/tcsh-fix-autotest.patch \
|
gnu/packages/patches/tcsh-fix-autotest.patch \
|
||||||
gnu/packages/patches/teckit-cstdio.patch \
|
|
||||||
gnu/packages/patches/texi2html-document-encoding.patch \
|
gnu/packages/patches/texi2html-document-encoding.patch \
|
||||||
gnu/packages/patches/texi2html-i18n.patch \
|
gnu/packages/patches/texi2html-i18n.patch \
|
||||||
gnu/packages/patches/tidy-CVE-2015-5522+5523.patch \
|
gnu/packages/patches/tidy-CVE-2015-5522+5523.patch \
|
||||||
|
|
|
@ -34,6 +34,7 @@
|
||||||
#:use-module ((guix licenses) #:prefix license:)
|
#:use-module ((guix licenses) #:prefix license:)
|
||||||
#:use-module (guix packages)
|
#:use-module (guix packages)
|
||||||
#:use-module (guix download)
|
#:use-module (guix download)
|
||||||
|
#:use-module (guix svn-download)
|
||||||
#:use-module (guix build-system cmake)
|
#:use-module (guix build-system cmake)
|
||||||
#:use-module (guix build-system gnu))
|
#:use-module (guix build-system gnu))
|
||||||
|
|
||||||
|
@ -139,27 +140,33 @@ X11-system or any other graphical user interface.")
|
||||||
(define-public teckit
|
(define-public teckit
|
||||||
(package
|
(package
|
||||||
(name "teckit")
|
(name "teckit")
|
||||||
(version "2.5.1")
|
(version "2.5.4")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
;; Downloaded tarballs vary with each download, so we use an
|
||||||
(uri (list
|
;; svn snapshot. The 2.5.4 release seems to be made in r128,
|
||||||
(string-append
|
;; but r132 updates additional files to contain the correct
|
||||||
"http://scripts.sil.org/svn-view/teckit/TAGS/TECkit_"
|
;; version number (r129 to r131 do not concern TRUNK).
|
||||||
(string-map (lambda (x) (if (char=? x #\.) #\_ x)) version)
|
(method svn-fetch)
|
||||||
".tar.gz")
|
(uri (svn-reference
|
||||||
"http://pkgs.fedoraproject.org/repo/pkgs/teckit/TECkit_2_5_1.tar.gz/4913f71f0f42bfd9cf8f161688b35dea/TECkit_2_5_1.tar.gz"
|
(url "https://scripts.sil.org/svn-public/teckit/TRUNK")
|
||||||
;; This used to be the canonical URL but it vanished.
|
(revision 132)))
|
||||||
;; See <http://bugs.gnu.org/19600>.
|
(file-name (string-append name "-" version))
|
||||||
;; (string-append
|
(sha256
|
||||||
;; "http://scripts.sil.org/svn-view/teckit/TAGS/TECkit_"
|
(base32
|
||||||
;; (string-map (lambda (x) (if (char=? x #\.) #\_ x)) version)
|
"1xqkqgw30pb24snh46srmjs2j4zhz2dfi5pf7znia0k34mrpwivz"))))
|
||||||
;; ".tar.gz")
|
|
||||||
))
|
|
||||||
(sha256 (base32
|
|
||||||
"0fjiwvic8mdxpkyccfp7zh26y9xnvkp0skqbyfkrjiacd191k82r"))
|
|
||||||
(patches (list (search-patch "teckit-cstdio.patch")))))
|
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(inputs `(("zlib" ,zlib)))
|
(inputs `(("zlib" ,zlib)))
|
||||||
|
(native-inputs
|
||||||
|
`(("autoconf" ,autoconf)
|
||||||
|
("automake" ,automake)
|
||||||
|
("libtool" ,libtool)
|
||||||
|
("perl" ,perl))) ; for the tests
|
||||||
|
(arguments
|
||||||
|
`(#:phases
|
||||||
|
(modify-phases %standard-phases
|
||||||
|
(add-after 'unpack 'autogen
|
||||||
|
(lambda _
|
||||||
|
(zero? (system* "sh" "autogen.sh")))))))
|
||||||
(synopsis "Toolkit for encoding conversions")
|
(synopsis "Toolkit for encoding conversions")
|
||||||
(description
|
(description
|
||||||
"TECkit is a low-level toolkit intended to be used by other applications
|
"TECkit is a low-level toolkit intended to be used by other applications
|
||||||
|
|
|
@ -1,10 +0,0 @@
|
||||||
--- TECkit_2_5_1/source/Compiler.cpp 2008-04-07 16:21:12.000000000 +0200
|
|
||||||
+++ TECkit_2_5_1/source/Compiler.cpp 2013-01-26 00:33:18.000000000 +0100
|
|
||||||
@@ -29,6 +29,7 @@
|
|
||||||
|
|
||||||
#include "Compiler.h"
|
|
||||||
|
|
||||||
+#include <cstdio>
|
|
||||||
#include <iostream>
|
|
||||||
#include <iomanip>
|
|
||||||
#include <algorithm>
|
|
Loading…
Reference in New Issue