gnu: elixir: Update to 1.4.2.

* gnu/packages/elixir.scm (elixir): Update to 1.4.2.
* gnu/packages/patches/elixir-disable-failing-tests.patch: Adjust.

Signed-off-by: Leo Famulari <leo@famulari.name>
This commit is contained in:
Pjotr Prins 2017-05-06 12:19:44 +00:00 committed by Leo Famulari
parent 4b7917f2f3
commit 151960e436
No known key found for this signature in database
GPG Key ID: 2646FA30BACA7F08
2 changed files with 90 additions and 66 deletions

View File

@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU ;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Leo Famulari <leo@famulari.name> ;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016 Pjotr Prins <pjotr.public12@thebird.nl> ;;; Copyright © 2016, 2017 Pjotr Prins <pjotr.guix@thebird.nl>
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net> ;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
;;; ;;;
;;; This file is part of GNU Guix. ;;; This file is part of GNU Guix.
@ -30,7 +30,7 @@
(define-public elixir (define-public elixir
(package (package
(name "elixir") (name "elixir")
(version "1.3.2") (version "1.4.2")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (string-append "https://github.com/elixir-lang/elixir" (uri (string-append "https://github.com/elixir-lang/elixir"
@ -38,9 +38,10 @@
(file-name (string-append name "-" version ".tar.gz")) (file-name (string-append name "-" version ".tar.gz"))
(sha256 (sha256
(base32 (base32
"0jsc6kl7f74yszcypdv3w3vhyc9qfqav8nwc41in082m0vpfy95y")) "0gsmgx4h6rvxilcbsx2z6yirm6g2g5bsxdvr0608ng4bsv22wknb"))
;; FIXME: Some tests had to be disabled as they fail in the ;; FIXME: 27 tests (out of 4K) had to be disabled as
;; build environment. Common failures are: ;; they fail in the build environment. Common failures
;; are:
;; - Mix.Shell.cmd() fails with error 130 ;; - Mix.Shell.cmd() fails with error 130
;; - The git_repo fixture cannot be found ;; - The git_repo fixture cannot be found
;; - Communication with spawned processes fails with EPIPE ;; - Communication with spawned processes fails with EPIPE

View File

@ -119,33 +119,6 @@ index fff3351..d6ed1b3 100644
test "remote converger is not invoked if deps diverge" do test "remote converger is not invoked if deps diverge" do
deps = [{:deps_repo, "0.1.0", path: "custom/deps_repo"}, deps = [{:deps_repo, "0.1.0", path: "custom/deps_repo"},
{:git_repo, "0.2.0", git: MixTest.Case.fixture_path("git_repo"), only: :test}] {:git_repo, "0.2.0", git: MixTest.Case.fixture_path("git_repo"), only: :test}]
diff --git a/lib/mix/test/mix/rebar_test.exs b/lib/mix/test/mix/rebar_test.exs
index d2dd098..12cef15 100644
--- a/lib/mix/test/mix/rebar_test.exs
+++ b/lib/mix/test/mix/rebar_test.exs
@@ -120,6 +120,7 @@ defmodule Mix.RebarTest do
assert Enum.all?(deps, &(&1.manager == :rebar3))
end
+ @tag :skip
test "Rebar overrides" do
Mix.Project.push(RebarOverrideAsDep)
@@ -150,6 +151,7 @@ defmodule Mix.RebarTest do
end
end
+ @tag :skip
test "get and compile dependencies for Rebar" do
Mix.Project.push(RebarAsDep)
@@ -180,6 +182,7 @@ defmodule Mix.RebarTest do
end
end
+ @tag :skip
test "get and compile dependencies for rebar3" do
Mix.Project.push(Rebar3AsDep)
diff --git a/lib/mix/test/mix/shell/io_test.exs b/lib/mix/test/mix/shell/io_test.exs diff --git a/lib/mix/test/mix/shell/io_test.exs b/lib/mix/test/mix/shell/io_test.exs
index 9bfb6b4..d982ef3 100644 index 9bfb6b4..d982ef3 100644
@ -259,3 +232,53 @@ index 69f9428..406668a 100644
test "loads umbrella child dependencies in all environments" do test "loads umbrella child dependencies in all environments" do
in_fixture "umbrella_dep/deps/umbrella", fn -> in_fixture "umbrella_dep/deps/umbrella", fn ->
Mix.Project.in_project :umbrella, ".", fn _ -> Mix.Project.in_project :umbrella, ".", fn _ ->
diff --git a/lib/elixir/test/elixir/kernel/dialyzer_test.exs b/lib/elixir/test/elixir/kernel/dialyzer_test.exs
index 792222c..e90beb9 100644
--- a/lib/elixir/test/elixir/kernel/dialyzer_test.exs
+++ b/lib/elixir/test/elixir/kernel/dialyzer_test.exs
@@ -54,6 +54,7 @@ defmodule Kernel.DialyzerTest do
{:ok, [outdir: dir, dialyzer: dialyzer]}
end
+ @tag :skip
test "no warnings on valid remote calls", context do
copy_beam! context, Dialyzer.RemoteCall
assert_dialyze_no_warnings! context
@@ -78,11 +79,13 @@ defmodule Kernel.DialyzerTest do
assert_dialyze_no_warnings! context
end
+ @tag :skip
test "no warnings on struct update", context do
copy_beam! context, Dialyzer.StructUpdate
assert_dialyze_no_warnings! context
end
+ @tag :skip
test "no warnings on protocol calls with opaque types", context do
copy_beam! context, Dialyzer.ProtocolOpaque
copy_beam! context, Dialyzer.ProtocolOpaque.Entity
@@ -90,6 +93,7 @@ defmodule Kernel.DialyzerTest do
assert_dialyze_no_warnings! context
end
+ @tag :skip
test "no warnings on and/2 and or/2", context do
copy_beam! context, Dialyzer.BooleanCheck
assert_dialyze_no_warnings! context
diff --git a/Makefile b/Makefile
index 2fc4f9a..aef8366 100644
--- a/Makefile
+++ b/Makefile
@@ -201,7 +201,7 @@ $(TEST_EBIN)/%.beam: $(TEST_ERL)/%.erl
$(Q) mkdir -p $(TEST_EBIN)
$(Q) $(ERLC) -o $(TEST_EBIN) $<
-test_elixir: test_stdlib test_ex_unit test_logger test_mix test_eex test_iex
+test_elixir: test_stdlib test_ex_unit test_logger test_eex test_iex
test_stdlib: compile
@ echo "==> elixir (exunit)"