gnu: fbreader: Fix building with newer curl.
* gnu/packages/ebook.scm (fbreader)[source]: Add patch. * gnu/packages/patches/fbreader-curl-7.62.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it.
This commit is contained in:
parent
af8fd11bed
commit
152d6bf014
|
@ -685,6 +685,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/fasthenry-spUtils.patch \
|
||||
%D%/packages/patches/fasthenry-spSolve.patch \
|
||||
%D%/packages/patches/fasthenry-spFactor.patch \
|
||||
%D%/packages/patches/fbreader-curl-7.62.patch \
|
||||
%D%/packages/patches/fcgi-2.4.0-gcc44-fixes.patch \
|
||||
%D%/packages/patches/fcgi-2.4.0-poll.patch \
|
||||
%D%/packages/patches/fifo-map-fix-flags-for-gcc.patch \
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
;;; GNU Guix --- Functional package management for GNU
|
||||
;;; Copyright © 2015, 2016 Andreas Enge <andreas@enge.fr>
|
||||
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
|
||||
;;; Copyright © 2016, 2018 Efraim Flashner <efraim@flashner.co.il>
|
||||
;;; Copyright © 2016, 2017 Alex Griffin <a@ajgrf.com>
|
||||
;;; Copyright © 2017 Brendan Tildesley <brendan.tildesley@openmailbox.org>
|
||||
;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
|
||||
|
@ -247,7 +247,8 @@ designed to be used in a generic text renderer.")
|
|||
(file-name (string-append name "-" version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"0gf1nl562fqkwlzcn6rgkp1j8jcixzmfsnwxbc0sm49zh8n3zqib"))))
|
||||
"0gf1nl562fqkwlzcn6rgkp1j8jcixzmfsnwxbc0sm49zh8n3zqib"))
|
||||
(patches (search-patches "fbreader-curl-7.62.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
(inputs
|
||||
`(("curl" ,curl)
|
||||
|
|
|
@ -0,0 +1,30 @@
|
|||
https://github.com/geometer/FBReader/commit/b7c78e965d06f78043a57e230c866c3af3f5a1eb.patch
|
||||
https://github.com/geometer/FBReader/issues/310
|
||||
https://github.com/geometer/FBReader/pull/311/commits
|
||||
|
||||
From b7c78e965d06f78043a57e230c866c3af3f5a1eb Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Vladim=C3=ADr=20=C4=8Cun=C3=A1t?= <vcunat@gmail.com>
|
||||
Date: Sun, 9 Dec 2018 10:18:03 +0100
|
||||
Subject: [PATCH] fix compatibility with curl-7.62
|
||||
|
||||
https://github.com/curl/curl/commit/3f3b26d6fe
|
||||
---
|
||||
zlibrary/core/src/unix/curl/ZLCurlNetworkManager.cpp | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/zlibrary/core/src/unix/curl/ZLCurlNetworkManager.cpp b/zlibrary/core/src/unix/curl/ZLCurlNetworkManager.cpp
|
||||
index 54cc37f6c..03e2a5721 100644
|
||||
--- a/zlibrary/core/src/unix/curl/ZLCurlNetworkManager.cpp
|
||||
+++ b/zlibrary/core/src/unix/curl/ZLCurlNetworkManager.cpp
|
||||
@@ -285,9 +285,11 @@ std::string ZLCurlNetworkManager::perform(const ZLExecutionData::Vector &dataLis
|
||||
#endif
|
||||
errors.insert(ZLStringUtil::printf(errorResource["peerFailedVerificationMessage"].value(), ZLNetworkUtil::hostFromUrl(url)));
|
||||
break;
|
||||
+#if LIBCURL_VERSION_NUM < 0x073e00
|
||||
case CURLE_SSL_CACERT:
|
||||
errors.insert(ZLStringUtil::printf(errorResource["sslCertificateAuthorityMessage"].value(), ZLNetworkUtil::hostFromUrl(url)));
|
||||
break;
|
||||
+#endif
|
||||
case CURLE_SSL_CACERT_BADFILE:
|
||||
errors.insert(ZLStringUtil::printf(errorResource["sslBadCertificateFileMessage"].value(), request.sslCertificate().Path));
|
||||
break;
|
Loading…
Reference in New Issue