gnu: grep: Skip timing-sensitive test.

This avoids failures on loaded machines as seen
at <http://hydra.gnu.org/build/906900/log/raw>.

* gnu/packages/patches/grep-timing-sensitive-test.patch: New file.
* gnu-system.am (dist_patch_DATA): Add it.
* gnu/packages/base.scm (grep): Use it.
master
Ludovic Courtès 2016-01-03 14:49:55 +01:00
parent dd1937d75d
commit 1575dcd134
3 changed files with 20 additions and 2 deletions

View File

@ -1,5 +1,5 @@
# GNU Guix --- Functional package management for GNU
# Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
# Copyright © 2012, 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
# Copyright © 2013, 2014, 2015 Andreas Enge <andreas@enge.fr>
# Copyright © 2013, 2014, 2015 Mark H Weaver <mhw@netris.org>
#
@ -498,6 +498,7 @@ dist_patch_DATA = \
gnu/packages/patches/gobject-introspection-absolute-shlib-path.patch \
gnu/packages/patches/gobject-introspection-cc.patch \
gnu/packages/patches/gobject-introspection-girepository.patch \
gnu/packages/patches/grep-timing-sensitive-test.patch \
gnu/packages/patches/grub-gets-undeclared.patch \
gnu/packages/patches/grub-freetype.patch \
gnu/packages/patches/guile-1.8-cpp-4.5.patch \

View File

@ -80,7 +80,9 @@ command-line arguments, multiple languages, and so on.")
version ".tar.xz"))
(sha256
(base32
"1srn321x7whlhs5ks36zlcrrmj4iahll8fxwsh1vbz3v04px54fa"))))
"1srn321x7whlhs5ks36zlcrrmj4iahll8fxwsh1vbz3v04px54fa"))
(patches
(list (search-patch "grep-timing-sensitive-test.patch")))))
(build-system gnu-build-system)
(native-inputs `(("perl" ,perl))) ;some of the tests require it
(synopsis "Print lines matching a pattern")

View File

@ -0,0 +1,15 @@
Skip this performance regression test.
The test measures things on the order of 20ms. On a loaded machine, we
have seen enough variation that the test would fail.
--- grep-2.22/tests/long-pattern-perf 2016-01-03 12:52:38.491575007 +0100
+++ grep-2.22/tests/long-pattern-perf 2016-01-03 12:53:39.768464687 +0100
@@ -16,6 +16,7 @@
# You should have received a copy of the GNU General Public License
# along with this program. If not, see <http://www.gnu.org/licenses/>.
+exit 77
. "${srcdir=.}/init.sh"; path_prepend_ ../src
fail=0