gnu: nasm: Switch patch to phase.
* gnu/packages/assembly.scm (nasm)[source]: Remove patch. [arguments]: Disable ps and pdf doc outputs in new phase. * gnu/packages/patches/nasm-no-ps-pdf.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
4181c9393d
commit
161fb9be8e
|
@ -748,7 +748,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/mupen64plus-ui-console-notice.patch \
|
||||
%D%/packages/patches/musl-CVE-2016-8859.patch \
|
||||
%D%/packages/patches/mutt-store-references.patch \
|
||||
%D%/packages/patches/nasm-no-ps-pdf.patch \
|
||||
%D%/packages/patches/net-tools-bitrot.patch \
|
||||
%D%/packages/patches/netcdf-config-date.patch \
|
||||
%D%/packages/patches/netsurf-about.patch \
|
||||
|
|
|
@ -41,17 +41,25 @@
|
|||
version "/" name "-" version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"12bl6vc5sjp9nnhf0iwy6l27vq783y0rxrjpp8sy84h5cb7a3fwx"))
|
||||
(patches (search-patches "nasm-no-ps-pdf.patch"))))
|
||||
"12bl6vc5sjp9nnhf0iwy6l27vq783y0rxrjpp8sy84h5cb7a3fwx"))))
|
||||
(build-system gnu-build-system)
|
||||
(native-inputs `(("perl" ,perl) ;for doc and test target
|
||||
("texinfo" ,texinfo)))
|
||||
(arguments
|
||||
`(#:test-target "test"
|
||||
#:phases (modify-phases %standard-phases
|
||||
(add-after 'install 'install-info
|
||||
(lambda _
|
||||
(zero? (system* "make" "install_doc")))))))
|
||||
#:phases
|
||||
(modify-phases %standard-phases
|
||||
(add-after 'unpack 'dont-build-ps-pdf-outputs
|
||||
(lambda _
|
||||
(substitute* "doc/Makefile.in"
|
||||
(("info html nasmdoc.txt nasmdoc.ps nasmdoc.pdf")
|
||||
"info html nasmdoc.txt")
|
||||
(("nasmdoc.ps nasmdoc.pdf nasmdoc.txt \\$\\(INSTALLROOT\\)\\$\\(docdir\\)")
|
||||
"nasmdoc.txt $(INSTALLROOT)$(docdir)"))
|
||||
#t))
|
||||
(add-after 'install 'install-info
|
||||
(lambda _
|
||||
(zero? (system* "make" "install_doc")))))))
|
||||
(home-page "http://www.nasm.us/")
|
||||
(synopsis "80x86 and x86-64 assembler")
|
||||
(description
|
||||
|
|
|
@ -1,20 +0,0 @@
|
|||
Avoid building PS and PDF docs, which do not build bit-reproducible. NASM
|
||||
already installs doc in info and html.
|
||||
|
||||
--- nasm-2.12.01/doc/Makefile.in.orig 2016-06-21 18:02:59.483484829 +0200
|
||||
+++ nasm-2.12.01/doc/Makefile.in 2016-06-21 18:03:46.700151410 +0200
|
||||
@@ -27,7 +27,7 @@
|
||||
PS2PDF = @PS2PDF@ # Part of GhostScript
|
||||
|
||||
SRCS = nasmdoc.src inslist.src changes.src
|
||||
-OUT = info html nasmdoc.txt nasmdoc.ps nasmdoc.pdf
|
||||
+OUT = info html nasmdoc.txt
|
||||
|
||||
# exports
|
||||
export srcdir
|
||||
@@ -100,4 +100,4 @@
|
||||
$(INSTALL_DATA) info/* $(INSTALLROOT)$(infodir)
|
||||
mkdir -p $(INSTALLROOT)$(docdir)/html
|
||||
$(INSTALL_DATA) html/* $(INSTALLROOT)$(docdir)/html
|
||||
- $(INSTALL_DATA) nasmdoc.ps nasmdoc.pdf nasmdoc.txt $(INSTALLROOT)$(docdir)
|
||||
+ $(INSTALL_DATA) nasmdoc.txt $(INSTALLROOT)$(docdir)
|
Loading…
Reference in New Issue