gnu: bash-completion: Search for completion modules in profiles.

* gnu/packages/patches/bash-completion-directories.patch: New file.
* gnu-system.am (dist_patch_DATA): Add it.
* gnu/packages/bash.scm (bash-completion)[source]: Use it.
master
Ludovic Courtès 2015-03-12 22:08:04 +01:00
parent cd9bc11273
commit 16629c8adf
3 changed files with 38 additions and 1 deletions

View File

@ -364,6 +364,7 @@ dist_patch_DATA = \
gnu/packages/patches/automake-skip-amhello-tests.patch \
gnu/packages/patches/avahi-localstatedir.patch \
gnu/packages/patches/avrdude-fix-libusb.patch \
gnu/packages/patches/bash-completion-directories.patch \
gnu/packages/patches/bowtie-fix-makefile.patch \
gnu/packages/patches/bigloo-gc-shebangs.patch \
gnu/packages/patches/binutils-ld-new-dtags.patch \

View File

@ -19,6 +19,7 @@
(define-module (gnu packages bash)
#:use-module (guix licenses)
#:use-module (gnu packages)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages readline)
#:use-module (gnu packages bison)
@ -218,7 +219,9 @@ without modification.")
"bash-completion-" version ".tar.bz2"))
(sha256
(base32
"0kxf8s5bw7y50x0ksb77d3kv0dwadixhybl818w27y6mlw26hq1b"))))
"0kxf8s5bw7y50x0ksb77d3kv0dwadixhybl818w27y6mlw26hq1b"))
(patches
(list (search-patch "bash-completion-directories.patch")))))
(build-system gnu-build-system)
(synopsis "Bash completions for common commands")
(description

View File

@ -0,0 +1,33 @@
Bash-completion is written with FHS in mind where completion scripts
all get added to /usr/share/bash-completion/completions and are picked
up by the dynamic completion loader from there---whether they are
part of bash-completion or installed by another package.
On Guix systems, we want not only to search within bash-completion's own
directory, but also in the user's profile and in the system profile.
This is what this patch does.
--- bash-completion-2.1/bash_completion 2015-03-11 09:45:45.056846446 +0100
+++ bash-completion-2.1/bash_completion 2015-03-11 09:52:43.248159504 +0100
@@ -1928,9 +1928,20 @@ _completion_loader()
local compfile=./completions
[[ $BASH_SOURCE == */* ]] && compfile="${BASH_SOURCE%/*}/completions"
compfile+="/${1##*/}"
+ local base="${1##*/}"
+ # Look for completion files in the user and global profiles and
+ # lastly in 'bash-completion' itself.
+ for file in \
+ "$HOME/.guix-profile/share/bash-completion/completions/$base" \
+ "$HOME/.guix-profile/etc/bash_completion.d/$base" \
+ "/run/current-system/profile/share/bash-completion/completions/$base" \
+ "/run/current-system/profile/etc/bash_completion.d/$base" \
+ "$compfile"
+ do
# Avoid trying to source dirs; https://bugzilla.redhat.com/903540
- [[ -f "$compfile" ]] && . "$compfile" &>/dev/null && return 124
+ [[ -f "$file" ]] && . "$file" &>/dev/null && return 124
+ done
# Need to define *something*, otherwise there will be no completion at all.
complete -F _minimal "$1" && return 124