gnu: Python: Adjust grafts for core-updates merge.

This adjust the grafts from a55ebe2e3a and
90aeaee861 to apply to Python 2.7.15 and 3.7.0.

* gnu/packages/patches/python2-CVE-2018-1060.patch,
gnu/packages/patches/python2-CVE-2018-1061.patch: Delete files.
* gnu/local.mk (dist_patch_DATA): Remove them.
* gnu/packages/python.scm (python-2/fixed): Remove patches that are already
present in 2.7.15.
(python-3/fixed): Remove obsolete phase.
master
Marius Bakke 2018-10-17 20:53:24 +02:00
parent d02bb02f7d
commit 16f14f63db
No known key found for this signature in database
GPG Key ID: A2A06DF2A33A54FA
4 changed files with 2 additions and 56 deletions

View File

@ -1068,8 +1068,6 @@ dist_patch_DATA = \
%D%/packages/patches/pygpgme-disable-problematic-tests.patch \
%D%/packages/patches/pyqt-configure.patch \
%D%/packages/patches/pyqt-public-sip.patch \
%D%/packages/patches/python2-CVE-2018-1060.patch \
%D%/packages/patches/python2-CVE-2018-1061.patch \
%D%/packages/patches/python2-CVE-2018-14647.patch \
%D%/packages/patches/python2-CVE-2018-1000802.patch \
%D%/packages/patches/python-2-deterministic-build-info.patch \

View File

@ -1,20 +0,0 @@
Fix CVE-2018-1060:
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-1060
Taken from upstream commit (sans test and NEWS):
https://github.com/python/cpython/commit/e052d40cea15f582b50947f7d906b39744dc62a2
diff --git a/Lib/poplib.py b/Lib/poplib.py
index b91e5f72d2ca..a238510b38fc 100644
--- a/Lib/poplib.py
+++ b/Lib/poplib.py
@@ -274,7 +274,7 @@ def rpop(self, user):
return self._shortcmd('RPOP %s' % user)
- timestamp = re.compile(r'\+OK.*(<[^>]+>)')
+ timestamp = re.compile(br'\+OK.[^<]*(<.*>)')
def apop(self, user, secret):
"""Authorisation

View File

@ -1,20 +0,0 @@
Fix CVE-2018-1061:
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-1061
Taken from upstream commit (sans test and NEWS):
https://github.com/python/cpython/commit/e052d40cea15f582b50947f7d906b39744dc62a2
diff --git a/Lib/difflib.py b/Lib/difflib.py
index 1c6fbdbedcb7..788a92df3f89 100644
--- a/Lib/difflib.py
+++ b/Lib/difflib.py
@@ -1103,7 +1103,7 @@ def _qformat(self, aline, bline, atags, btags):
import re
-def IS_LINE_JUNK(line, pat=re.compile(r"\s*#?\s*$").match):
+def IS_LINE_JUNK(line, pat=re.compile(r"\s*(?:#\s*)?$").match):
r"""
Return 1 for ignorable line: iff `line` is blank or contains a single '#'.

View File

@ -323,9 +323,7 @@ data types.")
(inherit (package-source python-2))
(patches (append
(origin-patches (package-source python-2))
(search-patches "python2-CVE-2018-1060.patch"
"python2-CVE-2018-1061.patch"
"python2-CVE-2018-14647.patch"
(search-patches "python2-CVE-2018-14647.patch"
"python2-CVE-2018-1000802.patch")))))))
(define-public python2-called-python
@ -419,17 +417,7 @@ data types.")
(source (origin
(inherit (package-source python-3))
(patches (append (origin-patches (package-source python-3))
(search-patches "python-CVE-2018-14647.patch")))))
(arguments
(substitute-keyword-arguments (package-arguments python-3)
((#:phases phases)
`(modify-phases ,phases
(add-after 'unpack 'delete-broken-test
(lambda _
;; Delete test which fails on recent kernels:
;; <https://bugs.python.org/issue34587>.
(delete-file "Lib/test/test_socket.py")
#t))))))))
(search-patches "python-CVE-2018-14647.patch")))))))
;; Current major version.
(define-public python python-3)