gnu: libreoffice: Fix build with newer GLM.
* gnu/packages/patches/libreoffice-glm.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/libreoffice.scm (libreoffice)[source](patches): Add it.
This commit is contained in:
parent
4266df5cf8
commit
1743172cdb
|
@ -880,6 +880,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/libmygpo-qt-fix-qt-5.11.patch \
|
||||
%D%/packages/patches/libmygpo-qt-missing-qt5-modules.patch \
|
||||
%D%/packages/patches/libreoffice-icu.patch \
|
||||
%D%/packages/patches/libreoffice-glm.patch \
|
||||
%D%/packages/patches/libsndfile-armhf-type-checks.patch \
|
||||
%D%/packages/patches/libsndfile-CVE-2017-8361-8363-8365.patch \
|
||||
%D%/packages/patches/libsndfile-CVE-2017-8362.patch \
|
||||
|
|
|
@ -907,7 +907,8 @@ converting QuarkXPress file format. It supports versions 3.1 to 4.1.")
|
|||
(sha256
|
||||
(base32
|
||||
"0vnmb231hyhxm7klaqd8vp3rmvix145bq8iqzv19jgl1yaqkxl21"))
|
||||
(patches (search-patches "libreoffice-icu.patch"))))
|
||||
(patches (search-patches "libreoffice-icu.patch"
|
||||
"libreoffice-glm.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
(native-inputs
|
||||
`(("bison" ,bison)
|
||||
|
|
|
@ -0,0 +1,58 @@
|
|||
Fix build with GLM 0.9.9.
|
||||
|
||||
This patch is an amalgamation of these upstream commits:
|
||||
|
||||
https://github.com/LibreOffice/core/commit/953c4add8fd76d88f49a81ae4c21a1fdcc007e57
|
||||
https://github.com/LibreOffice/core/commit/5f1bf6598b5725ad1e50ae9f7ec7524cc8a834fa
|
||||
|
||||
diff --git a/chart2/Library_chartcore.mk b/chart2/Library_chartcore.mk
|
||||
index 28bc87b89057..69d4c0552636 100644
|
||||
--- a/chart2/Library_chartcore.mk
|
||||
+++ b/chart2/Library_chartcore.mk
|
||||
@@ -23,6 +23,12 @@ $(eval $(call gb_Library_add_defs,chartcore,\
|
||||
-DOOO_DLLIMPLEMENTATION_CHARTVIEW \
|
||||
))
|
||||
|
||||
+ifeq ($(SYSTEM_GLM),TRUE)
|
||||
+$(eval $(call gb_Library_add_defs,chartcore,\
|
||||
+ -DGLM_ENABLE_EXPERIMENTAL \
|
||||
+))
|
||||
+endif
|
||||
+
|
||||
$(eval $(call gb_Library_set_precompiled_header,chartcore,$(SRCDIR)/chart2/inc/pch/precompiled_chartcore))
|
||||
|
||||
$(eval $(call gb_Library_use_externals,chartcore,\
|
||||
diff --git a/vcl/Library_vcl.mk b/vcl/Library_vcl.mk
|
||||
index c1f3cc5324e7..0b684c6185a9 100644
|
||||
--- a/vcl/Library_vcl.mk
|
||||
+++ b/vcl/Library_vcl.mk
|
||||
@@ -49,6 +49,12 @@ $(eval $(call gb_Library_add_defs,vcl,\
|
||||
-DENABLE_MERGELIBS=$(if $(MERGELIBS),1,0) \
|
||||
))
|
||||
|
||||
+ifeq ($(SYSTEM_GLM),TRUE)
|
||||
+$(eval $(call gb_Library_add_defs,vcl,\
|
||||
+ -DGLM_ENABLE_EXPERIMENTAL \
|
||||
+))
|
||||
+endif
|
||||
+
|
||||
$(eval $(call gb_Library_use_sdk_api,vcl))
|
||||
|
||||
$(eval $(call gb_Library_use_custom_headers,vcl,\
|
||||
diff --git a/vcl/Executable_icontest.mk b/vcl/Executable_icontest.mk
|
||||
index ce163303f8a4..8c917b71cd0e 100644
|
||||
--- a/vcl/Executable_icontest.mk
|
||||
+++ b/vcl/Executable_icontest.mk
|
||||
@@ -19,6 +19,12 @@ $(eval $(call gb_Executable_use_externals,icontest,\
|
||||
))
|
||||
endif
|
||||
|
||||
+ifeq ($(SYSTEM_GLM),TRUE)
|
||||
+$(eval $(call gb_Executable_add_defs,icontest,\
|
||||
+ -DGLM_ENABLE_EXPERIMENTAL \
|
||||
+))
|
||||
+endif
|
||||
+
|
||||
$(eval $(call gb_Executable_use_api,icontest,\
|
||||
offapi \
|
||||
udkapi \
|
Loading…
Reference in New Issue