gnu: libgnome: Adjust for latest GLib.
* gnu/packages/patches/libgnome-encoding.patch: New file. * gnu/packages/gnome.scm (libgnome)[source]: Use it. * gnu/local.mk (dist_patch_DATA): Add it.
This commit is contained in:
parent
ad51430398
commit
17c3eea760
|
@ -813,6 +813,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/libgit2-0.25.1-mtime-0.patch \
|
||||
%D%/packages/patches/libgdata-fix-tests.patch \
|
||||
%D%/packages/patches/libgdata-glib-duplicate-tests.patch \
|
||||
%D%/packages/patches/libgnome-encoding.patch \
|
||||
%D%/packages/patches/libgxps-CVE-2017-11590.patch \
|
||||
%D%/packages/patches/libffi-3.2.1-complex-alpha.patch \
|
||||
%D%/packages/patches/libjxr-fix-function-signature.patch \
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
;;; GNU Guix --- Functional package management for GNU
|
||||
;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
|
||||
;;; Copyright © 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
|
||||
;;; Copyright © 2014, 2015, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
|
||||
;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
|
||||
;;; Copyright © 2014, 2016 Eric Bavier <bavier@member.fsf.org>
|
||||
;;; Copyright © 2014, 2015 Federico Beffa <beffa@fbengineering.ch>
|
||||
|
@ -1484,7 +1484,8 @@ to access local and remote files with a single consistent API.")
|
|||
name "-" version ".tar.bz2"))
|
||||
(sha256
|
||||
(base32
|
||||
"197pnq8y0knqjhm2fg4j6hbqqm3qfzfnd0irhwxpk1b4hqb3kimj"))))
|
||||
"197pnq8y0knqjhm2fg4j6hbqqm3qfzfnd0irhwxpk1b4hqb3kimj"))
|
||||
(patches (search-patches "libgnome-encoding.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
`(#:phases
|
||||
|
|
|
@ -0,0 +1,16 @@
|
|||
Remove non-UTF-8 character (this is a NO-BREAK SPACE character, encoded in
|
||||
ISO-8859-1) to fix build failure with 'glib-mkenums' in GLib 2.54.2+.
|
||||
|
||||
Patch from <https://github.com/macports/macports-ports/commit/1f3efc8e65cc060d1701407bd1e56e62e6bd9c55>.
|
||||
|
||||
--- a/libgnome/gnome-config.h 2009-04-23 04:29:13.000000000 -0500
|
||||
+++ b/libgnome/gnome-config.h 2017-10-04 02:17:22.000000000 -0500
|
||||
@@ -270,7 +270,7 @@ void gnome_config_clean_key_ (const char
|
||||
#define gnome_config_private_clean_key(path) \
|
||||
(gnome_config_clean_key_((path),TRUE))
|
||||
|
||||
-/* returns the true filename of the config file */
|
||||
+/* returns the true filename of the config file */
|
||||
#define gnome_config_get_real_path(path) \
|
||||
(g_build_filename (gnome_user_dir_get(),(path),NULL))
|
||||
#define gnome_config_private_get_real_path(path) \
|
Loading…
Reference in New Issue