gnu: python-dendropy: Fix failing tests.

* gnu/packages/patches/python-dendropy-fix-tests.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/bioinformatics.scm (python-dendropy)[source]: Add patch.
master
Ricardo Wurmus 2017-02-21 18:28:21 +01:00
parent d6caebc4d6
commit 1885bb0c08
No known key found for this signature in database
GPG Key ID: 197A5888235FACAC
3 changed files with 44 additions and 1 deletions

View File

@ -853,6 +853,7 @@ dist_patch_DATA = \
%D%/packages/patches/python-3-search-paths.patch \
%D%/packages/patches/python-3.4-fix-tests.patch \
%D%/packages/patches/python-3.5-fix-tests.patch \
%D%/packages/patches/python-dendropy-fix-tests.patch \
%D%/packages/patches/python-file-double-encoding-bug.patch \
%D%/packages/patches/python-fix-tests.patch \
%D%/packages/patches/python-parse-too-many-fields.patch \

View File

@ -1981,7 +1981,8 @@ accessing bigWig files.")
(uri (pypi-uri "DendroPy" version))
(sha256
(base32
"15c7s3d5gf19ljsxvq5advaa752wfi7pwrdjyhzmg85hccyvp47p"))))
"15c7s3d5gf19ljsxvq5advaa752wfi7pwrdjyhzmg85hccyvp47p"))
(patches (search-patches "python-dendropy-fix-tests.patch"))))
(build-system python-build-system)
(home-page "http://packages.python.org/DendroPy/")
(synopsis "Library for phylogenetics and phylogenetic computing")

View File

@ -0,0 +1,41 @@
This patch fixes two test failures. It was downloaded from:
https://github.com/jeetsukumaran/DendroPy/commit/93f984bba7a6c588a28ca87f4e557ce283809453
From 93f984bba7a6c588a28ca87f4e557ce283809453 Mon Sep 17 00:00:00 2001
From: jeetsukumaran <jeetsukumaran@gmail.com>
Date: Tue, 21 Feb 2017 16:41:01 -0500
Subject: [PATCH] Update to Python 3 container and iteration semantics
---
dendropy/dataio/newickreader.py | 3 ++-
dendropy/datamodel/treemodel.py | 3 +++
2 files changed, 5 insertions(+), 1 deletion(-)
diff --git a/dendropy/dataio/newickreader.py b/dendropy/dataio/newickreader.py
index 6dcf3c5..f978729 100644
--- a/dendropy/dataio/newickreader.py
+++ b/dendropy/dataio/newickreader.py
@@ -303,7 +303,8 @@ def tree_iter(self,
taxon_symbol_map_fn=taxon_symbol_mapper.require_taxon_for_symbol)
yield tree
if tree is None:
- raise StopIteration
+ # raise StopIteration
+ return
def _read(self,
stream,
diff --git a/dendropy/datamodel/treemodel.py b/dendropy/datamodel/treemodel.py
index 0ecfe31..73146f0 100644
--- a/dendropy/datamodel/treemodel.py
+++ b/dendropy/datamodel/treemodel.py
@@ -772,6 +772,9 @@ def __hash__(self):
def __eq__(self, other):
return self is other
+ def __lt__(self, other):
+ return id(self) < id(other)
+
###########################################################################
### Basic Structure