gnu: aegisub: Fix build.
* gnu/packages/patches/aegisub-icu59-include-unistr.patch: New file. * gnu/lokal.mk (dist_patch_DATA): Register it. * gnu/packages/video.scm (aegisub)[source]: Use patch. [arguments]: Add CXXFLAGS, Return #t from fix-ldflags phase. Signed-off-by: Leo Famulari <leo@famulari.name>
This commit is contained in:
parent
504e26ed32
commit
18e56ad7eb
|
@ -566,6 +566,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/aegis-perl-tempdir2.patch \
|
%D%/packages/patches/aegis-perl-tempdir2.patch \
|
||||||
%D%/packages/patches/aegis-test-fixup-1.patch \
|
%D%/packages/patches/aegis-test-fixup-1.patch \
|
||||||
%D%/packages/patches/aegis-test-fixup-2.patch \
|
%D%/packages/patches/aegis-test-fixup-2.patch \
|
||||||
|
%D%/packages/patches/aegisub-icu59-include-unistr.patch \
|
||||||
%D%/packages/patches/agg-am_c_prototype.patch \
|
%D%/packages/patches/agg-am_c_prototype.patch \
|
||||||
%D%/packages/patches/amule-crypto-6.patch \
|
%D%/packages/patches/amule-crypto-6.patch \
|
||||||
%D%/packages/patches/ansible-wrap-program-hack.patch \
|
%D%/packages/patches/ansible-wrap-program-hack.patch \
|
||||||
|
|
|
@ -0,0 +1,12 @@
|
||||||
|
This patch adds an include needed since icu59:
|
||||||
|
Source: https://git.archlinux.org/svntogit/community.git/plain/trunk/icu59.patch?h=packages/aegisub
|
||||||
|
--- aegisub-3.2.2/src/utils.cpp 2014-12-08 02:07:09.000000000 +0200
|
||||||
|
+++ aegisub-3.2.2/src/utils.cpp 2017-04-26 11:11:15.438239182 +0300
|
||||||
|
@@ -44,6 +44,7 @@
|
||||||
|
#include <boost/filesystem/path.hpp>
|
||||||
|
#include <map>
|
||||||
|
#include <unicode/locid.h>
|
||||||
|
+#include <unicode/unistr.h>
|
||||||
|
#include <wx/clipbrd.h>
|
||||||
|
#include <wx/filedlg.h>
|
||||||
|
#include <wx/stdpaths.h>
|
|
@ -28,6 +28,7 @@
|
||||||
;;; Copyright © 2018 Leo Famulari <leo@famulari.name>
|
;;; Copyright © 2018 Leo Famulari <leo@famulari.name>
|
||||||
;;; Copyright © 2018 Brendan Tildesley <brendan.tildesley@openmailbox.org>
|
;;; Copyright © 2018 Brendan Tildesley <brendan.tildesley@openmailbox.org>
|
||||||
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
|
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
|
||||||
|
;;; Copyright © 2018 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
|
||||||
;;;
|
;;;
|
||||||
;;; This file is part of GNU Guix.
|
;;; This file is part of GNU Guix.
|
||||||
;;;
|
;;;
|
||||||
|
@ -2738,21 +2739,24 @@ programmers to access a standard API to open and decompress media files.")
|
||||||
name "-" version ".tar.xz"))
|
name "-" version ".tar.xz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"11b83qazc8h0iidyj1rprnnjdivj1lpphvpa08y53n42bfa36pn5"))))
|
"11b83qazc8h0iidyj1rprnnjdivj1lpphvpa08y53n42bfa36pn5"))
|
||||||
|
(patches (search-patches "aegisub-icu59-include-unistr.patch"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
`(#:configure-flags
|
`(#:configure-flags
|
||||||
(list "--disable-update-checker"
|
(list "--disable-update-checker"
|
||||||
"--without-portaudio"
|
"--without-portaudio"
|
||||||
"--without-openal"
|
"--without-openal"
|
||||||
"--without-oss")
|
"--without-oss"
|
||||||
|
"CXXFLAGS=-DU_USING_ICU_NAMESPACE=1")
|
||||||
;; tests require busted, a lua package we don't have yet
|
;; tests require busted, a lua package we don't have yet
|
||||||
#:tests? #f
|
#:tests? #f
|
||||||
#:phases
|
#:phases
|
||||||
(modify-phases %standard-phases
|
(modify-phases %standard-phases
|
||||||
(add-before 'configure 'fix-ldflags
|
(add-before 'configure 'fix-ldflags
|
||||||
(lambda _
|
(lambda _
|
||||||
(setenv "LDFLAGS" "-pthread"))))))
|
(setenv "LDFLAGS" "-pthread")
|
||||||
|
#t)))))
|
||||||
(inputs
|
(inputs
|
||||||
`(("boost" ,boost)
|
`(("boost" ,boost)
|
||||||
("desktop-file-utils" ,desktop-file-utils)
|
("desktop-file-utils" ,desktop-file-utils)
|
||||||
|
|
Loading…
Reference in New Issue