gnu: libtool and libltdl: Update to 2.4.6.
* gnu/packages/autotools.scm (libtool, libltdl): Update to 2.4.6. * gnu/packages/patches/libtool-skip-tests.patch: Adapt to 2.4.6.
This commit is contained in:
parent
da466f7ff6
commit
192c6f966f
|
@ -2,6 +2,7 @@
|
||||||
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
|
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
|
||||||
;;; Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
|
;;; Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
|
||||||
;;; Copyright © 2014 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
|
;;; Copyright © 2014 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
|
||||||
|
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
|
||||||
;;;
|
;;;
|
||||||
;;; This file is part of GNU Guix.
|
;;; This file is part of GNU Guix.
|
||||||
;;;
|
;;;
|
||||||
|
@ -238,14 +239,14 @@ Makefile, simplifying the entire process for the developer.")
|
||||||
(define-public libtool
|
(define-public libtool
|
||||||
(package
|
(package
|
||||||
(name "libtool")
|
(name "libtool")
|
||||||
(version "2.4.5")
|
(version "2.4.6")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "mirror://gnu/libtool/libtool-"
|
(uri (string-append "mirror://gnu/libtool/libtool-"
|
||||||
version ".tar.xz"))
|
version ".tar.xz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0zhphv4n9bdd6sz66lqfrfqcsnv89mg2bykgi5w9401va4vc3al4"))
|
"0vxj52zm709125gwv9qqlw02silj8bnjnh4y07arrz60r31ai1vw"))
|
||||||
(patches
|
(patches
|
||||||
(list (search-patch "libtool-skip-tests.patch")))))
|
(list (search-patch "libtool-skip-tests.patch")))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
|
@ -295,14 +296,14 @@ complexity of working with shared libraries across platforms.")
|
||||||
;; Libtool's extensive test suite isn't run.
|
;; Libtool's extensive test suite isn't run.
|
||||||
(package
|
(package
|
||||||
(name "libltdl")
|
(name "libltdl")
|
||||||
(version "2.4.4")
|
(version "2.4.6")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "mirror://gnu/libtool/libtool-"
|
(uri (string-append "mirror://gnu/libtool/libtool-"
|
||||||
version ".tar.xz"))
|
version ".tar.xz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0v3zq08qxv7k5067mpqrkjkjl3wphhg06i696mka90mzadc5nad8"))
|
"0vxj52zm709125gwv9qqlw02silj8bnjnh4y07arrz60r31ai1vw"))
|
||||||
(patches
|
(patches
|
||||||
(list (search-patch "libtool-skip-tests.patch")))))
|
(list (search-patch "libtool-skip-tests.patch")))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
|
|
|
@ -4,8 +4,8 @@ one in demo.test, and one in destdir.at. Disable these.
|
||||||
|
|
||||||
Also skip the nopic test on ARM and MIPS systems.
|
Also skip the nopic test on ARM and MIPS systems.
|
||||||
|
|
||||||
--- libtool-2.4.4/tests/demo.at.orig 2014-11-19 07:28:51.000000000 -0500
|
--- libtool-2.4.6/tests/demo.at.orig 2015-01-16 13:52:04.000000000 -0500
|
||||||
+++ libtool-2.4.4/tests/demo.at 2015-01-07 17:30:46.482247718 -0500
|
+++ libtool-2.4.6/tests/demo.at 2015-02-16 10:48:51.435851966 -0500
|
||||||
@@ -510,7 +510,7 @@
|
@@ -510,7 +510,7 @@
|
||||||
AT_SETUP([force non-PIC objects])
|
AT_SETUP([force non-PIC objects])
|
||||||
|
|
||||||
|
@ -15,9 +15,9 @@ Also skip the nopic test on ARM and MIPS systems.
|
||||||
# These hosts cannot use non-PIC shared libs
|
# These hosts cannot use non-PIC shared libs
|
||||||
exit 77 ;;
|
exit 77 ;;
|
||||||
*-solaris*|*-sunos*)
|
*-solaris*|*-sunos*)
|
||||||
--- libtool-2.4.4/tests/testsuite.orig 2014-11-29 11:43:11.000000000 -0500
|
--- libtool-2.4.6/tests/testsuite.orig 2015-02-15 11:15:25.000000000 -0500
|
||||||
+++ libtool-2.4.4/tests/testsuite 2015-01-07 17:24:51.424672582 -0500
|
+++ libtool-2.4.6/tests/testsuite 2015-02-16 10:50:58.736483216 -0500
|
||||||
@@ -8633,7 +8633,7 @@
|
@@ -8741,7 +8741,7 @@
|
||||||
|
|
||||||
{ set +x
|
{ set +x
|
||||||
$as_echo "$at_srcdir/demo.at:535: case \$host in
|
$as_echo "$at_srcdir/demo.at:535: case \$host in
|
||||||
|
@ -26,7 +26,7 @@ Also skip the nopic test on ARM and MIPS systems.
|
||||||
# These hosts cannot use non-PIC shared libs
|
# These hosts cannot use non-PIC shared libs
|
||||||
exit 77 ;;
|
exit 77 ;;
|
||||||
*-solaris*|*-sunos*)
|
*-solaris*|*-sunos*)
|
||||||
@@ -8658,7 +8658,7 @@
|
@@ -8766,7 +8766,7 @@
|
||||||
"
|
"
|
||||||
at_fn_check_prepare_notrace 'a `...` command substitution' "demo.at:535"
|
at_fn_check_prepare_notrace 'a `...` command substitution' "demo.at:535"
|
||||||
( $at_check_trace; case $host in
|
( $at_check_trace; case $host in
|
||||||
|
@ -35,19 +35,19 @@ Also skip the nopic test on ARM and MIPS systems.
|
||||||
# These hosts cannot use non-PIC shared libs
|
# These hosts cannot use non-PIC shared libs
|
||||||
exit 77 ;;
|
exit 77 ;;
|
||||||
*-solaris*|*-sunos*)
|
*-solaris*|*-sunos*)
|
||||||
@@ -9185,7 +9185,7 @@ read at_status <"$at_status_file"
|
@@ -9298,7 +9298,7 @@
|
||||||
#AT_START_33
|
#AT_START_34
|
||||||
at_fn_group_banner 33 'demo.at:548' \
|
at_fn_group_banner 34 'demo.at:548' \
|
||||||
"hardcoding library path" " " 3
|
"hardcoding library path" " " 4
|
||||||
-at_xfail=no
|
-at_xfail=no
|
||||||
+at_xfail=yes
|
+at_xfail=yes
|
||||||
test no = "$ACLOCAL" && at_xfail=yes
|
test no = "$ACLOCAL" && at_xfail=yes
|
||||||
test no = "$AUTOHEADER" && at_xfail=yes
|
test no = "$AUTOHEADER" && at_xfail=yes
|
||||||
test no = "$AUTOMAKE" && at_xfail=yes
|
test no = "$AUTOMAKE" && at_xfail=yes
|
||||||
@@ -27052,7 +27052,7 @@ read at_status <"$at_status_file"
|
@@ -27243,7 +27243,7 @@
|
||||||
#AT_START_97
|
#AT_START_98
|
||||||
at_fn_group_banner 97 'destdir.at:75' \
|
at_fn_group_banner 98 'destdir.at:75' \
|
||||||
"DESTDIR with in-package deplibs" " " 7
|
"DESTDIR with in-package deplibs" " " 8
|
||||||
-at_xfail=no
|
-at_xfail=no
|
||||||
+at_xfail=yes
|
+at_xfail=yes
|
||||||
eval `$LIBTOOL --config | $GREP '^fast_install='`
|
eval `$LIBTOOL --config | $GREP '^fast_install='`
|
||||||
|
|
Loading…
Reference in New Issue