gnu: python-nose-timer: Update to 0.7.2.
* gnu/packages/check.scm (python-nose-timer): Update to 0.7.2. [source]: Remove patch... * gnu/packages/patches/python-nose-timer-drop-ordereddict.patch: ...delete file... * gnu/local.mk (dist_patch_DATA): ...and remove it.
This commit is contained in:
parent
ecbac51a0c
commit
1ba7a62362
|
@ -1050,7 +1050,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/python-genshi-stripping-of-unsafe-script-tags.patch \
|
%D%/packages/patches/python-genshi-stripping-of-unsafe-script-tags.patch \
|
||||||
%D%/packages/patches/python2-larch-coverage-4.0a6-compatibility.patch \
|
%D%/packages/patches/python2-larch-coverage-4.0a6-compatibility.patch \
|
||||||
%D%/packages/patches/python-networkx2-reproducible-build.patch \
|
%D%/packages/patches/python-networkx2-reproducible-build.patch \
|
||||||
%D%/packages/patches/python-nose-timer-drop-ordereddict.patch \
|
|
||||||
%D%/packages/patches/python-pillow-fix-failing-tests.patch \
|
%D%/packages/patches/python-pillow-fix-failing-tests.patch \
|
||||||
%D%/packages/patches/python2-rdflib-drop-sparqlwrapper.patch \
|
%D%/packages/patches/python2-rdflib-drop-sparqlwrapper.patch \
|
||||||
%D%/packages/patches/python-scikit-learn-fix-test-non-determinism.patch \
|
%D%/packages/patches/python-scikit-learn-fix-test-non-determinism.patch \
|
||||||
|
|
|
@ -1902,19 +1902,14 @@ create data based on random numbers and yet remain repeatable.")
|
||||||
(define-public python-nose-timer
|
(define-public python-nose-timer
|
||||||
(package
|
(package
|
||||||
(name "python-nose-timer")
|
(name "python-nose-timer")
|
||||||
(version "0.7.0")
|
(version "0.7.2")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (pypi-uri "nose-timer" version))
|
(uri (pypi-uri "nose-timer" version))
|
||||||
(patches
|
|
||||||
(search-patches
|
|
||||||
;; This patch will not be needed in the next version.
|
|
||||||
;; It is taken from the master branch.
|
|
||||||
"python-nose-timer-drop-ordereddict.patch"))
|
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1s32ymsnby8lz2qk55ifj9zi50dqcg6swnj5cz2rmwxg2jsslsxp"))))
|
"0ywg223p528014z5s0vzck74r4xyw3kvcp2casfnc85dkvir1zj7"))))
|
||||||
(build-system python-build-system)
|
(build-system python-build-system)
|
||||||
(propagated-inputs
|
(propagated-inputs
|
||||||
`(("python-nose" ,python-nose)
|
`(("python-nose" ,python-nose)
|
||||||
|
|
|
@ -1,44 +0,0 @@
|
||||||
From 700076019b5aff72aac7651cc830aaef21ee9a47 Mon Sep 17 00:00:00 2001
|
|
||||||
From: jakirkham <jakirkham@gmail.com>
|
|
||||||
Date: Fri, 7 Jul 2017 05:57:56 -0400
|
|
||||||
Subject: [PATCH] Drop ordereddict requirement (#84)
|
|
||||||
|
|
||||||
* Drop ordereddict requirement
|
|
||||||
|
|
||||||
As Python 2.7 is the minimum Python supported, every version of Python
|
|
||||||
should have `ordereddict` preincluded in the standard library one way or
|
|
||||||
another. So we can drop this dependency and just handle the differences
|
|
||||||
between Python 2 and Python 3.
|
|
||||||
---
|
|
||||||
nosetimer/plugin.py | 5 +----
|
|
||||||
setup.py | 1 -
|
|
||||||
2 files changed, 1 insertion(+), 5 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/nosetimer/plugin.py b/nosetimer/plugin.py
|
|
||||||
index ef28e11..d093a51 100644
|
|
||||||
--- a/nosetimer/plugin.py
|
|
||||||
+++ b/nosetimer/plugin.py
|
|
||||||
@@ -12,10 +12,7 @@
|
|
||||||
except ImportError:
|
|
||||||
import queue as Queue
|
|
||||||
|
|
||||||
-try:
|
|
||||||
- from collections import OrderedDict
|
|
||||||
-except ImportError:
|
|
||||||
- from ordereddict import OrderedDict
|
|
||||||
+from collections import OrderedDict
|
|
||||||
|
|
||||||
|
|
||||||
# define constants
|
|
||||||
diff --git a/setup.py b/setup.py
|
|
||||||
index 6a55b82..d249325 100755
|
|
||||||
--- a/setup.py
|
|
||||||
+++ b/setup.py
|
|
||||||
@@ -27,7 +27,6 @@
|
|
||||||
install_requires=[
|
|
||||||
'nose',
|
|
||||||
'termcolor',
|
|
||||||
- 'ordereddict',
|
|
||||||
],
|
|
||||||
license='MIT',
|
|
||||||
entry_points={
|
|
Loading…
Reference in New Issue