gnu: Remove dbus-localstatedir.patch.
This is a followup to 25087f. * gnu/packages/patches/dbus-localstatedir.patch: Remove file.
This commit is contained in:
parent
25087f60b6
commit
1c255eeec9
|
@ -1,39 +0,0 @@
|
||||||
Do not try to create $localstatedir and $sysconfdir since we cannot do this
|
|
||||||
when they are /var and /etc.
|
|
||||||
|
|
||||||
--- a/bus/Makefile.in
|
|
||||||
+++ b/bus/Makefile.in
|
|
||||||
@@ -565,7 +565,7 @@ top_build_prefix = @top_build_prefix@
|
|
||||||
top_builddir = @top_builddir@
|
|
||||||
top_srcdir = @top_srcdir@
|
|
||||||
dbusdatadir = $(datadir)/dbus-1
|
|
||||||
-legacydbusdatadir = $(sysconfdir)/dbus-1
|
|
||||||
+legacydbusdatadir = $(prefix)/etc/dbus-1
|
|
||||||
dbus_daemon_execdir = $(DBUS_DAEMONDIR)
|
|
||||||
DBUS_BUS_LIBS = \
|
|
||||||
$(XML_LIBS) \
|
|
||||||
@@ -1669,7 +1669,6 @@ clean-local:
|
|
||||||
install-data-hook:
|
|
||||||
$(mkinstalldirs) $(DESTDIR)$(dbusdatadir)/session.d
|
|
||||||
$(mkinstalldirs) $(DESTDIR)$(dbusdatadir)/services
|
|
||||||
-@DBUS_UNIX_TRUE@ $(mkinstalldirs) $(DESTDIR)$(localstatedir)/run/dbus
|
|
||||||
@DBUS_UNIX_TRUE@ $(mkinstalldirs) $(DESTDIR)$(dbusdatadir)/system.d
|
|
||||||
@DBUS_UNIX_TRUE@ $(mkinstalldirs) $(DESTDIR)$(dbusdatadir)/system-services
|
|
||||||
# Install dbus.socket as default implementation of a D-Bus stack.
|
|
||||||
diff --git a/tools/Makefile.in b/tools/Makefile.in
|
|
||||||
index 915971d..6b6897d 100644
|
|
||||||
--- a/tools/Makefile.in
|
|
||||||
+++ b/tools/Makefile.in
|
|
||||||
@@ -1055,12 +1055,6 @@ uninstall-am: uninstall-binPROGRAMS uninstall-dist_examplesSCRIPTS
|
|
||||||
.PRECIOUS: Makefile
|
|
||||||
|
|
||||||
|
|
||||||
-# create the /var/lib/dbus directory for dbus-uuidgen
|
|
||||||
-install-data-local:
|
|
||||||
- $(MKDIR_P) $(DESTDIR)$(localstatedir)/lib/dbus
|
|
||||||
-
|
|
||||||
-installcheck-local:
|
|
||||||
- test -d $(DESTDIR)$(localstatedir)/lib/dbus
|
|
||||||
|
|
||||||
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
|
||||||
# Otherwise a system limit (for SysV at least) may be exceeded.
|
|
Loading…
Reference in New Issue