gnu: coreutils: Update to 8.27.
* gnu/packages/base.scm (coreutils): Update to 8.27. [source](patches): Remove "coreutils-fix-cross-compilation.patch" and add "coreutils-cut-huge-range-test.patch". [native-inputs]: Remove "coreutils-cut-huge-range-test.patch". [arguments]: Remove 'patch-cut-test' phase. Remove #:parallel-tests?. * gnu/local.mk (dist_patch_DATA): Remove "coreutils-fix-cross-compilation.patch". * gnu/packages/patches/coreutils-fix-cross-compilation.patch: Remove. * gnu/packages/patches/coreutils-cut-huge-range-test.patch: Adjust.
This commit is contained in:
parent
34d624cef5
commit
1cbd63f205
|
@ -525,7 +525,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/cmake-fix-tests.patch \
|
%D%/packages/patches/cmake-fix-tests.patch \
|
||||||
%D%/packages/patches/coda-use-system-libs.patch \
|
%D%/packages/patches/coda-use-system-libs.patch \
|
||||||
%D%/packages/patches/coreutils-cut-huge-range-test.patch \
|
%D%/packages/patches/coreutils-cut-huge-range-test.patch \
|
||||||
%D%/packages/patches/coreutils-fix-cross-compilation.patch \
|
|
||||||
%D%/packages/patches/cpio-CVE-2016-2037.patch \
|
%D%/packages/patches/cpio-CVE-2016-2037.patch \
|
||||||
%D%/packages/patches/cpufrequtils-fix-aclocal.patch \
|
%D%/packages/patches/cpufrequtils-fix-aclocal.patch \
|
||||||
%D%/packages/patches/cracklib-CVE-2016-6318.patch \
|
%D%/packages/patches/cracklib-CVE-2016-6318.patch \
|
||||||
|
|
|
@ -286,15 +286,15 @@ used to apply commands with arbitrarily long arguments.")
|
||||||
(define-public coreutils
|
(define-public coreutils
|
||||||
(package
|
(package
|
||||||
(name "coreutils")
|
(name "coreutils")
|
||||||
(version "8.26")
|
(version "8.27")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "mirror://gnu/coreutils/coreutils-"
|
(uri (string-append "mirror://gnu/coreutils/coreutils-"
|
||||||
version ".tar.xz"))
|
version ".tar.xz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"13lspazc7xkviy93qz7ks9jv4sldvgmwpq36ghrbrqpq93br8phm"))
|
"0sv547572iq8ayy8klir4hnngnx92a9nsazmf1wgzfc7xr4x74c8"))
|
||||||
(patches (search-patches "coreutils-fix-cross-compilation.patch"))))
|
(patches (search-patches "coreutils-cut-huge-range-test.patch"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(inputs `(("acl" ,acl) ; TODO: add SELinux
|
(inputs `(("acl" ,acl) ; TODO: add SELinux
|
||||||
("gmp" ,gmp) ;bignums in 'expr', yay!
|
("gmp" ,gmp) ;bignums in 'expr', yay!
|
||||||
|
@ -309,21 +309,12 @@ used to apply commands with arbitrarily long arguments.")
|
||||||
;; copy of help2man. However, don't pass it when cross-compiling since
|
;; copy of help2man. However, don't pass it when cross-compiling since
|
||||||
;; that would lead it to try to run programs to get their '--help' output
|
;; that would lead it to try to run programs to get their '--help' output
|
||||||
;; for help2man.
|
;; for help2man.
|
||||||
`(,@(if (%current-target-system)
|
(if (%current-target-system)
|
||||||
'()
|
'()
|
||||||
`(("perl" ,perl)))
|
`(("perl" ,perl))))
|
||||||
|
|
||||||
;; Apply this patch only on ARM to avoid a full rebuild.
|
|
||||||
;; TODO: Move to 'patches' in the next update cycle.
|
|
||||||
,@(if (string-prefix? "arm" (or (%current-target-system)
|
|
||||||
(%current-system)))
|
|
||||||
`(("cut-test.patch"
|
|
||||||
,(search-patch "coreutils-cut-huge-range-test.patch")))
|
|
||||||
'())))
|
|
||||||
(outputs '("out" "debug"))
|
(outputs '("out" "debug"))
|
||||||
(arguments
|
(arguments
|
||||||
`(#:parallel-build? #f ; help2man may be called too early
|
`(#:parallel-build? #f ; help2man may be called too early
|
||||||
#:parallel-tests? #f ; race condition fixed after 8.26
|
|
||||||
#:phases (alist-cons-before
|
#:phases (alist-cons-before
|
||||||
'build 'patch-shell-references
|
'build 'patch-shell-references
|
||||||
(lambda* (#:key inputs #:allow-other-keys)
|
(lambda* (#:key inputs #:allow-other-keys)
|
||||||
|
@ -338,22 +329,7 @@ used to apply commands with arbitrarily long arguments.")
|
||||||
(substitute* (find-files "tests" "\\.sh$")
|
(substitute* (find-files "tests" "\\.sh$")
|
||||||
(("#!/bin/sh")
|
(("#!/bin/sh")
|
||||||
(format #f "#!~a/bin/sh" bash)))))
|
(format #f "#!~a/bin/sh" bash)))))
|
||||||
|
%standard-phases)))
|
||||||
,@(if (string-prefix? "arm" (or (%current-target-system)
|
|
||||||
(%current-system)))
|
|
||||||
'((alist-cons-before
|
|
||||||
'build 'patch-cut-test
|
|
||||||
(lambda* (#:key inputs native-inputs
|
|
||||||
#:allow-other-keys)
|
|
||||||
(let ((patch (or (assoc-ref inputs
|
|
||||||
"cut-test.patch")
|
|
||||||
(assoc-ref native-inputs
|
|
||||||
"cut-test.patch"))))
|
|
||||||
(zero?
|
|
||||||
(system* "patch" "-p1" "--force"
|
|
||||||
"--input" patch))))
|
|
||||||
%standard-phases))
|
|
||||||
'(%standard-phases)))))
|
|
||||||
(synopsis "Core GNU utilities (file, text, shell)")
|
(synopsis "Core GNU utilities (file, text, shell)")
|
||||||
(description
|
(description
|
||||||
"GNU Coreutils includes all of the basic command-line tools that are
|
"GNU Coreutils includes all of the basic command-line tools that are
|
||||||
|
|
|
@ -1,22 +1,33 @@
|
||||||
This patch fixes 100% reproducible test failures on arm-linux-gnueabihf in our
|
This patch fixes 100% reproducible test failures on arm-linux-gnueabihf in our
|
||||||
the build environment chroot, as reported at <https://bugs.gnu.org/26253>.
|
the build environment chroot, as reported at <https://bugs.gnu.org/26253>,
|
||||||
It is a followup to this upstream patch:
|
and now on x86_64-linux-gnu as well. It is a variant of this upstream patch:
|
||||||
|
|
||||||
commit 28803c8a3144d5d4363cdbd148bbe067af1a67c2
|
commit f5422009389678680dba9ff4ecb7d33632ee3383
|
||||||
Author: Pádraig Brady <P@draigBrady.com>
|
Author: Ludovic Courtès <ludo@gnu.org>
|
||||||
Date: Fri Mar 3 00:25:54 2017 -0800
|
Date: Mon Mar 27 20:34:39 2017 -0700
|
||||||
|
|
||||||
tests: avoid a spurious failure on older debian
|
tests: avoid false ulimit failure on some systems
|
||||||
|
|
||||||
|
* tests/misc/cut-huge-range.sh: On some systems returns_ may
|
||||||
|
use more memory, so incorporate that in the determination
|
||||||
|
of the ulimit value to use. Noticed on ARMv7 with bash-4.4.12,
|
||||||
|
and x86_64 with bash-4.2.37.
|
||||||
|
Fixes http://bugs.gnu.org/26253
|
||||||
|
|
||||||
... which appeared to be insufficient.
|
... which appeared to be insufficient.
|
||||||
|
|
||||||
|
diff --git a/tests/misc/cut-huge-range.sh b/tests/misc/cut-huge-range.sh
|
||||||
|
index 6b3c5b6ed..55b7b640e 100755
|
||||||
--- a/tests/misc/cut-huge-range.sh
|
--- a/tests/misc/cut-huge-range.sh
|
||||||
+++ b/tests/misc/cut-huge-range.sh
|
+++ b/tests/misc/cut-huge-range.sh
|
||||||
@@ -22,6 +22,7 @@ getlimits_
|
@@ -20,9 +20,9 @@
|
||||||
|
print_ver_ cut
|
||||||
|
getlimits_
|
||||||
|
|
||||||
vm=$(get_min_ulimit_v_ cut -b1 /dev/null) \
|
-vm=$(get_min_ulimit_v_ cut -b1 /dev/null) \
|
||||||
|
+vm=$(get_min_ulimit_v_ sh -c 'cut -b1 /dev/null') \
|
||||||
|| skip_ "this shell lacks ulimit support"
|
|| skip_ "this shell lacks ulimit support"
|
||||||
+vm=$(($vm + $(getconf PAGESIZE))) # avoid spurious failures
|
vm=$(($vm + 1000)) # avoid spurious failures
|
||||||
|
|
||||||
# sed script to subtract one from the input.
|
# sed script to subtract one from the input.
|
||||||
# Each input line should consist of a positive decimal number.
|
# Each input line should consist of a positive decimal number.
|
||||||
|
|
|
@ -1,15 +0,0 @@
|
||||||
Coreutils fails to cross compile for other platforms because cu_install_program
|
|
||||||
is not being evaluated properly. This patch fixes it.
|
|
||||||
See <https://lists.gnu.org/archive/html/coreutils/2017-01/msg00039.html>
|
|
||||||
--- a/Makefile.in
|
|
||||||
+++ b/Makefile.in
|
|
||||||
@@ -5023,7 +5023,7 @@ pr = progs-readme
|
|
||||||
@CROSS_COMPILING_FALSE@cu_install_program = src/ginstall
|
|
||||||
|
|
||||||
# Use the just-built 'ginstall', when not cross-compiling.
|
|
||||||
-@CROSS_COMPILING_TRUE@cu_install_program = @INSTALL_PROGRAM@
|
|
||||||
+@CROSS_COMPILING_TRUE@cu_install_program := @INSTALL@
|
|
||||||
info_TEXINFOS = doc/coreutils.texi
|
|
||||||
doc_coreutils_TEXINFOS = \
|
|
||||||
doc/perm.texi \
|
|
||||||
|
|
Loading…
Reference in New Issue