gnu: ghostscript: Add $libdir to the RUNPATH of executables.
Fixes <http://bugs.gnu.org/20050>. Reported by taylanbayirli@gmail.com (Taylan Ulrich Bayırlı/Kammer). * gnu/packages/patches/ghostscript-runpath.patch: New file. * gnu/packages/ghostscript.scm (ghostscript)[source]: Use it. * gnu-system.am (dist_patch_DATA): Add it.
This commit is contained in:
parent
c17b2adf54
commit
1d386b2d71
|
@ -412,6 +412,7 @@ dist_patch_DATA = \
|
|||
gnu/packages/patches/flex-bison-tests.patch \
|
||||
gnu/packages/patches/gawk-shell.patch \
|
||||
gnu/packages/patches/gcc-cross-environment-variables.patch \
|
||||
gnu/packages/patches/ghostscript-runpath.patch \
|
||||
gnu/packages/patches/glib-tests-desktop.patch \
|
||||
gnu/packages/patches/glib-tests-homedir.patch \
|
||||
gnu/packages/patches/glib-tests-prlimit.patch \
|
||||
|
|
|
@ -126,8 +126,10 @@ printing, and psresize, for adjusting page sizes.")
|
|||
(method url-fetch)
|
||||
(uri (string-append "mirror://gnu/ghostscript/gnu-ghostscript-"
|
||||
version ".tar.xz"))
|
||||
(sha256 (base32
|
||||
"0q4jj41p0qbr4mgcc9q78f5zs8cm1g57wgryhsm2yq4lfslm3ib1"))))
|
||||
(sha256
|
||||
(base32
|
||||
"0q4jj41p0qbr4mgcc9q78f5zs8cm1g57wgryhsm2yq4lfslm3ib1"))
|
||||
(patches (list (search-patch "ghostscript-runpath.patch")))))
|
||||
(build-system gnu-build-system)
|
||||
(inputs `(("freetype" ,freetype)
|
||||
("lcms" ,lcms)
|
||||
|
|
|
@ -0,0 +1,17 @@
|
|||
This patch adds $(libdir) to the RUNPATH of 'gsc' and 'gsx'.
|
||||
|
||||
--- gnu-ghostscript-9.14.0/base/unix-dll.mak 2015-04-05 15:12:45.386957927 +0200
|
||||
+++ gnu-ghostscript-9.14.0/base/unix-dll.mak 2015-04-05 15:12:49.222982359 +0200
|
||||
@@ -91,11 +91,11 @@ $(GS_SO_MAJOR): $(GS_SO_MAJOR_MINOR)
|
||||
# Build the small Ghostscript loaders, with Gtk+ and without
|
||||
$(GSSOC_XE): $(GS_SO) $(PSSRC)$(SOC_LOADER)
|
||||
$(GLCC) -g -o $(GSSOC_XE) $(PSSRC)dxmainc.c \
|
||||
- -L$(BINDIR) -l$(GS_SO_BASE)
|
||||
+ -L$(BINDIR) -l$(GS_SO_BASE) -Wl,-rpath=$(libdir)
|
||||
|
||||
$(GSSOX_XE): $(GS_SO) $(PSSRC)$(SOC_LOADER)
|
||||
$(GLCC) -g $(SOC_CFLAGS) -o $(GSSOX_XE) $(PSSRC)$(SOC_LOADER) \
|
||||
- -L$(BINDIR) -l$(GS_SO_BASE) $(SOC_LIBS)
|
||||
+ -L$(BINDIR) -l$(GS_SO_BASE) $(SOC_LIBS) -Wl,-rpath=$(libdir)
|
||||
|
||||
# ------------------------- Recursive make targets ------------------------- #
|
Loading…
Reference in New Issue