gnu: gst-plugins-base: Update to 1.10.4.

* gnu/packages/gstreamer.scm (gst-plugins-base): Update to 1.10.4.
[source]: Remove obsolete patch 'gst-plugins-base-fix-test-on-32bit.patch'
* gnu/packages/patches/gst-plugins-base-fix-test-on-32bit.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
master
Leo Famulari 2017-02-26 19:46:48 -05:00
parent c1ed10f95e
commit 1d8e727357
No known key found for this signature in database
GPG Key ID: 2646FA30BACA7F08
3 changed files with 6 additions and 37 deletions

View File

@ -605,7 +605,6 @@ dist_patch_DATA = \
%D%/packages/patches/grub-gets-undeclared.patch \
%D%/packages/patches/grub-freetype.patch \
%D%/packages/patches/gsl-test-i686.patch \
%D%/packages/patches/gst-plugins-base-fix-test-on-32bit.patch \
%D%/packages/patches/guile-1.8-cpp-4.5.patch \
%D%/packages/patches/guile-arm-fixes.patch \
%D%/packages/patches/guile-default-utf8.patch \

View File

@ -146,7 +146,7 @@ This package provides the core library and elements.")
(define-public gst-plugins-base
(package
(name "gst-plugins-base")
(version "1.10.3")
(version "1.10.4")
(source
(origin
(method url-fetch)
@ -154,9 +154,11 @@ This package provides the core library and elements.")
name "-" version ".tar.xz"))
(sha256
(base32
"040pifl4cgsqqz2si4s1y5khj3zwm39w21siagxwp805swbrcag6"))
(patches
(search-patches "gst-plugins-base-fix-test-on-32bit.patch"))))
"1dsyjf6rncsbg4rfj40cvf1wwpjj9h3j3c7bh4zp7jylnfv4blpn"))
; (patches
; (search-patches "gst-plugins-base-fix-test-on-32bit.patch"))
))
(build-system gnu-build-system)
(outputs '("out" "doc"))
(propagated-inputs

View File

@ -1,32 +0,0 @@
This fixes a test failure on i686.
Patch copied from upstream source repository:
https://cgit.freedesktop.org/gstreamer/gst-plugins-base/commit/?id=5e2e111627871c566ffc6607eda8f4ef4699d040
From 5e2e111627871c566ffc6607eda8f4ef4699d040 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Sebastian=20Dr=C3=B6ge?= <sebastian@centricular.com>
Date: Thu, 2 Feb 2017 14:56:39 +0200
Subject: [PATCH] multifdsink: Make sure to use a 64 bit integer for the
units-max property
---
tests/check/elements/multifdsink.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/tests/check/elements/multifdsink.c b/tests/check/elements/multifdsink.c
index af138cc92..951b1b9fa 100644
--- a/tests/check/elements/multifdsink.c
+++ b/tests/check/elements/multifdsink.c
@@ -869,7 +869,7 @@ GST_START_TEST (test_client_kick)
gint i, initial_buffers = 3, num_buffers = 0;
sink = setup_multifdsink ();
- g_object_set (sink, "units-max", initial_buffers, NULL);
+ g_object_set (sink, "units-max", (gint64) initial_buffers, NULL);
fail_if (pipe (pfd1) == -1);
fail_if (pipe (pfd2) == -1);
--
2.11.0