gnu: meandmyshadow: Update to 0.5.

* gnu/packages/games.scm (meandmyshadow): Update to 0.5.
[source]: Add unreleased bugfix patch.
[arguments]: Remove obsolete ‘set-sdl'paths’ phase.
[inputs]: Switch to SDL 2. Add lua. Remove libx11, mesa, and glu.
* gnu/packages/patches/meandmyshadow-define-paths-earlier.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
master
Tobias Geerinckx-Rice 2018-10-31 01:27:07 +01:00
parent 4cae7e67f3
commit 1d9a9d27ae
No known key found for this signature in database
GPG Key ID: 0DB0FF884F556D79
3 changed files with 63 additions and 26 deletions

View File

@ -951,6 +951,7 @@ dist_patch_DATA = \
%D%/packages/patches/mcrypt-CVE-2012-4409.patch \
%D%/packages/patches/mcrypt-CVE-2012-4426.patch \
%D%/packages/patches/mcrypt-CVE-2012-4527.patch \
%D%/packages/patches/meandmyshadow-define-paths-earlier.patch \
%D%/packages/patches/mesa-skip-disk-cache-test.patch \
%D%/packages/patches/meson-for-build-rpath.patch \
%D%/packages/patches/metabat-fix-compilation.patch \

View File

@ -572,7 +572,7 @@ automata. The following features are available:
(define-public meandmyshadow
(package
(name "meandmyshadow")
(version "0.4.1")
(version "0.5")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/meandmyshadow/"
@ -580,37 +580,23 @@ automata. The following features are available:
"-src.tar.gz"))
(sha256
(base32
"0wl5dc75qy001s6043cx0vr2l5y2qfv1cldqnwill9sfygqj9p95"))))
"1b6qf83vdfv8jwn2jq9ywmda2qn2f5914i7mwfy04m17wx593m3m"))
(patches (search-patches
;; This will not be needed in the next release.
"meandmyshadow-define-paths-earlier.patch"))))
(build-system cmake-build-system)
(arguments
'(#:tests? #f ; there are no tests
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'set-sdl'paths
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "cmake/Modules/FindSDL_gfx.cmake"
(("/usr/local/include/SDL")
(string-append (assoc-ref inputs "sdl")
"/include/SDL")))
;; Because SDL provides lib/libX11.so.6 we need to explicitly
;; link with libX11, even though we're using the GL backend.
(substitute* "CMakeLists.txt"
(("\\$\\{X11_LIBRARIES\\}") "-lX11"))
#t)))))
`(#:tests? #f)) ; there are no tests
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs
`(("sdl" ,(sdl-union (list sdl
sdl-image
sdl-gfx
sdl-mixer
sdl-ttf)))
("libx11" ,libx11) ; needed by sdl's libX11
`(("curl" ,curl)
("libarchive" ,libarchive)
("openssl" ,openssl)
("mesa" ,mesa)
("glu" ,glu)
("curl" ,curl)))
("lua" ,lua)
("sdl" ,(sdl-union (list sdl2
sdl2-image
sdl2-mixer
sdl2-ttf)))))
(home-page "http://meandmyshadow.sourceforge.net/")
(synopsis "Puzzle/platform game")
(description "Me and My Shadow is a puzzle/platform game in which you try

View File

@ -0,0 +1,50 @@
From: Tobias Geerinckx-Rice <me@tobias.gr>
Date: Wed, 31 Oct 2018 02:24:26 +0100
Subject: [PATCH] gnu: meandmyshadow: Define paths earlier.
The following patch was taken verbatim from the upstream repository[0]
and will be included in the next release.
[0]: https://github.com/acmepjz/meandmyshadow/pull/29
---
From 4847e6b5755258a1e0534f2d4b91dce2ce3b459e Mon Sep 17 00:00:00 2001
From: Dmitry Marakasov <amdmi3@amdmi3.ru>
Date: Wed, 24 Oct 2018 23:31:19 +0300
Subject: [PATCH] Define paths earlier in CMakeLists.txt
At the very least, paths should be defined before Configure_File(), otherwise empty DATAROOTDIR is substituted in config.h
---
CMakeLists.txt | 13 +++++++------
1 file changed, 7 insertions(+), 6 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e79639a..6321d9d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,6 +2,13 @@ Project (meandmyshadow)
CMake_Minimum_Required (VERSION 3.1)
Set (CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/cmake/Modules/")
+#Path options
+Set (BINDIR "bin" CACHE STRING "Where to install binaries")
+Set (DATAROOTDIR "${CMAKE_INSTALL_PREFIX}/share" CACHE STRING "Sets the root of data directories to a non-default location")
+Set (ICONDIR "${DATAROOTDIR}/icons" CACHE STRING "Sets the icon directory for desktop entry to a non-default location.")
+Set (DESKTOPDIR "${DATAROOTDIR}/applications" CACHE STRING "Sets the desktop file directory for desktop entry to a non-default location.")
+
+#Options
Option (DEBUG_MODE "Compile the game with debug mode enabled" OFF)
Option (DISABLED_DEBUG_STUFF "Enable this you'll see a lot of annoying script debug messages which will lag the game." OFF)
@@ -164,12 +171,6 @@ Target_Link_Libraries (
${LUA_LIBRARIES}
)
-#Path options
-Set (BINDIR "bin" CACHE STRING "Where to install binaries")
-Set (DATAROOTDIR "${CMAKE_INSTALL_PREFIX}/share" CACHE STRING "Sets the root of data directories to a non-default location")
-Set (ICONDIR "${DATAROOTDIR}/icons" CACHE STRING "Sets the icon directory for desktop entry to a non-default location.")
-Set (DESKTOPDIR "${DATAROOTDIR}/applications" CACHE STRING "Sets the desktop file directory for desktop entry to a non-default location.")
-
#Install locations
Install (DIRECTORY ${PROJECT_SOURCE_DIR}/data DESTINATION ${DATAROOTDIR}/meandmyshadow/)
Install (FILES AUTHORS DESTINATION ${DATAROOTDIR}/meandmyshadow/)