gnu: btrfs-progs: Update to 4.17.1.
* gnu/packages/linux.scm (btrfs-progs): Update to 4.17.1. [source]: Remove patch. [native-inputs]: Add python. * gnu/packages/patches/btrfs-progs-e-value-block.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
76c888cb94
commit
1dfb14d2f7
|
@ -594,7 +594,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/binutils-loongson-workaround.patch \
|
||||
%D%/packages/patches/blast+-fix-makefile.patch \
|
||||
%D%/packages/patches/boost-fix-icu-build.patch \
|
||||
%D%/packages/patches/btrfs-progs-e-value-block.patch \
|
||||
%D%/packages/patches/byobu-writable-status.patch \
|
||||
%D%/packages/patches/cairo-CVE-2016-9082.patch \
|
||||
%D%/packages/patches/calibre-no-updates-dialog.patch \
|
||||
|
|
|
@ -3240,7 +3240,7 @@ and copy/paste text in the console and in xterm.")
|
|||
(define-public btrfs-progs
|
||||
(package
|
||||
(name "btrfs-progs")
|
||||
(version "4.15.1")
|
||||
(version "4.17.1")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://kernel.org/linux/kernel/"
|
||||
|
@ -3248,8 +3248,7 @@ and copy/paste text in the console and in xterm.")
|
|||
"btrfs-progs-v" version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"15izak6jg6pqr6ha9447cdrdj9k6kfiarvwlrj53cpvrsv02l437"))
|
||||
(patches (search-patches "btrfs-progs-e-value-block.patch"))))
|
||||
"0x6d53fbrcmzvhv461575fzsv3373427p4srz646w2wcagqk82xz"))))
|
||||
(build-system gnu-build-system)
|
||||
(outputs '("out"
|
||||
"static")) ; static versions of the binaries in "out"
|
||||
|
@ -3285,6 +3284,7 @@ and copy/paste text in the console and in xterm.")
|
|||
("zstd" ,zstd)))
|
||||
(native-inputs `(("pkg-config" ,pkg-config)
|
||||
("asciidoc" ,asciidoc)
|
||||
("python" ,python)
|
||||
("xmlto" ,xmlto)
|
||||
;; For building documentation.
|
||||
("libxml2" ,libxml2)
|
||||
|
|
|
@ -1,37 +0,0 @@
|
|||
From c78f59a971ce4b543f3177e383b677862b2d9fb5 Mon Sep 17 00:00:00 2001
|
||||
From: Qu Wenruo <wqu@suse.com>
|
||||
Date: Wed, 14 Mar 2018 08:56:57 +0800
|
||||
Subject: [PATCH] btrfs-progs: convert/ext2: Remove check for
|
||||
ext2_ext_attr_entry->e_value_block
|
||||
|
||||
In latest e2fsprogs (1.44.0) definition of ext2_ext_attr_entry has
|
||||
removed member e_value_block, as currently ext* doesn't support it set
|
||||
anyway.
|
||||
|
||||
So remove such check so that we can pass compile.
|
||||
|
||||
Issue: #110
|
||||
Bugzilla: https://bugzilla.kernel.org/show_bug.cgi?id=199071
|
||||
Signed-off-by: Qu Wenruo <wqu@suse.com>
|
||||
Signed-off-by: David Sterba <dsterba@suse.com>
|
||||
---
|
||||
convert/source-ext2.c | 3 +--
|
||||
1 file changed, 1 insertion(+), 2 deletions(-)
|
||||
|
||||
diff --git a/convert/source-ext2.c b/convert/source-ext2.c
|
||||
index b1492c78..070126ec 100644
|
||||
--- a/convert/source-ext2.c
|
||||
+++ b/convert/source-ext2.c
|
||||
@@ -422,8 +422,7 @@ static int ext2_xattr_check_entry(struct ext2_ext_attr_entry *entry,
|
||||
{
|
||||
size_t value_size = entry->e_value_size;
|
||||
|
||||
- if (entry->e_value_block != 0 || value_size > size ||
|
||||
- entry->e_value_offs + value_size > size)
|
||||
+ if (value_size > size || entry->e_value_offs + value_size > size)
|
||||
return -EIO;
|
||||
return 0;
|
||||
}
|
||||
--
|
||||
2.16.3
|
||||
|
Loading…
Reference in New Issue