gnu: node: Update to 7.10.0.

* gnu/packages/node.scm (node): Update to 7.10.0.
(node)[arguments]: Disabled more tests.
* gnu/packages/patches/node-9077.patch: Delete incompatible patch file.
Recreate patch file from node pull request 9077.

Signed-off-by: Marius Bakke <mbakke@fastmail.com>
This commit is contained in:
Jelle Licht 2017-05-22 20:03:20 +02:00 committed by Marius Bakke
parent a7a7186ce6
commit 1fdb883082
No known key found for this signature in database
GPG Key ID: A2A06DF2A33A54FA
2 changed files with 18 additions and 15 deletions

View File

@ -38,14 +38,14 @@
(define-public node (define-public node
(package (package
(name "node") (name "node")
(version "7.8.0") (version "7.10.0")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (string-append "http://nodejs.org/dist/v" version (uri (string-append "http://nodejs.org/dist/v" version
"/node-v" version ".tar.gz")) "/node-v" version ".tar.gz"))
(sha256 (sha256
(base32 (base32
"1nkngdjbsm81nn3v0w0c2aqx9nb7mwy3z49ynq4wwcrzfr9ap8ka")) "00vdmb0z8b2sd547bkksgy9dfq5gi5xfd9b3f0rc4ngvpzl3z164"))
;; https://github.com/nodejs/node/pull/9077 ;; https://github.com/nodejs/node/pull/9077
(patches (search-patches "node-9077.patch")))) (patches (search-patches "node-9077.patch"))))
(build-system gnu-build-system) (build-system gnu-build-system)
@ -86,7 +86,9 @@
"test/parallel/test-cluster-master-error.js" "test/parallel/test-cluster-master-error.js"
"test/parallel/test-cluster-master-kill.js" "test/parallel/test-cluster-master-kill.js"
"test/parallel/test-npm-install.js" "test/parallel/test-npm-install.js"
"test/sequential/test-child-process-emfile.js")) "test/sequential/test-child-process-emfile.js"
"test/sequential/test-benchmark-child-process.js"
"test/sequential/test-http-regr-gh-2928.js"))
#t)) #t))
(replace 'configure (replace 'configure
;; Node's configure script is actually a python script, so we can't ;; Node's configure script is actually a python script, so we can't

View File

@ -12,19 +12,20 @@ zlib. Using a shared zlib results in build breakage:
^ ~~~~~~~~~~~~~~~~~ ^ ~~~~~~~~~~~~~~~~~
1 error generated. 1 error generated.
--- ---
node.gyp | 2 ++ node.gyp | 3 ++-
1 file changed, 2 insertions(+) 1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/node.gyp b/node.gyp diff --git a/node.gyp b/node.gyp
index fa98547..d799ba1 100644 index 272dc98..667c260 100644
--- a/node.gyp --- a/node.gyp
+++ b/node.gyp +++ b/node.gyp
@@ -480,6 +480,8 @@ @@ -653,7 +653,8 @@
}], [ 'node_shared_zlib=="false"', {
[ 'node_shared_zlib=="false"', { 'dependencies': [
'dependencies': [ 'deps/zlib/zlib.gyp:zlib' ], 'deps/zlib/zlib.gyp:zlib',
+ }, { - ]
+ 'defines': [ 'ZLIB_CONST' ], + ]}, {
}], + 'defines': [ 'ZLIB_CONST' ],
}],
[ 'node_shared_http_parser=="false"', { [ 'node_shared_openssl=="false"', {
'dependencies': [