gnu: gitolite: Update to 3.6.5.
* gnu/packages/version-control.scm (gitolite): Update to 3.6.5. [source]: Remove patch. * gnu/packages/patches/gitolite-openssh-6.8-compat.patch: Remove file. * gnu-system.am (dist_patch_DATA): Remove it.
This commit is contained in:
parent
b65195c2cc
commit
20109e07bd
|
@ -484,7 +484,6 @@ dist_patch_DATA = \
|
|||
gnu/packages/patches/geoclue-config.patch \
|
||||
gnu/packages/patches/ghostscript-CVE-2015-3228.patch \
|
||||
gnu/packages/patches/ghostscript-runpath.patch \
|
||||
gnu/packages/patches/gitolite-openssh-6.8-compat.patch \
|
||||
gnu/packages/patches/glib-networking-ssl-cert-file.patch \
|
||||
gnu/packages/patches/glib-tests-desktop.patch \
|
||||
gnu/packages/patches/glib-tests-homedir.patch \
|
||||
|
|
|
@ -1,25 +0,0 @@
|
|||
From ed807a40c6683960e357bc995b3acf721ec088b4 Mon Sep 17 00:00:00 2001
|
||||
From: Sitaram Chamarty <sitaram@atc.tcs.com>
|
||||
Date: Thu, 19 Mar 2015 05:17:59 +0530
|
||||
Subject: [PATCH] openssh 6.8 compat
|
||||
|
||||
---
|
||||
src/triggers/post-compile/ssh-authkeys | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/triggers/post-compile/ssh-authkeys b/src/triggers/post-compile/ssh-authkeys
|
||||
index 84dda73..d5f5d8b 100755
|
||||
--- a/src/triggers/post-compile/ssh-authkeys
|
||||
+++ b/src/triggers/post-compile/ssh-authkeys
|
||||
@@ -115,7 +115,7 @@ sub fp_file {
|
||||
my $f = shift;
|
||||
my $fp = `ssh-keygen -l -f '$f'`;
|
||||
chomp($fp);
|
||||
- _die "fingerprinting failed for '$f'" unless $fp =~ /([0-9a-f][0-9a-f](:[0-9a-f][0-9a-f])+)/;
|
||||
+ _die "fingerprinting failed for '$f'" unless $fp =~ /([0-9a-f][0-9a-f](:[0-9a-f][0-9a-f])+)/ or $fp =~ m(SHA256:([A-ZA-z0-9+/]+));
|
||||
$fp = $1;
|
||||
return $fp;
|
||||
}
|
||||
--
|
||||
2.2.1
|
||||
|
|
@ -489,19 +489,16 @@ also walk each side of a merge and test those changes individually.")
|
|||
(define-public gitolite
|
||||
(package
|
||||
(name "gitolite")
|
||||
(version "3.6.2")
|
||||
(version "3.6.5")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append
|
||||
"https://github.com/sitaramc/gitolite/archive/v"
|
||||
version ".tar.gz"))
|
||||
(file-name (string-append name "-" version ".tar.gz"))
|
||||
;; Commit ed807a4 upstream
|
||||
(patches
|
||||
(list (search-patch "gitolite-openssh-6.8-compat.patch")))
|
||||
(sha256
|
||||
(base32
|
||||
"1gsgzi9ayb4rablki3mqr11b0h8db4xg43df660marfpacmkfb01"))))
|
||||
"0xpqg04gyr4dhdhxx5lbk61lwwd5ml32530bigg2qy663icngwqm"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
'(#:tests? #f ; no tests
|
||||
|
|
Loading…
Reference in New Issue