gnu: eudev: Update to 3.2.2.
* gnu/packages/linux.scm (eudev): Update to 3.2.2. [source](patches): Remove "eudev-conflicting-declaration.patch". * gnu/packages/patches/eudev-conflicting-declaration.patch: Remove. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
4e859e9233
commit
202342fdda
|
@ -570,7 +570,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/emacs-scheme-complete-scheme-r5rs-info.patch \
|
||||
%D%/packages/patches/emacs-source-date-epoch.patch \
|
||||
%D%/packages/patches/eudev-rules-directory.patch \
|
||||
%D%/packages/patches/eudev-conflicting-declaration.patch \
|
||||
%D%/packages/patches/evilwm-lost-focus-bug.patch \
|
||||
%D%/packages/patches/expat-CVE-2016-0718-fix-regression.patch \
|
||||
%D%/packages/patches/fabric-tests.patch \
|
||||
|
|
|
@ -1831,7 +1831,7 @@ from the module-init-tools project.")
|
|||
;; The post-systemd fork, maintained by Gentoo.
|
||||
(package
|
||||
(name "eudev")
|
||||
(version "3.2.1")
|
||||
(version "3.2.2")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append
|
||||
|
@ -1839,9 +1839,8 @@ from the module-init-tools project.")
|
|||
version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"06gyyl90n85x8i7lfhns514y1kg1ians13l467admyzy3kjxkqsp"))
|
||||
(patches (search-patches "eudev-rules-directory.patch"
|
||||
"eudev-conflicting-declaration.patch"))))
|
||||
"0qqgbgpm5wdllk0s04pf80nwc8pr93xazwri1bylm1f15zn5ck1y"))
|
||||
(patches (search-patches "eudev-rules-directory.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
'(#:phases (modify-phases %standard-phases
|
||||
|
|
|
@ -1,31 +0,0 @@
|
|||
Fix build failure due to conflicting declaration of
|
||||
keyboard_lookup_key() in gperf-3.1:
|
||||
|
||||
https://bugs.gentoo.org/show_bug.cgi?id=604864
|
||||
|
||||
Patch copied from upstream source repository:
|
||||
|
||||
https://github.com/gentoo/eudev/commit/5bab4d8de0dcbb8e2e7d4d5125b4aea1652a0d60
|
||||
|
||||
From 5bab4d8de0dcbb8e2e7d4d5125b4aea1652a0d60 Mon Sep 17 00:00:00 2001
|
||||
From: "Anthony G. Basile" <blueness@gentoo.org>
|
||||
Date: Thu, 5 Jan 2017 16:21:17 -0500
|
||||
Subject: [PATCH] src/udev/udev-builtin-keyboard.c: fix build with gperf 3.1
|
||||
|
||||
Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
|
||||
---
|
||||
src/udev/udev-builtin-keyboard.c | 1 -
|
||||
1 file changed, 1 deletion(-)
|
||||
|
||||
diff --git a/src/udev/udev-builtin-keyboard.c b/src/udev/udev-builtin-keyboard.c
|
||||
index 73171c3..fad3520 100644
|
||||
--- a/src/udev/udev-builtin-keyboard.c
|
||||
+++ b/src/udev/udev-builtin-keyboard.c
|
||||
@@ -28,7 +28,6 @@
|
||||
|
||||
#include "udev.h"
|
||||
|
||||
-static const struct key *keyboard_lookup_key(const char *str, unsigned len);
|
||||
#include "keyboard-keys-from-name.h"
|
||||
#include "keyboard-keys-to-name.h"
|
||||
|
Loading…
Reference in New Issue