gnu: vsearch: Update to 2.4.0.
* gnu/packages/bioinformatics.scm (vsearch): Update to 2.4.0. [source]: Convert most operations in the snippet to patch form and adjust for 2.4.0. * gnu/packages/patches/vsearch-unbundle-cityhash.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
This commit is contained in:
parent
c8916c3336
commit
206af46fe1
|
@ -5748,7 +5748,7 @@ track. The database is exposed as a @code{TxDb} object.")
|
|||
(define-public vsearch
|
||||
(package
|
||||
(name "vsearch")
|
||||
(version "2.3.4")
|
||||
(version "2.4.0")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
|
@ -5758,31 +5758,12 @@ track. The database is exposed as a @code{TxDb} object.")
|
|||
(file-name (string-append name "-" version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"1xyraxmhyx62mxx8z7c8waygvcijwkh48ms1ar60w2cv2y2sn4al"))
|
||||
(modules '((guix build utils)))
|
||||
"007q9a50hdw4vs2iajabvbw7qccml4r8cbqzyi5ipkkf42jk3vnr"))
|
||||
(patches (search-patches "vsearch-unbundle-cityhash.patch"))
|
||||
(snippet
|
||||
'(begin
|
||||
;; Remove bundled cityhash and '-mtune=native'.
|
||||
(substitute* "src/Makefile.am"
|
||||
(("^AM_CXXFLAGS=-I\\$\\{srcdir\\}/cityhash \
|
||||
-O3 -mtune=native -Wall -Wsign-compare")
|
||||
(string-append "AM_CXXFLAGS=-lcityhash"
|
||||
" -O3 -Wall -Wsign-compare"))
|
||||
(("^__top_builddir__bin_vsearch_SOURCES = city.h \\\\")
|
||||
"__top_builddir__bin_vsearch_SOURCES = \\")
|
||||
(("^city.h \\\\") "\\")
|
||||
(("^citycrc.h \\\\") "\\")
|
||||
(("^libcityhash_a.*") "")
|
||||
(("noinst_LIBRARIES = libcpu_sse2.a libcpu_ssse3.a \
|
||||
libcityhash.a")
|
||||
"noinst_LIBRARIES = libcpu_sse2.a libcpu_ssse3.a")
|
||||
(("__top_builddir__bin_vsearch_LDADD = libcpu_ssse3.a \
|
||||
libcpu_sse2.a libcityhash.a")
|
||||
"__top_builddir__bin_vsearch_LDADD = libcpu_ssse3.a \
|
||||
libcpu_sse2.a -lcityhash"))
|
||||
(substitute* "src/vsearch.h"
|
||||
(("^\\#include \"city.h\"") "#include <city.h>")
|
||||
(("^\\#include \"citycrc.h\"") "#include <citycrc.h>"))
|
||||
;; Remove bundled cityhash sources. The vsearch source is adjusted
|
||||
;; for this in the patch.
|
||||
(delete-file "src/city.h")
|
||||
(delete-file "src/citycrc.h")
|
||||
(delete-file "src/city.cc")
|
||||
|
|
|
@ -0,0 +1,73 @@
|
|||
diff --git a/src/Makefile.am b/src/Makefile.am
|
||||
index e56a8a2..4adcc48 100644
|
||||
--- a/src/Makefile.am
|
||||
+++ b/src/Makefile.am
|
||||
@@ -3,7 +3,7 @@ bin_PROGRAMS = $(top_builddir)/bin/vsearch
|
||||
if TARGET_PPC
|
||||
AM_CXXFLAGS=-Wall -Wsign-compare -O3 -g -mcpu=power8
|
||||
else
|
||||
-AM_CXXFLAGS=-Wall -Wsign-compare -O3 -g
|
||||
+AM_CXXFLAGS=-Wall -Wsign-compare -O3 -g -lcityhash
|
||||
endif
|
||||
|
||||
AM_CFLAGS=$(AM_CXXFLAGS)
|
||||
@@ -18,8 +18,6 @@ allpairs.h \
|
||||
arch.h \
|
||||
bitmap.h \
|
||||
chimera.h \
|
||||
-city.h \
|
||||
-citycrc.h \
|
||||
cluster.h \
|
||||
cpu.h \
|
||||
db.h \
|
||||
@@ -59,31 +57,26 @@ xstring.h
|
||||
|
||||
if TARGET_PPC
|
||||
libcpu_a_SOURCES = cpu.cc $(VSEARCHHEADERS)
|
||||
-noinst_LIBRARIES = libcpu.a libcityhash.a
|
||||
+noinst_LIBRARIES = libcpu.a
|
||||
else
|
||||
libcpu_sse2_a_SOURCES = cpu.cc $(VSEARCHHEADERS)
|
||||
libcpu_sse2_a_CXXFLAGS = $(AM_CXXFLAGS) -msse2
|
||||
libcpu_ssse3_a_SOURCES = cpu.cc $(VSEARCHHEADERS)
|
||||
libcpu_ssse3_a_CXXFLAGS = $(AM_CXXFLAGS) -mssse3 -DSSSE3
|
||||
-noinst_LIBRARIES = libcpu_sse2.a libcpu_ssse3.a libcityhash.a
|
||||
+noinst_LIBRARIES = libcpu_sse2.a libcpu_ssse3.a
|
||||
endif
|
||||
|
||||
-libcityhash_a_SOURCES = city.cc city.h
|
||||
-
|
||||
if TARGET_WIN
|
||||
|
||||
-libcityhash_a_CXXFLAGS = -Wall -Wno-sign-compare -O3 -g -D_MSC_VER
|
||||
-__top_builddir__bin_vsearch_LDFLAGS = -static
|
||||
-__top_builddir__bin_vsearch_LDADD = libregex.a libcityhash.a libcpu_ssse3.a libcpu_sse2.a
|
||||
+__top_builddir__bin_vsearch_LDFLAGS = -static -lcityhash
|
||||
+__top_builddir__bin_vsearch_LDADD = libregex.a libcpu_ssse3.a libcpu_sse2.a
|
||||
|
||||
else
|
||||
|
||||
-libcityhash_a_CXXFLAGS = -Wall -Wno-sign-compare -O3 -g
|
||||
-
|
||||
if TARGET_PPC
|
||||
-__top_builddir__bin_vsearch_LDADD = libcityhash.a libcpu.a
|
||||
+__top_builddir__bin_vsearch_LDADD = libcpu.a
|
||||
else
|
||||
-__top_builddir__bin_vsearch_LDADD = libcityhash.a libcpu_ssse3.a libcpu_sse2.a
|
||||
+__top_builddir__bin_vsearch_LDADD = libcpu_ssse3.a libcpu_sse2.a
|
||||
endif
|
||||
|
||||
endif
|
||||
diff --git a/src/vsearch.h b/src/vsearch.h
|
||||
index f2c244b..5f51bbe 100644
|
||||
--- a/src/vsearch.h
|
||||
+++ b/src/vsearch.h
|
||||
@@ -148,7 +148,7 @@
|
||||
#include <bzlib.h>
|
||||
#endif
|
||||
|
||||
-#include "city.h"
|
||||
+#include <city.h>
|
||||
#include "md5.h"
|
||||
#include "sha1.h"
|
||||
|
Loading…
Reference in New Issue