gnu: xapian: Update to 1.4.9.
* gnu/packages/patches/xapian-revert-5489fb2f8.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. * gnu/packages/search.scm (xapian): Update to 1.4.9. [source](patches): Remove. (python-xapian-bindings): Update to 1.4.9.
This commit is contained in:
parent
d79c8148cc
commit
208e82297c
|
@ -1230,7 +1230,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/wpa-supplicant-krack-followups.patch \
|
||||
%D%/packages/patches/wxmaxima-do-not-use-old-gnuplot-parameters.patch \
|
||||
%D%/packages/patches/x265-detect512-all-arches.patch \
|
||||
%D%/packages/patches/xapian-revert-5489fb2f8.patch \
|
||||
%D%/packages/patches/xboing-CVE-2004-0149.patch \
|
||||
%D%/packages/patches/xf86-video-ark-remove-mibstore.patch \
|
||||
%D%/packages/patches/xf86-video-geode-glibc-2.20.patch \
|
||||
|
|
|
@ -1,23 +0,0 @@
|
|||
Revert this upstream commit which breaks a test case in "notmuch":
|
||||
|
||||
https://git.xapian.org/?p=xapian;a=commitdiff;h=5489fb2f838c0f0b0a593b4c17df282a93a1fe5a
|
||||
|
||||
See the notmuch FAQ entry:
|
||||
|
||||
https://notmuchmail.org/faq/#index12h2
|
||||
|
||||
This should be fixed for later releases.
|
||||
|
||||
diff --git a/backends/glass/glass_postlist.cc b/xapian-core/backends/glass/glass_postlist.cc
|
||||
index 80e578b85..a47f14a68 100644
|
||||
--- a/backends/glass/glass_postlist.cc
|
||||
+++ b/backends/glass/glass_postlist.cc
|
||||
@@ -759,7 +759,7 @@ GlassPostList::open_nearby_postlist(const std::string & term_,
|
||||
(void)need_pos;
|
||||
if (term_.empty())
|
||||
RETURN(NULL);
|
||||
- if (!this_db.get() || this_db->postlist_table.is_modified())
|
||||
+ if (!this_db.get() || this_db->postlist_table.is_writable())
|
||||
RETURN(NULL);
|
||||
RETURN(new GlassPostList(this_db, term_, cursor->clone()));
|
||||
}
|
|
@ -46,15 +46,14 @@
|
|||
(define-public xapian
|
||||
(package
|
||||
(name "xapian")
|
||||
(version "1.4.7")
|
||||
(version "1.4.9")
|
||||
;; Note: When updating Xapian, remember to update xapian-bindings below.
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "https://oligarchy.co.uk/xapian/" version
|
||||
"/xapian-core-" version ".tar.xz"))
|
||||
(patches (search-patches "xapian-revert-5489fb2f8.patch"))
|
||||
(sha256
|
||||
(base32 "1lxmlds3v5s1gng9nk1rvmln1zcksrw5ds509y0glylwch5qmw0k"))))
|
||||
(base32 "1k7m7m9jld96k16ansfw2w3c354pvd8ibhnrb6dw012g06fw7sfd"))))
|
||||
(build-system gnu-build-system)
|
||||
(inputs `(("zlib" ,zlib)
|
||||
("util-linux" ,util-linux)))
|
||||
|
@ -92,7 +91,7 @@ rich set of boolean query operators.")
|
|||
"/xapian-bindings-" version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"0sjf9ck3a6p7xnd84w09l6s0xn2g03k9a9417f4mjnywfq9pa6a5"))))
|
||||
"0ll3z3418r7bzxs4kyini2cbci5xl8i5scl3wyx88s2v4ak56bcz"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
`(#:configure-flags '("--with-python3")
|
||||
|
|
Loading…
Reference in New Issue