gnu: dico: Patch 'idxgcide' bug.
* gnu/packages/patches/dico-idxgcide-bug.patch: New file. * gnu/packages/dico.scm (dico)[source]: Use it. * gnu/local.mk (dist_patch_DATA): Add it.
This commit is contained in:
parent
c6b3dc69bd
commit
212163f8d5
|
@ -471,6 +471,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/dealii-p4est-interface.patch \
|
||||
%D%/packages/patches/devil-CVE-2009-3994.patch \
|
||||
%D%/packages/patches/devil-fix-libpng.patch \
|
||||
%D%/packages/patches/dico-idxgcide-bug.patch \
|
||||
%D%/packages/patches/dico-libtool-deterministic.patch \
|
||||
%D%/packages/patches/diffutils-gets-undeclared.patch \
|
||||
%D%/packages/patches/dfu-programmer-fix-libusb.patch \
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
;;; GNU Guix --- Functional package management for GNU
|
||||
;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
|
||||
;;; Copyright © 2015, 2016 Ludovic Courtès <ludo@gnu.org>
|
||||
;;;
|
||||
;;; This file is part of GNU Guix.
|
||||
;;;
|
||||
|
@ -44,7 +44,8 @@
|
|||
(base32
|
||||
"04pjks075x20d19l623mj50bw64g8i41s63z4kzzqcbg9qg96x64"))
|
||||
(patches (search-patches "cpio-gets-undeclared.patch"
|
||||
"dico-libtool-deterministic.patch"))))
|
||||
"dico-libtool-deterministic.patch"
|
||||
"dico-idxgcide-bug.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
'(#:configure-flags (list (string-append "--with-guile-site-dir=" %output
|
||||
|
|
|
@ -0,0 +1,21 @@
|
|||
Reported at <http://mail.gnu.org.ua/archives/bug-dico/2016-07/msg00000.html>.
|
||||
Patch the .c file to avoid depending on Flex.
|
||||
|
||||
commit 4599abbda3b5979367138ea098e435c919fe93fc
|
||||
Author: Sergey Poznyakoff <gray@gnu.org>
|
||||
Date: Thu Jul 28 14:09:58 2016 +0300
|
||||
|
||||
Bugfix
|
||||
|
||||
* modules/gcide/idxgcide.l (main): Initialize ipg_header.
|
||||
|
||||
--- dico-2.2/modules/gcide/idxgcide.c 2016-07-28 14:15:07.823587004 +0200
|
||||
+++ dico-2.2/modules/gcide/idxgcide.c 2016-07-28 14:15:09.435600549 +0200
|
||||
@@ -2497,6 +2497,7 @@ main(int argc, char **argv)
|
||||
dico_log(L_ERR, 0, _("not enough memory"));
|
||||
exit(EX_UNAVAILABLE);
|
||||
}
|
||||
+ idx_page->ipg_header.hdr.phdr_numentries = 0;
|
||||
idx_page->ipg_header.hdr.phdr_text_offset = idx_header.ihdr_pagesize / 2;
|
||||
|
||||
idx_header.ihdr_maxpageref = idx_header.ihdr_pagesize / 2 /
|
Loading…
Reference in New Issue