gnu: arb: Update to 2.10.0.

* gnu/packages/algebra.scm (arb): Update to 2.10.0.
* gnu/packages/patches/arb-ldconfig.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove patch.
master
Andreas Enge 2017-03-03 17:02:12 +01:00
parent 169a438c0f
commit 21abf092a4
No known key found for this signature in database
GPG Key ID: F7D5C9BF765C61E3
3 changed files with 4 additions and 28 deletions

View File

@ -1,6 +1,6 @@
# GNU Guix --- Functional package management for GNU
# Copyright © 2012, 2013, 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
# Copyright © 2013, 2014, 2015, 2016 Andreas Enge <andreas@enge.fr>
# Copyright © 2013, 2014, 2015, 2016, 2017 Andreas Enge <andreas@enge.fr>
# Copyright © 2016 Mathieu Lirzin <mthl@gnu.org>
# Copyright © 2013, 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
# Copyright © 2016 Chris Marusich <cmmarusich@gmail.com>
@ -482,7 +482,6 @@ dist_patch_DATA = \
%D%/packages/patches/alsa-lib-mips-atomic-fix.patch \
%D%/packages/patches/antiword-CVE-2014-8123.patch \
%D%/packages/patches/apr-skip-getservbyname-test.patch \
%D%/packages/patches/arb-ldconfig.patch \
%D%/packages/patches/artanis-fix-Makefile.in.patch \
%D%/packages/patches/ath9k-htc-firmware-binutils.patch \
%D%/packages/patches/ath9k-htc-firmware-gcc.patch \

View File

@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2014, 2015, 2016 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2013, 2015, 2017 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
@ -311,7 +311,7 @@ fast arithmetic.")
(define-public arb
(package
(name "arb")
(version "2.8.1")
(version "2.10.0")
(source (origin
(method url-fetch)
(uri (string-append
@ -320,8 +320,7 @@ fast arithmetic.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
"04hhcpshfkcq9fr4hixbhpps50yf9drk62xgkvlcaj5kb4nyrx7l"))
(patches (search-patches "arb-ldconfig.patch"))))
"0jwcv9ssvi8axb1y7m2h4ykgyl015cl6g28gfl92l4dgnag585ak"))))
(build-system gnu-build-system)
(propagated-inputs
`(("flint" ,flint))) ; flint.h is included by arf.h

View File

@ -1,22 +0,0 @@
diff -u -r arb-2.8.1.orig/configure arb-2.8.1/configure
--- arb-2.8.1.orig/configure 2015-12-31 17:30:01.000000000 +0100
+++ arb-2.8.1/configure 2016-01-20 16:41:41.336726596 +0100
@@ -647,6 +647,7 @@
echo "ARB_SHARED=$SHARED" >> Makefile
echo "ARB_LIB=$ARB_LIB" >> Makefile
echo "ARB_LIBNAME=$ARB_LIBNAME" >> Makefile
+echo "ARB_MAJOR=$ARB_MAJOR" >> Makefile
echo "ARB_SOLIB=$ARB_SOLIB" >> Makefile
echo "EXEEXT=$EXEEXT" >> Makefile
echo "PREFIX=$PREFIX" >> Makefile
diff -u -r arb-2.8.1.orig/Makefile.in arb-2.8.1/Makefile.in
--- arb-2.8.1.orig/Makefile.in 2015-12-31 17:30:01.000000000 +0100
+++ arb-2.8.1/Makefile.in 2016-01-20 16:30:32.575298517 +0100
@@ -101,6 +101,7 @@
$(LDCONFIG) -n "$(CURDIR)"; \
fi
ln -sf "$(ARB_LIB)" "$(ARB_LIBNAME)"; \
+ ln -sf "$(ARB_LIB)" "$(ARB_LIBNAME).$(ARB_MAJOR)"; \
libarb.a: $(OBJS) $(LIB_SOURCES) $(EXT_SOURCES) $(HEADERS) $(EXT_HEADERS) | build build/interfaces
$(AT)$(foreach ext, $(EXTENSIONS), $(foreach dir, $(patsubst $(ext)/%.h, %, $(wildcard $(ext)/*.h)), mkdir -p build/$(dir); BUILD_DIR=$(CURDIR)/build/$(dir); export BUILD_DIR; MOD_DIR=$(dir); export MOD_DIR; $(MAKE) -f $(CURDIR)/Makefile.subdirs -C $(ext)/$(dir) static || exit $$?;))